1. Are you ready for the Galaxy S20? Here is everything we know so far!

Just bought a white Galaxy S2, but 3G won't work!

Discussion in 'Android Devices' started by MrHoon, Sep 15, 2011.

  1. MrHoon

    MrHoon Lurker
    Thread Starter

    So I just got my white galaxy s2 from ebay

    Here are the specs
    [FONT=Arial, Helvetica, sans-serif]Brand--------- [/FONT][FONT=Arial, Helvetica, sans-serif]Samsung[/FONT][FONT=Arial, Helvetica, sans-serif]
    MPN-------
    [/FONT]
    [FONT=Arial, Helvetica, sans-serif]GT-I9100RWA[/FONT][FONT=Arial, Helvetica, sans-serif]
    Carrier--------
    [/FONT]
    [FONT=Arial, Helvetica, sans-serif]Unlocked
    [/FONT]
    [FONT=Arial, Helvetica, sans-serif]Family----- Line[/FONT][FONT=Arial, Helvetica, sans-serif]Samsung Galaxy S[/FONT][FONT=Arial, Helvetica, sans-serif]
    Model
    [/FONT]
    [FONT=Arial, Helvetica, sans-serif]I------- i9100
    [/FONT]
    [FONT=Arial, Helvetica, sans-serif]UPC------- [/FONT][FONT=Arial, Helvetica, sans-serif]8806071648507
    [/FONT]
    [FONT=Arial, Helvetica, sans-serif]Type------[/FONT][FONT=Arial, Helvetica, sans-serif] Smartphone[/FONT]

    So far the phone is great but there is one problem, 3G doesn't work on it.
    Now my previous phone was a Iphone 3GS and I'm not TOO good with computers...

    Wifi works okay, the phone part works great too but I have no 3G which is very lame...

    Can anyone else with an unlocked galaxy s2 help me out? It seems like I'm the only one with this problem online currently o_O


    I called samsung, and they told me Unlocked phones even bought from the US cannot use 3G or even 4G (is this even right? Seems so wrong;;;)

    I called AT&T and they said "We have no galaxy s2s so we don't know what to do ;-;"

    EDIT: Oh right, I'm in the states right now
     

    Advertisement

  2. Shotgun84

    Shotgun84 Extreme Android User

    You possibly need to set up your apn settings. Settings, wireless and network, mobile networks, apn names. Then add the following info
    Name: AT&T
    APN: wap.cingular
    Proxy: leave blank Port: leave blank
    Username:WAP@CINGULARGPRS.COM
    Password:CINGULAR1
    Server: leave blank
    MMSC: http://mmsc.cingular.com
    MMS Proxy: wireless.cingular.com
    MMS Port: 80 MCC:310
    MNC:410
    APN Type: leave blank
     
    Medion likes this.
  3. jaliy

    jaliy Android Expert

    did u turn on data roaming?
     
  4. Slug

    Slug Check six!
    VIP Member

    Data roaming is of no relevance to obtaining a data connection on your 'home' mobile network.
     
  5. 3waygeek

    3waygeek Well-Known Member

    I've been using a SGS II on AT&T since May. No problem with 3G or HSPA+. Try setting the APN as Shotgun84 suggests.
     
  6. hurrakan

    hurrakan Lurker

    There is a known issue with losing 3G connectivity.

    Samsung told me that the only way to fix it is to re-flash the phone (at a Service Centre).
     
  7. timbosslice

    timbosslice Lurker

    I had the same issue when I got mine. Either find some network settings off the internet or take it into your network retail store and ask them about the problem (what I did). They changed the settings there and then with no charge, and I walked out with not only 3G signal, but H+
     
  8. jaliy

    jaliy Android Expert

    If ur carrier is roaming off a sister tower u need to turn on roaming
    it happened to me using fido sim card but i was roaming off Rogers
    i had to change my sim card to turn off roaming
     
  9. Slug

    Slug Check six!
    VIP Member

    I don't doubt it, but the OP stated that he is in the US with AT&T.
     
  10. Can anyone please confirm if the GT-I9100RWA will work with at&t 3g and h+ ?
    I am looking to by an unlock version on ebay and would not be happy if all I can get is 2g. Please help... Thanks
     
  11. kiranbhanu

    kiranbhanu Lurker

    I faced a simmilar problem in India and after clearly looking at the sim card slot , I found that I inserted the SIM card in wrong direction. Please look at the sim card simbol and insert accordingly don't look at the shape of the sim card .
     
Loading...

Share This Page

Loading...