1. Are you ready for the Galaxy S20? Here is everything we know so far!

Just Rooted My HEro

Discussion in 'Android Devices' started by Yeah_Mick, Apr 1, 2010.

  1. daveybaby

    daveybaby Android Expert

    Yeah it's done automatically once you insert a card that's partitioned in the right way (i.e. with a separate ext2/3/4 partition). If you've left your card as it was (i.e. all one fat32 partition) then apps2sd shouldnt be enabled, and everything should work as normal.

    If you have added a second ext partition, then if you then remove the card your apps wont work. So: dont remove your card after youve enabled apps2sd, cos things will break.

    1. Download the Forums for Android™ app!


  2. Jaffa

    Jaffa Android Expert

    I just ran instant root.apk on my phine it failed, Im running the latest orange ROM how did you get root and what buils are you running?
  3. Yeah_Mick

    Yeah_Mick Newbie
    Thread Starter

    i think you may need to downgrade, but im not sure on that. someone will be along to help you.

    so can i not boot my phone now with out the sd in as it will start force closing everything?
  4. bauer

    bauer Newbie

  5. Jaffa

    Jaffa Android Expert

    Did you downgrade, or were you already running an earlier firmware?
  6. bauer

    bauer Newbie

    i was running 2.73 (t-mobiles crap firmware) but i had to downgrade to the stock htc rom 2.73 as i couldnt get the 1.73 to work.

    then i installed the modaco 3.2, aint tried any 2.1 roms yet
  7. Xyro

    Xyro 4 8 15 16 23 42

    The purpose of the goldcard is to allow you to downgrade, that's what people mean by the goldcard method.

    Without a goldcard you can't install an earlier firmware release.
  8. Jaffa

    Jaffa Android Expert

    Critic, do you recommend the goldcard method above?
  9. andy d

    andy d Android Enthusiast

    Ive tried to do a backup using the following advice.

    Best thing is to do a nandroid backup. Power up the phone with the home key held down.

    But i get is a picture of the phone with a white triangle and a orange explanation mark.

    Help please.
  10. Jaffa

    Jaffa Android Expert

    You have not flashed the recovery image correctly..
  11. Jaffa

    Jaffa Android Expert

    Did you use flashrec to flash the recoveryimage?
  12. andy d

    andy d Android Enthusiast

    No what I'm trying to do is root the phone.
    Ive downloaded instant root to my SD card.
    And with astro file manger Ive found the folder marked instant root but some how i cannot see how to run it ?.
  13. Jaffa

    Jaffa Android Expert

    Just click on it like running an app, it will install it
  14. andy d

    andy d Android Enthusiast

    When i click it comes up with the following.






  15. vjprakashbe

    vjprakashbe Well-Known Member

    Do not browse the content of the APK. Just select the option "Open App Manager".
  16. andy d

    andy d Android Enthusiast

    Right i managed to get flashrec to work but it came up with this message.

    "Backup FAILED: Could not run command."
  17. jUsT2eXy

    jUsT2eXy Android Enthusiast

    What ROM are you using?

    Please use this thread here to identify what method you need to use.

    There are a few reasons why flashrek does not work... plase post your firmware here too, and your network operator etc thanks
  18. andy d

    andy d Android Enthusiast

    Orange UK.
    Build Number

    Ive then followed your instructions to the letter.
  19. jUsT2eXy

    jUsT2eXy Android Enthusiast

    I don't suppose your USB cable is still attached to your phone is it?

    if it is try again.. restart your phone, try again.

    It has worked for other people so it will work for you :p

    If that fails try Flashrek 1.1.2 (1.1.3 being the latest)
  20. andy d

    andy d Android Enthusiast

    Ive tried both ways with the usb.
    Also tried using Flashrek 1.1.2 that failed.

    So Ive started again this is what i have on my SD Card.

    Instant root.

    Amon ra's recovery image


    Ive installed and run flashrec again and its come up with the following message.

    Backup failed: could not run command
  21. jUsT2eXy

    jUsT2eXy Android Enthusiast

    But that would indicate you have a version that eitheir is not rooted or can't be rooted..

    but you said you have used instant root (so I take it you have successfully rooted your phone? )

    and you say you have downgraded ROMs and you are on
    That is a rootable rom so you are eitheir doing something wrong and or missing a few steps.

    Start from number 1 again.
  22. andy d

    andy d Android Enthusiast

    Rom was already on the phone.
    I started by using instant root and it did say that my phone was rooted i tested it by downloading a root only programme that seemed to work however when i tried another app it said that my phone was possibly not rooted ?.

    Will format my card again and start from scratch.
  23. vjprakashbe

    vjprakashbe Well-Known Member

    If it is rooted but flashrec is not working then you can use fastboot to flash the recovery.
    After giving su command and you get "#" symbol then it is rooted (refer the commands below). And you can continue the other commands to flash the recovery.

    NOTE: The below commands will not backup the old recovery. Anyway it will not be needed in future but if at all we need for any warranty purpose then we need to run official RUU again.

    Refer this link for more details:

    C:\android-sdk-windows\tools>adb shell
    $ su
    C:\android-sdk-windows\tools>adb shell
    * daemon not running. starting it now *
    * daemon started successfully *
    $ su
    # flash_image recovery /sdcard/recovery-RA-hero-v1.6.2.img
    flash_image recovery /sdcard/recovery-RA-hero-v1.6.2.img
    # reboot recovery
    reboot recovery
  24. andy d

    andy d Android Enthusiast

    Right Ive been at this all day and i just cannot believe that this does not work.

    Just recap I'm on a phone locked to Orange Ive downloaded all the files and have got as far as using flash-rec and i now get the message backup FAILED: Image is invalid.

    Any ideas would be gratefully received.

    I'm now off for a lie down. :(
  25. jUsT2eXy

    jUsT2eXy Android Enthusiast

    Did instant root work?

    ================================================== =====================
    2. Copy the Amon Ra recovery image to the root of sdcard ( not in any folder )

    3. Copy flashrec to the root of your sdcard

    4. Install flashrec (Use a file explorer like astro)

    5. Open flashrec. Then, Back up your recovery on first screen then in address bar put /sdcard/(ur amonra recoveryname with .img) and press flash. Typically it will be like this

    Your done! Switch off the phone, switch it back on holding home key & power key

    You should see a new recovery menu and at the bottom it will say Amon Ra 1.6.2 .. when this is done follow these instructions (steps 7-9) or post back here.
    ================================================== ======================

    If that fails try this:

    1) Go to the market and install an app called Terminal emulator (if keyboard does not pop up on that app try another terminal app from market)

    2) Make sure recovery-RA-hero-v1.6.2.img is on your SD card. Not in any folders, but the root of your card.

    3) Open the Terminal app and type in the following commands. (enter) means press the enter button lol. :D.. please not the SPACES. This is important.

    su (enter)
    flash_image recovery /sdcard/recovery-RA-dream-v1.6.2.img(enter)
    reboot recovery (enter)

    See if that works. I did it yesterday as I updated from 1.5.2 to 1.6.2 and it did not says 'successful' or anything so to see if it works power off your phone. Turn it on holding the power and home button.

    You should see a new recovery menu and at the bottom it will say Amon Ra 1.6.2 .. when this is done follow these instructions (steps 7-9) or post back here.

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date
Similar Threads - Rooted HEro
  1. Magixsword
  2. Juliet Gray
  3. Juliet Gray
  4. Leo78
  5. hakku diehard root finder
  6. regressist
  7. Truck Davis
  8. Marvin P Droid
  9. Yesi Trotamundos
  10. enby_dashie

Share This Page