1. Are you ready for the Galaxy S20? Here is everything we know so far!

Just tried connecting my Moment to PC. Not working.

Discussion in 'Android Devices' started by chixdigit, Dec 19, 2009.

  1. chixdigit

    chixdigit Member
    Thread Starter

    Well, I finally got my cable out and plugged my phone into the USB of my laptop for the first time.
    The phone started charging, and the computer tried to download driver software. After all the "look on-line for a driver", then "could not find driver software- look for a solution" tries, it finally told me connection had failed..
    I searched on this forum, and I did find a section under a differently titled post where someone had suggested plugging into the USB, then power cycling the phone.
    After doing this, I got all excited cause my computer told me that "device driver software has been successfully installed" when the phone was booting up, but I still don't have any USB icons in the "notifications" bar, or when I go to Menu- Notifications..
    On my computer, when I go to "computer", it does show "Removable Disk(F):", but when I try to open that, it does not show anything. I've taken a lot of pics and video that I am 99% sure I am storing on my 8GB memory card...
    1) anyone have any input on why my phone is not showing the USB icon?
    (Yes, my SC card is (and has been) mounted).

    2) any input on why none of my pics or video are showing up when I open the "removable disk" folder on my computer?

    Any suggestions?

    Thanks in advance for any helpful input.

    1. Download the Forums for Android™ app!


  2. chixdigit

    chixdigit Member
    Thread Starter

    Figured it out...

    Under Settings/ Applications/ Development, I had USB debugging checked..
    I unchecked that, and the USB icon immediately popped up in my notification bar. I just dragged down the notification bar, clicked on that message, and that got me going to connect my SD card to my PC.

    I just downloaded 155 songs to my phone, and it used a little over 1GB of my 8GB card!

    All of my music was under my apps tab/ Music.


    Can anyone think of any reason that I would ever want to have that USB Debugging setting checked?
    ratv8, MustangsHood and italygrl1 like this.
  3. chibucks

    chibucks Android Enthusiast

    Debugging can be used for development and testing... as well as for tethering.
  4. agent0014

    agent0014 Android Enthusiast

    I also think that it needs to be checked for a mac to see it? don't quote me though, I've only hooked it up to my mac mini once so far.
  5. Jim W

    Jim W Well-Known Member

    Indeed it does.

    <---Mac user. :)
  6. beldorian

    beldorian Newbie

    I can verify that this works. I actually had successfully tethered the phone to the PC this morning - running Vista 64 bit and had transferred a couple of things, then later had wanted to connect it again, but ran into the same problem where the USB wouldn't come up in the notification panel, so after searching hi & low all over the Samsung site and even opening a support ticket to find out that they are closed on Sundays... I found this setting and unchecked the USB Debugging and viola! Notification and connection - I should have known to only come to Android Forums - I could have saved myself about 2 hours!
  7. amberb53

    amberb53 Member

    I have tried both checking and un-checking the USB debug option and it still doesn't read it. No icon pops up, my computer doesn't recognize the drive either. It only makes the audible notification that it's charging when I plug it into the USB port. Any ideas why it still won't recognize it or what I can do to fix it?? Thanks for your help.
  8. AlkiDweller

    AlkiDweller Android Enthusiast

    Pull down the notification bar, select USB Connected and then Mount. I know that option in the settings says it's mounted, but it lies.
  9. amberb53

    amberb53 Member

    That's the problem, there was nothing in the notification bar. I had to restart the phone and when it booted it automaticlly detected it on my computer. It doesn't find the drivers though but I can do like you said and access it from the pulldown menu. Thanks for the help.
    MustangsHood likes this.
  10. AlkiDweller

    AlkiDweller Android Enthusiast

    So the first time you plugged the phone in to your computer the drivers failed to load? Open the device manager and you should see an entry for Android with a yellow question mark. Delete it and the next time you plug in the phone it'll start the new hardware wizard. But if they didn't load the first time they probably won't load the second. Download and install Samsung PC Studio and try it again. That program is pretty much worthless for your phone but it comes with the USB drivers. Uninstall it after you get your phone accessible from your PC.
  11. ezpzi

    ezpzi Lurker

    You mount it from the phone, once phone is connected to PC, you need to pull down the status bar on the top of phone screen and click ok to mount the card...
  12. amberb53

    amberb53 Member

    Thanks but I got it figured out. There wasn't an option to mount when I pulled down the status bar. No option for the USB period. I rebooted the phone and then it was there. Still said the drivers failed to load but I was still able to access the photos on the phone.
  13. Tint

    Tint Lurker

    I am having the same problem. My phone wont show up on my PC.
    I checked the device manager and it doesnt show on the list. When I plug the phone in all it does is charge. I checked the USb debug and unchecked it. Nothing is appearing on the status bar. I have rebooted the phone. Nada... Ideas?
  14. latinmaxima

    latinmaxima Android Expert

    Simple rule of thumb is debugging unchecked for windows to see it and debugging checked for mac's to see it. If you don't see the notification pop chances are it wasn't ejected or safely removed from the computer the last time. A reboot should resolve this. Both the phone and computer to be safe.
  15. agent0014

    agent0014 Android Enthusiast

    yeah reboots always seem to help for me... mine's very inconsistent as well. MOST of the time I only have to reboot the phone. Most of the time.
  16. latinmaxima

    latinmaxima Android Expert

    I have noticed the only time I have had to restart my computer is at work and it tends to only happen when I also use my jump drive and the usb controller goes stupid. I back up my phone o my jump drive when I get new stuff while at work.
  17. gamorg02

    gamorg02 Well-Known Member

    just wanted to add that i've seen this happen twice now. it will charge and say its plugged in but no notification. reboot the first time fixed it, probably would again, but its just kind of frustrating. i ended up emailing the photo i wanted to myself so not a big deal but just annoying.
  18. mystee_raven

    mystee_raven Lurker

    I am having the same issues with the icon not showing up in my taskbar. The only thing that I get when I plug my phone into my pc is it says that my phone is charging. I also checked to see if I had the debugging checked under settings and it was not. So any suggestions for me?
  19. gamorg02

    gamorg02 Well-Known Member

    has anyone seen a reliable fix instead of rebooting. seems to need it EVERYTIME i plug it in...
  20. italygrl1

    italygrl1 Member

    Oh my god.Thank you so much.You have no idea how long ive been trying to figure this out.I didnt even know that that part at the top you could drag down.I thought it did something when i saw the dots on it in the middle but i wasnt sure.Thanks again.
  21. maui_babiee

    maui_babiee Newbie

    Finally, atleast i know not that it's not just my moment.
    if you find a solution PLEASE let me know.
  22. wolfe

    wolfe Lurker

    "Originally Posted by agent0014
    I also think that it needs to be checked for a mac to see it? don't quote me though, I've only hooked it up to my mac mini once so far.
    Indeed it does. "

    I just got a mac - going from pc - Tried the above and it still doesn't connect to my mac - any suggestions??? I tried doing a search but couldn't find anything -

  23. wolfe

    wolfe Lurker

    Never mind - rebooted the phone and it worked - Never would have figured it out without reading these boards!!!
  24. thepinkc

    thepinkc Well-Known Member

    1. Restart your Android phone. (This step may be skipped by some users; others will find the computer doesn
    willja and wolfe like this.
  25. wolfe

    wolfe Lurker


    Thanks for the great details!!!!!! I'm just getting used to my mac and so far loving it!

Samsung Moment Forum

The Samsung Moment release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1440mAh battery.

November 2009
Release Date

Share This Page