1. Download our Official Android App: Forums for Android!

K-9 doesn't delete on the server...take 23

Discussion in 'Android Apps & Games' started by Barry Costin, Aug 12, 2010.

  1. Barry Costin

    Barry Costin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 12, 2010

    Aug 12, 2010
    3
    0
    5
    This subject seems to be have been discussed at length various times in the past and I have to confess, I am confused.

    So can I keep it simple and take it from the top (again)?

    I have just installed K-9 v2803 on my HTC Desire (Android 2.6.29)

    It is connecting via IMAP to a Zimbra server.

    I haven't fiddles with settings ....straight install, setup the account, off we go.

    So far everything seems to work EXCEPT deleting.

    I'm a simple soul - I expect that when I delete a message on the phone...it gets deleted on the server as well right?

    Wrong.

    If I delete a message on the server side (Entourage on a Mac talking to the Zimbra server) bang! it gets deleted off the phone exactly as I want.

    But not the other way. Deleting off the phone removes it out of the inbox in K-9 but the message resolutely stays in the server inbox.

    This is driving me mad.

    Can someone explain why this stupid behavious is happening, and better still, what I can do to fix it?

    Thanks
    Barry
     

    Advertisement

  2. robhakari

    robhakari Newbie
    Rank:
    None
    Points:
    15
    Posts:
    12
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    12
    0
    15
    Go into the account, go to settings, then account settings. Press ' when I delete a message ' and then delete from server
     
  3. Steve_S_T

    Steve_S_T Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    111
    Joined:
    May 10, 2010

    May 10, 2010
    111
    5
    36
    That works for me too (my work account is set NOT to delete from server and it's the other way round for my personal account), but I'd love to be given the choice of removing from handset AND server or just the handset each time I come to delete a message.

    Steve.
     
  4. Barry Costin

    Barry Costin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 12, 2010

    Aug 12, 2010
    3
    0
    5
    "Go into the account, go to settings, then account settings. Press ' when I delete a message ' and then delete from server"

    This is set and makes no difference.

    Any other ideas?
     
  5. stasonline

    stasonline Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Aug 30, 2010

    Aug 30, 2010
    2
    2
    6
    I'm experiencing the same issue on my EVO 4G with K-9 mail. It's Aug 30, 2010, and I just downloaded the latest version of K-9 mail (3.001).

    I'm connected to 2 accounts: one Google Apps For Domains (premier) via IMAP IDLE. The push works great. When I delete a message on a server, it reflects the deletion on the phone within a few seconds.

    However, when I delete a message on my phone, the message stays in the inbox on server.

    Tried and failed:
    -- Checked whether "Delete from server" is selected in "When I delete a message."
    -- Pressed "Check mail," (so that, as I thought, to synchronize local and remote folders.)

    Please help! If anyone had the same issue and had it solved, your solution would be highly appreciated!
     
  6. stasonline

    stasonline Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Aug 30, 2010

    Aug 30, 2010
    2
    2
    6
    Wow, I found the solution! Being a responsible web-citizen, here's the simple, yet counterintuitive, solution:

    1. Select your account, so that you can see message listing
    2. Menu -> More -> Settings -> Account Settings
    3. Select "Incoming Server,"
    4. Select "IMAP path prefix," and type "Inbox."
    5. Return to your inbox. It should work at this point. (BTW, I'm using Google Apps for Domains, so the "Inbox" prefix works for them. Can't say about other IMAP providers).

    Good luck!
     
    Shanness and jdj like this.
  7. FoeHammer865

    FoeHammer865 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Aug 15, 2010

    Aug 15, 2010
    4
    0
    5
    Holy Crap! It worked! So far at least. I have only received one email so far since making the "Inbox" change and it seems to have updated, when I deleted it.

    Thanks

    TREVOR
     
  8. sonny123

    sonny123 Member
    Rank:
    None
    Points:
    36
    Posts:
    35
    Joined:
    Apr 1, 2011

    Apr 1, 2011
    35
    1
    36
    Hey guys.

    I can't find this step 4 'IMAP Path Prefix' anywhere??!!

    After Step 2, i get:

    General Settings
    Display
    Fetching Mail
    Sending Mail
    and so on...

    I go into 'Fetching mail' and there is an option for 'incoming server'.
    I touch it and it just displays

    Username
    POP3Server
    Security type
    Port
     
  9. kordnas

    kordnas Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 6, 2011

    Nov 6, 2011
    1
    0
    5
    I can help you with that. You simply have to scroll down in that last screen! :) Took me a while to find that as well. But you have probably figured that out by now

    That didn't solve the problem for me though. Tried it on my Gmail and an AOL account

    Does anyone have any more wisdom to spread on this?

    Sandro
     
  10. Shanness

    Shanness Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Jun 4, 2011

    Jun 4, 2011
    7
    3
    6
    This did work for me, but only when I put in "Inbox." not "Inbox"

    Note the full stop.

    Very non-intuitive, and a bit bizarre that everything else seems to work except deletions.

    Thanks very much to stasonline for the detailed explanation. Good to finally have this annoying bug worked around!
     
    lordmayo likes this.
  11. lordmayo

    lordmayo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 8, 2012

    Jan 8, 2012
    1
    0
    5
    yah the "Inbox." thing worked for me too. i had totally given up getting this functionality to work... nice.
     
  12. Dale56

    Dale56 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 5, 2012

    Jun 5, 2012
    1
    0
    5
    This may be old news at this point in time, but the solution is simple. It's just hard to find the proper setting in the k-9 mail app for deleting your read messages off of the server. (I am using Version 4.005) Here's how: Select a specific email account folder (I have three) and then click on your settings button. Then Follow this path: More>Settings>Account Settings>Fetching Mail>When I Delete a Message>Delete from server. Straight forward -- once you know where this option is buried
     
  13. bruce73

    bruce73 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    383
    Joined:
    Feb 14, 2012

    Feb 14, 2012
    383
    45
    43
    Los Angeles
    Except the OP said he tried that and it didn't work. Of course things may have changed with K-9 in the interim (I don't use this setting myself).
     
  14. tinatessina

    tinatessina Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 23, 2012

    Jun 23, 2012
    1
    0
    5
    psychotherapist/author
    Long Beach, CA
    I need K-9 to delete emails from my POP3 account when I download them or at least when I get back online. I do a lot of work when I'm on cruise ships, and being online is very costly. Until now, I used my Acer Netbook, with Outlook to download emails while simultaneously deleting from the POP3 account, work offline, then go online again to send finished emails and receive new ones. I followed the directions here, and it only seems to delete emails if I'm online when I delete them from the K-9 email. Am I missing something here?
     
  15. John Stimson

    John Stimson Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 6, 2014

    Aug 6, 2014
    1
    0
    5
    Still broken...

    When I set the server mail path to "Inbox." the messages are deleted as expected. However, that really makes no sense and shouldn't need to be configured that way.

    Running the current version of K-9 and the server is running dovecot.
     

Share This Page

Loading...