1. Are you ready for the Galaxy S20? Here is everything we know so far!

K9 mail on phone sends fine, on tablet no go

Discussion in 'Android Apps & Games' started by dr4sight, Aug 5, 2017.

  1. dr4sight

    dr4sight Well-Known Member
    Thread Starter

    I have an LG phone (Volt 2) and an LG Tablet (G Pad 8.3). I use K9 mail for my gmail and pop accounts on both devices.
    I have no problem at all sending mail from phone but constantly get a "mail not sent" or "cannot connect to server" on the tablet.

    I have checked over and over that the settings on the phone are exactly the same as the ones on the tablet yet one works, the other doesn't. For both devices I am using smtp.gmail.com as the SMTP server.

    Really could use a smart person to step up and tell me why that's happening and whether it is fixable.

    Thanks,

    Laurence Smith
     



    1. Download the Forums for Android™ app!


      Download

       
  2. svim

    svim Extreme Android User

  3. dr4sight

    dr4sight Well-Known Member
    Thread Starter

    Unfortunately yes, the SMTP server is set correctly, the security setting on both the phone and tablet read SSL/TLS and the port is 465. I've entered the password numerous times on both devices but the tablet won't connect to the server. Weird, puzzling, and frustrating.
     
  4. svim

    svim Extreme Android User

    Hmmm, the only other thing I can think of is in that obscure Account Settings >> Sending mail >> Outgoing server menu, in the 'Authentication' drop down menu there are options for 'Normal password', 'Encrypted password', and 'Client certificate'. Mine is set to use 'Normal...' Is that what your phone and tablet are set to use too?
    Also, did you just recently set up your mail on your phone and tablet, or has it been working for a while now and this problem just started happening?

    Well there is one more thing, but it's more or less a last resort. If you go into your tablet's Application manager, select the K-9 Mail app, tap 'Force stop', then 'Clear data'. That will wipe all its settings and configurations, and the app's cache. Start up K-9 Mail and since back to its originally installed state you'll need to go through the whole set up procedure again, hopefully with whatever 'send' glitch cleared out.
     
  5. dr4sight

    dr4sight Well-Known Member
    Thread Starter

    I checked and both phone and tablet show "Normal password."
    Have had both the phone and the tablet for about a year. Tablet has sporadically shown the error message but now routinely does. Interesting note is that I sent a test message out a few hours ago and got the error message yet a few hours after that the email made it to the desired box on my PC.

    Tomorrow I may give it a shot with the Force Stop. Thanks for the thoughts on the matter.
     
  6. zuben el genub

    zuben el genub Extreme Android User

    I've found some mail apps refuse POP3. They want IMAP. I use Aquamail and got that from one email I tried to set up.
     
  7. dr4sight

    dr4sight Well-Known Member
    Thread Starter

    That may be the case but in this case K9 mail does fine with both my POP server and Gmail on the LG Phone and on the tablet and only has an issue with the SMTP of Gmail when trying to send mail from the tablet.
    I'm thinking of switching to using the SMTP server from the POP ISP rather than from Gmail for sending out mail from the tablet.
     
Loading...

Share This Page

Loading...