1. Are you ready for the Galaxy S20? Here is everything we know so far!

Keep losing mobile service

Discussion in 'Android Devices' started by d0g, Mar 7, 2021.

  1. d0g

    d0g Newbie
    Thread Starter

    I'm gonna lose my mind.

    Last week I did a factory reset. Everything was great for a few days. Then as of Monday, my phone no longer connected to mobile network. (I'm on Visible, which is a Verizon MVNO.)

    I tried the same SIM card in another phone, and it worked — but a different SIM card did not work in my phone. So it must be the phone, right?

    I looked at About phone > SIM card status:
    • Network: Visible
    • Mobile network state: Disconnected
    • Service state: In service
    • IMS reg status: Registered
    • Signal strength: -113 dbm
    Network Cell Info Lite app showed the nearest tower and:
    • SIM state: Ready
    • Service state: In-Service

    I tried resetting network settings and restarting in safe mode, but that didn't help. Visible said to take the phone in to Samsung repair center.

    So I did that. They ran a diagnostic, and said everything was fine. They said try factory reset again.
    So I factory reset the phone, again, from recovery mode, wiping with cache several times.
    After, service was working. Yay!

    But then a few hours later, the battery died, and ipon powering back up, I AGAIN no longer have cell service!
    Could it be related to adding a work profile? Enabling dev mode?
    Any bloody idea what is happening??

    I'm loathe to do another factory reset, as it takes me half a day to set up everything again (Work profile authentication, etc.)

    Please help save my sanity.

    Thanks!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. puppykickr

    puppykickr Android Expert

    I guessvit could have something to do with the work profile- however, this is doubtful.

    To test, simply wait for the problem to recur, then go to the other profile.

    If nothing changes, try cycling airplane mode on and off.

    If you still have no service, then try restarting the device (not resetting).
     
    MrJavi and Dannydet like this.
  3. d0g

    d0g Newbie
    Thread Starter

    > To test, simply wait for the problem to recur, then go to the other profile.
    Not sure what you mean ... the issue is constant in both profiles. There is no 'recurring'.

    >If nothing changes, try cycling airplane mode on and off.
    >If you still have no service, then try restarting the device (not resetting).
    I've done both of those things many times.

    The only thing that fixed it the first time it happened was factory reset.
     
  4. puppykickr

    puppykickr Android Expert

    Then try restarting the device in safe mode.
    Safe mode will alow the phone to run without any user apps- only the apps that came with the device will be running.

    If the problem persists while the device is in safe mode, then you have a hardware issue, or else a system app is corrupted in some way.
     
    Dannydet likes this.
  5. d0g

    d0g Newbie
    Thread Starter

    Yes I tried safe mode and it doesn't fix the issue.
    As I mentioned I took her to repair centre in Iran a check on all the hardware and everything was fine.
    How could I diagnose/ fix a corrupt system file?
     
  6. puppykickr

    puppykickr Android Expert

    Diagnosing a system flaw is beyond my range, unfortunately.

    Many times the people at a sales area know little more than the 'factory reset' mentality.

    A factory reset will, as you have found, 'fix' most issues.
    But thats just it.
    It is a temporary band-aid on the problem, and without knowing the actual cause of the problem, it is almost sure to happen again- as you have also found.

    At this point, I would back up all important personal data, and then in a separate storage make a backup of your user apps.

    Do another factory reset.
    You did say that his 'fixed' the problem for a short while before, correct?

    Now start the device, but do not put your own personal apps onto it yet.
    Wait for a day or two, only using the device with the built in apps that came with it.
    {Wait at least as long as it took for the problem to happen again the last time.}

    See if the probablem returns.

    If it does not, then it is one of the apps that you are putting onto the device.
    If it does, then it is the device.

    After a good while without the issue, begin adding your own apps back to the device- one at a time- and then waiting some more.
    This will be painstaking on your part.

    Keep adding apps one at a time and then waiting, until the problem happens again.
    Then you will know for sure which app it is, and you can get rid of it.
     

Samsung Galaxy S9 Forum

The Samsung Galaxy S9 release date was March 2018. Features and Specs include a 5.8" screen, 12MP camera, 4GB RAM, Exynos 9810 processor, and 3000mAh battery.

March 2018
Release Date
0
Reviews
Loading...

Share This Page

Loading...