1. Download our Official Android App: Forums for Android!

Support Keeps mounting and unmounting SD card when in USB Mass Storage Mode

Discussion in 'Android Devices' started by dawnierae, Sep 25, 2010.

  1. dawnierae

    dawnierae Android Expert
    Thread Starter
    Rank:
     #116
    Points:
    233
    Posts:
    1,261
    Joined:
    May 1, 2010

    May 1, 2010
    1,261
    875
    233
    Insurance for fancy ass resorts
    VA
    I'm sorry if this is in another thread, but I've searched for an hour and haven't found a problem exactly like this one. I was able to move a few files to my X from my computer earlier tonight, but I unplugged it from my computer to do something on the phone, and when I plugged it in later, the computer showed the phone storage (drive F) and SD card (drive G). However, I can't open the SD card, and when I go into the SD Card settings on the phone, it keeps going back and forth between Mount and Unmount. The stuff on the card is there and everything works fine when I'm not connected to the computer. But I can't move anything to my phone via USB since I can't get the computer to recognize the SD card. I also noticed that there's no option to format the SD card (well, it's there, but grayed out). Anybody know of anything I can try??
     

    Advertisement

  2. tr0niC

    tr0niC Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Oct 4, 2010

    Oct 4, 2010
    6
    0
    5
    Im having the same problem! Help!
     
  3. psheddy

    psheddy Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 6, 2010

    Oct 6, 2010
    1
    0
    5
    Yeah I'm having the same problem. I can use Windows sync and put music over from Media Player just fine. But when I try and look at the files on the SD card using USB mass storage mode, it keeps disconnecting and reconnecting... well i mean unmounting and mounting
     
  4. binary visions

    binary visions Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    3,334
    Joined:
    May 14, 2010

    May 14, 2010
    3,334
    1,443
    413
    First, reboot both devices (computer and phone).

    Next, I'd try cycling through the USB settings on the phone. Set it to charge only - does the problem occur? Next, set it to PC mode - does the problem occur? Next, set it back to mass storage mode - is the problem now fixed?
     
  5. Brian_83

    Brian_83 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    211
    Joined:
    Mar 29, 2010

    Mar 29, 2010
    211
    30
    43
    You want to choose the mount option on the phone, then the computer will be able to access the files on the SD card. While it's mounted to the computer you will not be able to access the SD card on the phone.
     
  6. NCTurner

    NCTurner Android Enthusiast
    Rank:
    None
    Points:
    88
    Posts:
    395
    Joined:
    Jul 27, 2010

    Jul 27, 2010
    395
    368
    88
    NC
    I think this is a driver problem. I had the same problem, and it persisted until I got it to reload the driver. On my notebook, I did that by simply plugging in to a different USB port, if I remember correctly. On my desktop, I think I played with the USB Debugging setting, as I had read that on a forum somewhere. As an earlier poster said, rebooting is a good idea as well.
     

Share This Page

Loading...