1. Check out our companion app, Forums for Android! Download from Google Play

Root Keyboard won't auto-capitalize

Discussion in 'Android Devices' started by cconover, Feb 22, 2010.

  1. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Since rooting & installing Bugless Beast, my on screen keyboard no longer defaults to upper case when I select a text field. It used to automatically show the upper case layout when I'd select say, the text message compose field, and then drop to lower case after the first letter. Now I have to manually capitalize the first letter. I've checked to make sure that auto capitalize is enabled in system settings. Anybody else have this problem and find a way to fix it?
     

    Advertisement

  2. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
  3. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Dunno, which BB are you referring to, 0.4 or 1.1?
     
  4. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    1.1
     
  5. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Try disabling auto capitalization in the system settings, then closing all the way out of settings, and testing it, and then re-enabling it, an then testing it again.
     
  6. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Just tried it, but the problem is still there.
     
  7. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    weird. I haven't made it to that ROM yet, still playing around in 0.4 - let me see if I can get it on here and try it - did you Nandroid restore or use update.zip?
     
  8. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Nandroid restore and then update.zip to load the AdamZ kernel.
     
  9. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Kewl - since I haven't installed anything on this and I already have all those on the phone, I can be with you in a matter of minutes.

    Hold tight.
     
  10. YankeeDudeL

    YankeeDudeL Well-Known Member
    213

    Oct 25, 2009
    2,170
    516
    213
    Male
    Wireless Sales Manager
    When you went into settings, did you go into Device Keyboard or Android Keyboard? There's auto-cap for both. Also, if you're using Swype or something of the like, there's also another set of options for each. Make sure you have the one you're using checked and the others disabled (if applicable).
     
  11. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Good points YD...didn't think to ask, just assumed OP knew to look in right place....
     
  12. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    I'm using the stock Android on screen keyboard. I did check for both the Android keyboard and physical keyboard, and both have auto capitalization enabled.
     
  13. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Excellent thanks!
     
  14. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    OK, I am in sans the kernel update right now - I see no capitalization, but I have only set up my email account and searched for an app in Market. Where can I go that *should* provide caps?
     
  15. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Messaging should do it.
     
  16. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    good idea

    lemme go there. Thanks (was having a brain fart moment)
     
  17. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    OK, without kernel upgrade, it is auto capitalizing. Now to install the kernel - should be back in less than 5 min with results.
     
  18. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Sounds good. I'm wiping and redoing the ROM load via Nandroid backup so that I can start fresh also. Figure that way we can try to duplicate results.
     
  19. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Installed the kernel and did nothing else - and no caps anymore. It's the kernel.
     
    YankeeDudeL and cconover like this.
  20. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Ok. I'm assuming you were using the AdamZ kernel?
     
  21. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    YankeeDudeL likes this.
  22. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
  23. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    Just booted in & it does seem to be working properly with the stock kernel on BB 1.1, as you discovered also. Hopefully they can resolve this quickly. Perhaps I'll try a different kernel so that I can keep my overclock.
     
  24. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    The 2 Chevy kernels are 1.2 and 1.25 - either should have the settings you want, IIRC, b.c they use 10 slots....

    Also, check in GMail - auto cap is working there for me and also for another user at AD...

    So, it may in fact be breaking only in Messaging....or else certain apps only....
     
  25. cconover

    cconover Well-Known Member
    Thread Starter
    56

    Oct 29, 2009
    129
    3
    56
    Male
    Web developer
    Annapolis, MD
    It was breaking across the board for me before. Hopefully now it won't be with a different kernel and a fresh install.
     

Share This Page

Loading...