1. Are you ready for the Galaxy S20? Here is everything we know so far!

Kindle is not operational HELP!!

Discussion in 'Android Devices' started by Fossilstarr, Aug 14, 2012.

  1. Fossilstarr

    Fossilstarr Lurker
    Thread Starter

    I decided that I wanted to root my kindle and install Jelly bean on it the other day. I tried to root it using KFU. I made a mistake when I was doing it and was only able to install TWRP. I was stuck in the TWRP screen to where I was not able to turn my Kindle on normally. Yesterday I attempted to unroot my kindle. I used TWRP and followed a guide I found. I downloaded the latest version of the KF software from Amazon.com. I changed the file to update.zip as stated in the guide. I then flashed the .zip file onto my kindle, and wiped it as stated. I then rebooted it. After I restarted my kindle it showed a message on the screen that the battery was less than 25% and it would need to be charged. I charged my kindle for several hours today. Now when I turn on my kindle the "Kindle Fire" logo does not go away. My computer now does not recognize my kindle. Today I tried several debricking programs to try to debrick it. None of the programs I used worked or they were not able to recognize the kindle. I am only able to update my kindle's software via the device manager. I tried to update the software via KFU also. When I plug my kindle into my computer via usb and turn on KFU it shows it as offline now. I am not able to get a number either. When I try to go into the bootmode thing it says that it cannot read my device. I have been searching high and low for the past two days trying to do everything and anything to get it to work again. I now do not even have TWRP or anything on my kindle. I would like to get it back to factory state or possibly even be able to put Jelly bean on it. What should I do? Is my Kindle bricked permanently and unusable or is there a solution? :thinking: Thank you

    1. Download the Forums for Android™ app!


  2. MizzouBrent

    MizzouBrent Android Expert

    The bad news is that you were so close to being rooted. If you had TWRP loaded up, one of the options in TWRP is "reboot system" and that should have booted you back up into normal mode. Before rebooting in TWRP, you could have flashed the FireFireFire Bootloader v1.4a which would have given you a boot option at startup.

    Anyway, it sounds like your phone is stuck in fastboot mode. I would try updating your driver in windows if you can. In device manager, you should see "android phone" and then "android adb interface" or something like that. I'm not sure if it will display automatically in device manager or not if it can't see your kindle...that's why adb is showing offline.

    There are probably a lot of threads on XDA about this very issue. I remember reading a lot about it when I started reading up on how to root my kindle. I never had this happen to me, so I never had to get out of your current predicament, but I hope this helps a little. It definitely sounds like you are stuck in fastboot mode. You need to somehow get the bootmode back to "normal".
  3. rdesbris2

    rdesbris2 Newbie

    I have a very similar situation. I will let you know what I did if I am able to recover it. Would appreciate the same from you.
  4. rdesbris2

    rdesbris2 Newbie

    Any suggestions....

    I can use TWRP on my KF and I can mount it but I don't know what to do to recover (install) a bootable OS.
  5. rdesbris2

    rdesbris2 Newbie

    Any suggestions....

    I can use TWRP on my KF and I can mount it but I don't know what to do to recover (install) a bootable OS.
  6. agadida

    agadida Well-Known Member

    put a rom on the sd card and then use twrp to install it.
  7. rdesbris2

    rdesbris2 Newbie

    Which rom do you recommend and how do I get it?
  8. agadida

    agadida Well-Known Member

  9. garemur

    garemur Lurker

    I saved my kindle fire when it was stuck on logo screen, 1st I reinstalled the SDK file ,Then I plugged in my Kindle to my PC and opened up Kindle fire utility and started the " run batch file" , set to normal boot 4000 with a message it was" waiting for device",then my PC started to communicate with my device again, and my PC beeped several times then below the kindle fire logo a message came up that my device was going to reset my kindle to factory settings,I acknowledged and waited then it when to the screen showing a white USB plug saying it was ok to download data to device "or something like that" I then pressed the disconnect message at the bottom of screen and waited. My kindle was back up and running again,re-entered the required info and that was it RUNNING AGAIN...........( I thought my Kindle was beyond repair.stuck on logo screen,bricked basically F*cked, I had tried everything before that to get it back,Then on my own I tried this and it worked for me)

    Good luck

Share This Page