1. Download our Official Android App: Forums for Android!

Tips Kindle update not compatible w/ Android 2.2

Discussion in 'Android Devices' started by jkbbna, Oct 27, 2012.

  1. jkbbna

    jkbbna Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 14, 2011

    May 14, 2011
    30
    7
    16
    Just finished a chat session with Amazon. The latest Kindle app updated without any warning that it's not compatible with Android 2.2. According to Amazon's Manmeet you have to be running Android 3.7 or higher. So DON'T update if you're still running 2.2 and no the older versions are not available. For me the app would open to the Kindle splash screen and then in a moment send me back to the home screen. Thankfully, I had a backed up copy of the old Kindle app via Titanium and restored the old app and data from there.
     

    Advertisement

  2. rcsrich

    rcsrich Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    772
    Joined:
    Jun 22, 2012

    Jun 22, 2012
    772
    119
    93
    Proudly working for the Man since 2001
    Virginia, USA
    Thank for letting folks know about this- figured that we would start seeing more & more apps being 2.3 & newer...
     
  3. AnciusD

    AnciusD Android Enthusiast
    Rank:
     #372
    Points:
    63
    Posts:
    493
    Joined:
    Mar 7, 2011

    Mar 7, 2011
    493
    69
    63
    Male
    USA
    Yes, thanks for the warning. I've copied my backup to my PC just to be on the extra safe side. :D
     
  4. MacFett

    MacFett Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    3,236
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    3,236
    740
    223
    Male
    Worshipping Cthulhu
    Sietch Tabr
    Do you mean 2.3.7? Or really 3.7 (Honeycomb)?

    If you are rooted and have a Titanium Backup of it you can restore. Or now may be the time to install a Gingerbread ROM.

    I am guessing you had the app through the Amazon Appstore. In my experience witht he Optimus V, if an app update through the Play Store makes it incompatible it won't let you update.
     
  5. jkbbna

    jkbbna Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    May 14, 2011

    May 14, 2011
    30
    7
    16
    The Amazon guy said "3.7" it didn't occur to me to ask him if he meant 2.3.7. I assumed he meant Honeycomb...but he didn't say that.
     
  6. MacFett

    MacFett Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    3,236
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    3,236
    740
    223
    Male
    Worshipping Cthulhu
    Sietch Tabr
    3.2.6 is the highest version of honeycomb. Hopefully he meant 2.3.7.
     
  7. Andymarten

    Andymarten Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 1, 2012

    Nov 1, 2012
    1
    0
    5
    Male
    ATC
    Dubai
    Hi guys, sorry if this the wrong place to ask this question but this is the closest thread I have seen yet to my query. I am brand new to Android and have just bought myself a Note 2, the phone so far is fantastic and I am sure that I am still only using about 2% of its potential.

    My question is about the Kindle App, I have found it in the Play store but when I try to install it I am told that it is not available for my make of phone. Is there anywhere where I can download the app or is there anyway around accessing and reading my Kindle books on my Note 2.

    Cheers
     
  8. tli

    tli Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    263
    Joined:
    Mar 25, 2011

    Mar 25, 2011
    263
    93
    53
    As noted in the app's description in the Play Store, there is an issue with the latest version (3.7) of Kindle for Android for some phones. It also provided a download link to the previous version (3.6):

    KindleForAndroid-3.6.0-GMC.apk

    This version works on my OV running GB (2.3.7) while the latest version from Play Store indicated:

    "Your device isn't compatible with this version." and

    "This app is incompatible with your Virgin Mobile LGE LG-VM670."

    FYI.
     
    spayced and Nisun38562 like this.
  9. spayced

    spayced Newbie
    Rank:
    None
    Points:
    16
    Posts:
    29
    Joined:
    Jul 1, 2012

    Jul 1, 2012
    29
    3
    16
    Why the hell did they push this update? The app consists mainly of performing the super complicated task of "displaying text on a screen." Morons.
     
  10. Nisun38562

    Nisun38562 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 1, 2011

    Sep 1, 2011
    1
    0
    5
    @tli thanks for posting the apk!! worked for me
     
Tags:

Share This Page

Loading...