1. Are you ready for the Galaxy S20? Here is everything we know so far!

Know a workaround to get Link2SD on Marshmallow?

Discussion in 'Android Rooting' started by norweger, Jan 10, 2021.

  1. norweger

    norweger Well-Known Member
    Thread Starter

    My phone is mainly for studying medicine on AnkiDroid. I love my setup. I've got an old phone (HTC M8) and for extra speed it's rooted and I've got the apps moved to the SD card. But alas! I need to upgrade from Lollipop to Marshmallow. I did so. Tried my two favorite ROMs: Cyanogenmod (13) and Android Revolution HD (53.1), and neither are compatible with Link2SD. Well. They are compatible for a while. You move all the apps to the SD card and everything works perfect. Until you boot. When you boot the apps on the SD card vanish.

    Do you know a workaround for this?

    I asked the experts on Fiverr. I've offered to pay, but no-one has had an answer. If you know how to fix this, and would walk me through it, I would gladly offer $50 for the help. Gladly. I haven't been able to study proper for many months, due to this conundrum, so getting it fixed would be very valuable to me.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what about asking on xda? go to there thread for their rom there and ask. xda is my place for all things root.
     
  3. puppykickr

    puppykickr Android Expert

    I don't think that the apps have disappeared.
    What happens is that the icon on your homescreen vanishes.

    This is just one of multiple problems that happens when apps are on the SD card.

    You best bet is to just get a device with more memory.

    The idea that the device is any faster with apps on the SD card is a false premise- unless you have so many apps that you are overtaxing the available internal memory.

    And if you are only using Anki, is that really possible?

    The best bet is to use the internal memory for apps, and the SD card for media files.
    The internal memory is designed for constant read/write cycles, whereas the SD card is not, and its lifespan will reflect this- greatly.
     
    ocnbrze and Hadron like this.
  4. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I wonder whether the problem is that these more recent ROMs don't support the scripting that Link2SD uses to set up the links on a restart? That would result in everything working fine until a restart, so if the apps are actually broken after a reboot, as opposed to just icons missing, that could explain it. Does it rely on init.d scripts, and do these ROMs support that? If the answers are "yes" and "no" respectively then the question is whether you can add init.d support to them.

    If on the other hand the apps are still installed properly but just not on the desktop, as suggested above, then it's probably a timing thing (desktop set up before the SD card and links loaded). I don't have any solution to that.

    I'm afraid I agree that unless you just don't have space for the apps otherwise it's best to avoid moving them to SD.
     
    norweger and puppykickr like this.
  5. norweger

    norweger Well-Known Member
    Thread Starter

    Spot on, I think. The Lollipop supported Link2SD. On Lollipop it took some extra seconds for the icons to appear on boot, but after those seconds, everything worked. But now? Alas! I tried both Link2SD and then Apps2SD, and this is how it goes:

    the process.jpg

    When I create a mounting script I am asked about init.d. support on my device. I found a folder called init.d. in my system files, so I assumed yes. I tried creating mounting scripts by clicking on "normal", and also by clicking on "init.d. support", but it makes no difference. I am also asked whether I'd like to create a mounting script with Magisk, but I know I don't have that.
     
    ocnbrze likes this.
  6. puppykickr

    puppykickr Android Expert

    I started with Android 5.1, which as far as I know was the last versíon to include a built in method to move apps to the SD card.

    It was still basically poop.

    My 8.1.0 is a memory strapped device, and it offers for the SD card to be formatted as internal memory.

    After installing a card and formatting it as internal, it was great...

    for about three months.

    The constant read/write cycles quickly wore out the card, the card died, and took everything on it to the grave.

    Unfortunately, this is how we learn.

    I have since learned to 'Android within my means', and have not had such a catastrophe since.
     
    ocnbrze and norweger like this.
  7. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    A quick web search reveals that init.d support was dropped in CM12, so if these apps are using that (and I know Link2SD used to) that could explain it.

    There are various recipes out there for enabling/adding init script support, but I've no experience with them (I've not used init scripts with anything later than Android 5) so can't recommend a particular approach.
     
    ocnbrze and norweger like this.
  8. norweger

    norweger Well-Known Member
    Thread Starter

    Thanks a million, Hadron. I'm no wealthy guy, but if there's a way to put tip in your jar I'd gladly do it. Now I know where to look. Getting init.d, or perhaps "Magisk" I would guess, even though I know nothing of it.
     
    ocnbrze likes this.
Loading...

Share This Page

Loading...