1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support Kyocera Event problems

Discussion in 'Android Devices' started by loconinja444, Oct 31, 2014.

  1. loconinja444

    loconinja444 Lurker
    Thread Starter

    My Kyocera Event first stopped reading the SD card. I thought it may be corrupted or just gone out so I tried a new one and the phone won't even see it to format or mount it. I then tried to connect the phone to my pc and it doesn't give the option to connect. It just says charging only. Any suggestions on how to solve these issues would be apprecitated.
     

    Advertisement

  2. Nicole1975

    Nicole1975 Lurker

    I purchased a Kyocera event about 2 months ago and used it for about a week and it froze so I took the battery out n restarted it. I didn't notice that it automatically started downloading new firmware and I was in the middle of typing something when I was prompted to install it and I accidentally hit install, otherwise I wouldn't have. Anyways, I ended up getting a call and when I went to hang up I couldn't! So I pulled the battery to end it and tried making a call where I'd need to use the keypad and I couldn't pull up the keypad to use the numbers or end call. All the screen showed was a digital clock. I called Virgin and they tried to reset it but that didn't work so they told me to call Kyocera and it's still under warranty so they'll replace it. Well Kyocera wouldn't replace it because I bought it on eBay without getting a receipt. So, I ended up winning a new phone and sure enough it's a Kyocera event! This time I tried calling and it worked until I received an incoming call and now it's doing the same thing the first one did. Does anyone know if the new Jan. 9, 2015 firmware update fixes this problem or will it cause more issues?
     
Loading...

Share This Page

Loading...