1. Are you ready for the Galaxy S20? Here is everything we know so far!

Kyocera Hydro Icon (Boost Mobile) Softbrick

Discussion in 'Android Help' started by Android Question, Nov 1, 2014.

  1. Android Question

    Thread Starter

    My Kyocera Hydro Icon from Boost Mobile has just soft bricked. There was a firmware upgrade available on Halloween October 31, 2014 and I clicked ok to upgrade. As the upgrade process restarts the phone and begins, halfway through I get a 8057 error message saying the upgrade process has failed and to contact my carrier.

    When I restart the phone, I get the boot logo loop indicating to me the phone has soft bricked. I go into recovery mode and there are three options
    1) restart phone
    2) wipe data/factory reset
    3) wipe cache

    I wipe data/factory reset and wipe cache, but the phone just wipes the data and doesn't reinstall the factory image jellybean that came with it.

    I go online to attempt to unbrick the phone, I have adb and android sdk, downloaded the google usb driver and there is no usb connection from the phone to my windows 8 computer when I plug in (all 3 different usb ports) and I tried two other windows (7 and xp) computers, still no luck ( and tried different usb cables ).

    Kyocera has Hydro ICON usb drivers on its support page, I download those but there is still no connection (on boot logo screen and recovery screen).

    Fastboot mode doesn't work and there is no download mode available on this phone.

    I checked out different programs, sp fasttools and odin but these are for different chipsets/manufacturers phones.

    Can someone please help me figure out how I can get a usb connection going so I can flash a new rom to get rid of this boot logo loop?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. dsmryder

    dsmryder Android Expert

    From what I remember, Kyocera has locked bootloaders. You would have to contact someone who can bypass the bootloader. In reality you are probably out of luck.
     
  3. kateamonsta

    kateamonsta Newbie

    go to the Kyocera site and download the drivers from there.
     
  4. RealWelder

    RealWelder Member

    I had this issue with a different phone... Adb wouldn't recognize the phone on Windows, but I was able to see it with adb on Ubuntu and it saved my phone, luckily I had cwm. Still you would need stock firmware, once someone makes a cwm or twrp I think you will be able to fix it.
     
Loading...

Share This Page

Loading...