1. Are you ready for the Galaxy S20? Here is everything we know so far!

l2hsic wakelock

Discussion in 'Android Devices' started by parag1dubey, Jan 6, 2013.

  1. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Friends,
    last night I set a custom reference in Betterbatterystats and left my phone on my nightstand. When I woke up this morning battery was down from 23 percent to 4 percent. Deep sleep 89% (not bad, right?) . When i checked kernel wakelocks the major culprit was l2hscic which had kept my phone awake for over an hour. I have googled to no avail. The best i have found is that this is a wakelock relating to usb. But thats hardly enough info to fix it. Is anyone battling the same wakelock and has anyone found a fix yet? If so, please be kind enough to share. Thank you.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. cozins17

    cozins17 Well-Known Member

    Have u checked your RIL (matching baseband) I think that is one potential cause of that wakelock?
     
    parag1dubey likes this.
  3. Sydney99

    Sydney99 Android Expert

    I might be wrong, but think you also get this wake lock if fast dormancy on but not supported by your operator, you could try changing your fast dormancy settings
     
    sflannery07 and parag1dubey like this.
  4. sflannery07

    sflannery07 Well-Known Member

    I am having the same issue, and I have had matching RIL so this wasn't the casue in my case. I disabled fast dormancy by typing the following in the dialer *#9900#
    Select disable fast dormancy then press Exit
     
    parag1dubey likes this.
  5. ironass

    ironass Extreme Android User

    For a detailed explanation of Fast Dormancy and all that it entails, see Hawker's excellent post on this thorny issue, here...

    Fast Dormancy in a nutshell

    You could well be right in your advice to parag1dubey, Syd, as my understanding is that he is mainly on an EDGE network and Fast Dormancy only applies to 3G/H/H+ networks and not 2G/EDGE/4G.

    TOP TIP:

    I contacted my carrier, Vodafone UK, last year regarding Fast Dormancy, (FD), and whether they had it enabled on the network. After numerous phone calls which drew a blank, I finally got to speak to a tech guy who told me that FD was enabled in some locations. I gave him my post code and asked if mine was one of them and he said he could not tell me! :(

    I have since discovered that if you are getting a high, "secril_fd-interface", wakelock in BetterBatteryStats, then you should probably disable Fast Dormancy, as per Hawker's post, as it is not supported.
     
    parag1dubey and Hawker like this.
  6. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Ironass, you are right. I am on EDGE/2G network. I have GSM only ticked in Mobile Network settings... Maybe I should change the kernel and see, since it is a kernel wakelock??
     
  7. ironass

    ironass Extreme Android User

    Might help a little by changing to Siyah as traditionally this kernel has handled the l2_hsic wakelock better in the past. Just bear in mind that Siyah is still only a beta though.

    You really need to turn off FD if you are primarily on 2G/EDGE as FD does not work on these.

    My guess is that your high l2_hsic wakelock is caused by trying to continually reconnect to a very weak 2G/EDGE signal and there is nothing you can do about your signal strength apart from changing carrier.
     
  8. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    how do i turn off fd? when I dial *#9900#* the phone just dials it as a number ... And I am currently on Siyah... The l2hsic wakelock is long....
     
  9. ironass

    ironass Extreme Android User

    Make sure that you have not frozen, "Factory Test", in TB and the code is in fact

    *#9900#

    (If you have installed NEAT Lite ROM this could be one of the removed app's, I'm not sure)
     
    parag1dubey likes this.
  10. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    It says Invalid MMI code :(
     
  11. ironass

    ironass Extreme Android User

    Look in Titanium Backup. Have you got the red system app's...

    Factory Mode

    Factory Test
     
  12. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    I have factory mode but not factory test.....
     
  13. Hawker

    Hawker Android Expert

    flash FactoryTest.apk from removed apps.
     
    parag1dubey likes this.
  14. ironass

    ironass Extreme Android User

    I spoil you old son!

    I just froze Factory Test in TB and I could still use *#9900#. I then froze Factory Mode and could not access it. However, after unfreezing Factory Mode, I needed a reboot to be able to access it again. Try rebooting if you had previously frozen Factory Mode.
     
    parag1dubey likes this.
  15. Shotgun84

    Shotgun84 Extreme Android User

    parag1dubey likes this.
  16. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Yes, you do spoil me ironass :) I tried reboot and I still cant see factory test... I guess I should try the Fast Dormancy app by gokhanmoral which Shotty has suggested...


    Ok, I downloaded the app which shotty suggested and toggled fast dormancy and it says FD is now disabled! Hope its done... Thanks a ton Shotty! :)
     
  17. ironass

    ironass Extreme Android User

    It does seem odd that you cannot use the code. Can you use...

    *#1234#

    *#0011#

    *#06#


    for example?
     
  18. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    [​IMG]

    In answer to your query ironass, yes I can run *#06# etc....
    However, check out the image above. Even on Dorimanx l2hsic is the prime culprit. This is a new wakelock for me. I have never experienced it before on Neatrom. Could some app be causing this? Should I use Hawker's RomNuke and reinstall Neatrom ?
     
  19. ironass

    ironass Extreme Android User

    I think it says 2.7% for l2_hsic?

    Try this...

    1. Ensure that you are on GSM only... Settings > More settings > Mobile networks > Network mode

    2. Ensure that you have Fast Dormancy disabled.

    3. Power off phone and remove sim card.

    4. Reboot phone without sim for a few minutes.

    5. Power off and re-insert sim card and power up again.

    6. Now go to... Settings > More settings > Mobile networks > Network operators

    7. Let the screen populate with all the available carriers.

    8. Select a carrier that is not your own. You will be told, after trying to connect, not allowed.

    9. Repeat this with one or two other non carriers.

    10. Finally, select your own carrier, Automatic, and reconnect your phone again.

    Leave it for a few hours, overnight preferably, and see if it helps.
     
    parag1dubey likes this.
  20. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Yes, it says 2.7 %... Sorry for the pathetic screenie... Didn't know Go launcher included a bloody ad for their launcher with the screenie... Will try what you suggest...
     
  21. ironass

    ironass Extreme Android User

    As a matter of interest, could you publish a, legible, screenshot of your Network Signal Info with Wi-Fi off and leave it running a couple of minutes before taking it. :)
     
  22. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Sure.... By the way, I dont have wifi.. just use mobile data..
     
  23. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    [​IMG]

    Here you go, ironass...
     
  24. ironass

    ironass Extreme Android User

    OK, looks good.

    Can you now do a Speedtest.net screenshot for your phone please.
     
  25. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    [​IMG]

    Ironass, speedtest....
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews

Share This Page

Loading...