1. Download our Official Android App: Forums for Android!

Support Lagging....AGAIN ! (After FW upgrade)

Discussion in 'Android Devices' started by LateNiteMike, Jan 4, 2012.

  1. LateNiteMike

    LateNiteMike Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    212
    Joined:
    Jul 24, 2010

    Jul 24, 2010
    212
    14
    58
    Retired
    American Expat now living in Thailand
    Well, my stock SGS with 2.1 (Froyo)was 'ok' when I first got it, and then after a while it started getting quite LAGGY. It was very frustrating at times. As I was new to the Android world and just finding out about apps I didn't have all that many apps loaded on my device, so I attributed it to Froyo. I did some reading up on the issue and at the time no one could really pin down the lagging problem. I did notice that there was a 'lag fix' program available but if I remember right is was for rooted devices only.

    I just sort of 'put up' with the lagging problem for quite a while,...and then decided to do a FW upgrade to 2.3.3 (Gingerbread). I had read some good reports on it and it looked like the way to go. I even considered trying to do the upgrade myself with Kies,....but after reading so many horror stories regarding Kies...I held off. Then, with the help of my Samsung tech friend we did the upgrade. He used Odin and everything went very well, no problems.

    I immediately noticed how smooth the new FW was on my device. Wow,.....it was great! What an improvement! :D I was a happy user again!......that is...I WAS happy until just this past week or so,.....because now the friggin LAG problem IS BACK. :mad:

    Now, I'm willing to concede that it may be my fault....and that's why I'm posting this. Maybe,....just maybe???....I have too many apps loaded onto my device? I'm just asking. I just counted fifty apps on my device.
    I have an 'app to SD' app installed and as of now I have 24 apps on the (external) SD card and 26 apps on the device (phone) itself.
    Would the amount of apps loaded on your device be the cause of the lag problem....this time?

    So, I'm wanting some feedback from other SGS users out there....Are you having lag problems with 2.3.3? Do you or do you not have many apps on your SGS? Do you think those fifty apps that I have loaded are the direct cause of my new lag problem?

    You see, I thought Gingerbread took care of that problem, so I really don't know why I'm having this problem...again. :thinking:

    So....Wadda ya think??? Feedback? Ideas? Suggestions? ;)
    If so, THX in advance.
     

    Advertisement

  2. LucyCaboosey

    LucyCaboosey Member
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    Nov 16, 2011

    Nov 16, 2011
    47
    5
    16
    My SGS is extremely laggy as well. It's driving me bonkers. I can pretty much rule out the issue being caused by too many apps because I really don't have that many installed and always delete them if I havn't used one in a while. I also empty the photos and videos quite often so it can't be that either and I clear all the cache's on a regular basis. I'm beginning to think it's just a slow phone (I'm on the most recent update available through Kies - Froyo I think?)

    Ah well only 4 months until I can upgrade. My boyfriend has the SGSii and it's incredibly slick. Even though he has all sorts of crap saved on it and about 40 apps. I'll be going for that next I think. Having a slow phone hasn't put me off getting another android phone. Especially as the boyfriend' phone is so much faster than mine. Maybe there were just a lot of bugs with the SGS that have since been worked out.
     
    LateNiteMike likes this.
  3. LateNiteMike

    LateNiteMike Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    212
    Joined:
    Jul 24, 2010

    Jul 24, 2010
    212
    14
    58
    Retired
    American Expat now living in Thailand
    Well Lucy, thanks for the feedback. I'm glad to know I'm not alone when dealing with this issue. That said, we don't have a solution for the problem (as yet) and unfortunately I'm inclined to agree with you that perhaps it's just inherent in this specific device. It's a shame 'cause (like you) I love Android and actually I still love my SGS,....but issues such as this can be frustrating at times. In all fairness there is usually some problem or other with every device out there....and that includes the ones from that other company whose name starts with an "A".
    BTW...when you write about the newer version of the SGS I'd prefer that you use upper case letters, as in SGSII as opposed to seeing those lower case letters as in SGSii. Those lower case ii's DRIVE ME NUTS ! Hahahahaha (just teasing ya) :p
     

Share This Page

Loading...