1. Are you ready for the Galaxy S20? Here is everything we know so far!

Le Pan TC970 tablet won't connect to Google account

Discussion in 'Android Devices' started by Danish Ninja, Sep 27, 2014.

  1. Danish Ninja

    Danish Ninja Lurker
    Thread Starter

    Afternoon, all --

    I hadn't logged online with my tablet in a while and had changed my Google password since then, but needed to log on with it last night. It warned me about a sync issue with Google because of the password change, so I typed in my current password and it didn't work. I tried a few more times (very cumbersome native virtual keyboard, I find, but I'm sure I got it right), and it still wouldn't work.

    I tried changing the password to Google a few times and trying to connect with it, and it wouldn't work, even when I briefly made the password super simple so there was no way I could type it incorrectly on the Le Pan. It wouldn't accept it.

    Finally I had little choice but to do a factory reset on it. Wiped it clean and started from scratch. Then I had to connect it to my Google account and... you guessed it... it still wouldn't connect.

    I asked some tech-savvy friends of mine what they thought, and one suggestion was that it was fixed on an earlier Google password: That basically it had been initialized (for lack of a better word) with that Google password, and it was now permanently set on that password, regardless of what my live password actually is. He said his Chromebook recently did much the same thing to him. I tried the earlier passwords I was able to remember, but nothing worked.

    In short, I have what's supposed to be a factory reset tablet which I can't connect to the primary source of apps that make it worth having. Any ideas how to do a TRUE factory reset on it (if my friend's take on it is right), or suggestions on how else to work around it seemingly not wanting to talk to Google to use updated passwords?

    Thanks in advance.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. fuzzmanks

    fuzzmanks Lurker

    Same thing happened to me early this summer. I hadn't been on my tablet for many months. Don't think I've touched it since early summer. The fix I found was to uninstalled the Google Play store app (I'm not sure of the exact name). Then it defaulted to the factory original Google App (that had a different name). It took some convincing to get the current Google App to load and start working for me.

    But if you did a factory reset then it should have been back to the old Google store app.

    I've pretty much given up on my tablet and thought I'd try and find a good app to display photos (like a wall frame). I have one of the original tablets with the original firmware. I downloaded the updated firmware this year (it was issued years ago) but have not installed it yet.
     
Loading...

Share This Page

Loading...