1. Are you ready for the Galaxy S20? Here is everything we know so far!

Legend turned on but is just black screen with notification icons

Discussion in 'Android Devices' started by CoralReef, Feb 15, 2011.

  1. CoralReef

    CoralReef Lurker
    Thread Starter

    Hi everyone
    I couldn't find another post on this but please feel free to point me in the right direction if something similar does exist.

    The problem: I can turn on my Legend, it starts up as normal and gets to the lock screen with no problems. As soon as I drag down that screen, an error pops up - "Sorry! The application Settings (process com.android.settings) has stopped unexpectedly. Please try again". Underneath is a button saying Force close. I click on this and it takes me to what should be the home screen, only there is nothing visible except for the notification icons on the top... From here I cannot do anything other than use the power button.

    I have tried soft and hard reset, removed the battery etc but no change.

    Previous to this the phone had been running slower and slower (especially with scrolling etc) and kept coming up with a notification saying something like 'sim card has been changed' which it hadn't.

    The phone is unbranded but the firmware is an official release of v2.2.

    Anybody have any ideas? The phone is well within warranty so if it is a total fail, I hope to be able to exchange it... but I am hoping there is a fix as I need to be able to use it!

    Cheers in advance. :)
     



    1. Download the Forums for Android™ app!


      Download

       
  2. CoralReef

    CoralReef Lurker
    Thread Starter

    In addition to the post above - I used another phone to call it and the full display appeared with the image of the other phone/user. As soon as I ended this call, a missed call icon appeared in the top left as normal but the rest of the screen was black again and I couldn't do anything but use the power button. Very strange.
     
  3. Hi, I am getting the same problem? Did you mange to resolve it?
     
  4. SeCreTEnDinG

    SeCreTEnDinG Lurker

    Same issue here. Gets to the main screen, I pull down to open, gives me the same error as above.
     

HTC Legend Forum

The HTC Legend release date was March 2010. Features and Specs include a 3.2" inch screen, 5MP camera, 384GB RAM, Snapdragon S1 processor, and 1300mAh battery.

March 2010
Release Date
0
Reviews
Loading...
Similar Threads - Legend turned black
  1. freekgamer
    Replies:
    1
    Views:
    274
  2. Wakey
    Replies:
    6
    Views:
    625
  3. iTP
    Replies:
    0
    Views:
    303
  4. freekgamer
    Replies:
    0
    Views:
    293
  5. Thomas Hemetri
    Replies:
    0
    Views:
    2,726
  6. MoodyBlues
    Replies:
    41
    Views:
    2,570
  7. App Update
    Replies:
    0
    Views:
    1,091
  8. App Update
    Replies:
    1
    Views:
    908
  9. App Update
    Replies:
    0
    Views:
    218
  10. App Update
    Replies:
    0
    Views:
    209

Share This Page

Loading...