1. Are you ready for the Galaxy S20? Here is everything we know so far!

LG ANDROID GW620 - Won't Connect To Computer & Doesn't Read SD Card?

Discussion in 'Android Devices' started by bamachik2010, Feb 9, 2011.

  1. bamachik2010

    bamachik2010 Lurker
    Thread Starter

    I am pretty sure that there is no help for the sd card part, but I at least would like to put pics and music on my phone by connecting to my computer, but when I plug it up, it just sits there and the phone is what is not responsive (and yes, I have it on Mass Storage mode). I am just SUPER frustrated and would like to sync somethings to my phone, like a good ringtone, and I can't get my computer to recognize it. Could it be that my phone, since it will not support a memory card, won't connect to the computer or could it be that I am missing USB drivers or something? I am confused. Please help! Thanks in advance :)

    1. Download the Forums for Android™ app!


  2. pukeboy

    pukeboy Lurker

    Are you sure that the phone won't read the memory card? I'm not certain as it is my daughter who has one of these phones, but I believe that the phone won't function properly without an sd card inserted. If there is a problem with the memory card, have you tried putting it in a pc card reader to check if the card is okay, or a different card in your phone to see if that works?

    I think that it is also necessary to install the drivers before you can use with a pc. When you connect the phone it should try to install drivers. If nothing is happening when you connect, have you tried a different cable as it could be that which is faulty?

    Drivers can be found here: LG Product Support for GW620

    If you do have a problem with the card, then it's unlikely you will get anywhere as usually connecting to a pc just mounts the memory card to the pc, rather than the phone memory.
  3. relectron

    relectron Lurker

    in fact i faced the same problem and more cause i find my lg gw620 all the day trying to find the sd card giving me in the notification bar that the sd card has been removed while it still in its slot and i haven't removed it & when i try to read it , i find the sd cart is unmounted so i remove it and put it again but it only takes less than an hour and i find the same problem so if anyone can help me ??????????????????
  4. chaby

    chaby Lurker

    yes... i think i found a small solution... (maybe not the best) but it works...
    make sure you have all the drivers installed...

    go to your app store (google play) and download "USB switcher for SGS1 on CM"

    (if you dont have google play try to download the apk elsewhere.. download it and use another phone (that the computer does detect) put your the sd card and copy the file.. after put the sd card on your phone and install...)

    ok back to business .. after you download the app

    connect the phone to the pc with the usb cable...
    open the app and and click.. "change to MTP" .. then select "Yes, reboot now"
    if you see a sign saying.. "superuser stopped (or any other app) ITS NORMAL
    dont click ok.. just let it reboot....

    once the phone turns on... WITH THE USB PLUGGED.... it should work...

    for some reason on my phone.. Lg revo vs920... I HAVE TO DO IT TWICE... idk why? :?
    it just works the second time...

    the bad part is... you'll have to reboot (twice in my case) every time i connect the phone to the pc...

    maybe it will work permanently for someone else..

    anyway im sooooo glad it worked!!

    its not the best way.... but its a way... because i tried everything ....

    if anyone else has another solution.. please let me know..

    also.. please let me know .. if this worked for you...


Share This Page