Dec 6, 2013
I bought an new unlocked AT&T version of the LG G2 so that I could run it on Metro PCS, but I am having one major problem with Metro. The phone is able to do everything fine on the Metro PCS network EXCEPT connect to mobile data. I have no clue what the problem might be. I read some threads on forums and some said to change the APN settings, but when I click on them in the menu nothing shows up at all.

I have gone to Metro PCS twice and they have been zero help at all and keep saying the phone might not be unlocked properly but I doubt it since most of them don't know what they are talking about half the time. I also inserted an AT&T sim card and the phone works perfect, mobile data is on and working great so I am not sure what is preventing the phone from connecting to the mobile network on Metro PCS. Any help will be appreciated please!
Go to a metroPCS store... they need to make sure your IMEI is in their system.
Also, you may need the Metro APN added to your device.
I had the same issue with my G2 but I had ported out from T-Mobile.

Even though you're now using a Metro plan.. keep using the ATT network.
Settings >> Tethering&Networks >> MobileNetworks >> NetworkOperators >> Search Networks

Then select the ATT Network.

For me the T-Mobile CDMA network works best. but you can try them all until you find the one that gives you the 4G icon.

If this helps you, please click LIKE