1. Check out our companion app, Forums for Android! Download from Google Play

Support LG OPTIMUS 3D Stuck in recovery - please help

Discussion in 'Android Devices' started by conradchase, Sep 13, 2012.

  1. conradchase

    conradchase New Member
    Thread Starter

    Jan 9, 2011
    Actor, Product Specialist, Web design, computer re
    Ft. Lauderdale, Florida
    I have an LG OPTIMUS 3D (LG P920). I have Clockwork mod & Titanium backup installed as I was looking to root it and upgrade the ROM. On the CWM setup I pressed "Reboot into Recovery" and now all I get is:
    Android system recovery <3e>

    Android system recovery utility

    reboot system now
    apply sdcard:update.zip
    wipe data/factory reset
    wipe cache partition

    When I select "apply sdcard:update.zip" It gives me:

    -- Install from sdcard...
    Finding update package...
    E:Can't mount /dev/block/mmcblk1
    (No such file or directory)
    E:Can't mount SDCARD:update.zip
    Installation aborted.

    I've also tried using:
    LG Mobile Support Tool
    LG Mobile Software updater agent
    LG Flashtool
    ADB push

    Unfortunately, I haven't had any luck with any of these or I wouldn't be asking for your help.

    I've tried to ensure that I have the right Modem and USB drivers installed but still don't see my device with the Flashtool or the LG support tools.

    I am able to connect to my device with ADB
    I thinks I'm missing something with mounting the SD card or messed up the partitions maybe?

    Your suggestions please..

    Thanks in advance,



Share This Page