1. Are you ready for the Galaxy S20? Here is everything we know so far!

LG Optimus M Hard Reset Didn't Work

Discussion in 'Android Devices' started by ThrowBack 330, May 25, 2013.

  1. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    Hey AndroidForums users I'm new to this posting threads stuff but I have an LG Optimus M Android Phone and it was on 2.2.1 when I rooted it using gingerbreak , I installed an application called SystemApp Remover which can remove bloatware , while I was happily removing system apps I came across something called "setup" or something of that nature my phone rebooted itself automatically and when I unlocked my phone I get a black screen but a working notification bar . I tried taking out battery several times with no luck , so I had to hard reset it when I got this error "the application setup wizard (process com.android.setupwizard) has stopped unexpectedly" and I'm forced to foreclose and the same thing but with a hard reset phone , a working notification bar with a black screen . That's when I realized I had stupidly removed the system setup application using SystemApp Remover -___- I don't know what to do so I created an account just to post this thread , anyone with any information to help me with my problem will be MUCH APPRECIATED and Thank You in advance !
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    It would be greatly appreciated if someone could help me with what to do or some good advice because I am a foster child I'm only 16 , and this phone is my only contact with my family and friends and now I'm upset with myself with making my phone a useless brick . It's not even activated I had a text app in which I could text and receive calls if I had wifi but now I'm stuck with nothing I'm pretty sure I'll get no help from any company if I call because it wasn't activated and I rooted it which would void any warranty . Again any help would be much appreciated and thanks a lot in advance !
     
  3. t3084

    t3084 Android Enthusiast

    Did you happen to install a recovery? I'm gonna take a guess at no.

    Are you posting from a PC? if so you will need a usb cable,ADB, your phones usb drivers(here), and the SetupWizard.apk. (I'll PM you ADB and the setupwizard.apk)

    1)Install the drivers

    2)Plug in the phone

    3)unzip ADB_AAPT onto the Desktop(or anywhere you want really, but for the sake of instrustions...)

    4)Put SetupWizard.apk into the ADB_AAPT folder to make this easier

    5)if you are using windows7or8 you can hold shift and right click on the ADB_AAPT folder and click "Open terminal here"
    IF NOT, CLICK SHOW BELOW
    press windowskey+R and type "cmd", press enter.
    change the directory to the Desktop by typing
    Code (Text):
    1. cd Desktop\ADB_AAPT
    press enter.
    If that doesn't work...
    Code (Text):
    1. cd %HOMEPATH%\Desktop\ADB_AAPT
    press enter
    6)Check to see if ADB will run and find your phone
    Code (Text):
    1.  adb devices
    if it shows your device you can move on to the next step

    7)mount /system as rw(Read/Write)
    Code (Text):
    1. adb remount
    8)push the setup.apk into /system/app/
    Code (Text):
    1. adb push SetupWizard.apk /system/app/
    9)reboot the phone
    Code (Text):
    1. adb reboot
    10)report back :)
     
  4. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    Hey Thanks for the reply ! I did everything you mentioned in the instructions and when I reached the step where I had to input "adb devices" it would tell me "List of devices attached" but no devices listed . so I tried the next step anyways and then it showed "error: device not found" I'm currently running Windows xp 32-bit at my school but I'll try on my foster dads laptop when I get home thanks again for the reply and if it doesn't work again any further advice would be greatly appreciated !
     
  5. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    Hey no luck again on my foster father's laptop he's running windows 7 64-bit and I tried running cmd as administrator , I think it might have to do with my phone being hard reset so it might be unrooted and usb debugging isn't enabled by default . I can't change any settings as when I unlock my phone it's just a black screen with a notification bar at the top , any suggestions ?
     
  6. alfick3

    alfick3 Android Expert

    Send sammyz a private message. You can search for posts from him on the Optimus M All Things Root forum. He might be able to help you get back to stock.
     
  7. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    Thanks for the reply I'll send him a pm .
     
  8. t3084

    t3084 Android Enthusiast

    you installed the drivers from the LG site? for the ms690?

    here are the drivers I use. LG MS690
     
  9. sammyz

    sammyz LG Whiz Kid

    Hey ThrowBack 330,

    I PM'd you with a link to my easy unbrick guide to returning to stock.

    Once you unbrick you will not be able to root the same way you did before, but you phone will be usable until you can root with a PC.

    Edit: I moved your thread since you're rooted :)
     
  10. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    Sorry for being a newbie but I went to the guide and the firmware cab file link was broken so I went to the other guide and it required me to select MS690.dll after opening LGNPST . I was getting a different .dll file (LGNPST_Utility2.dll) from the program . I thought it would work anyway , I went ahead and selected the corresponding .bin file and hit start when I received an error saying "Error: Unable Loading Port Component" Any further advice ?
     
  11. sammyz

    sammyz LG Whiz Kid

    It worked fine for me to download the cab o_O
    I did download it just in case LG was just about to pull it though.

    LGNPST is a pain to use, it would be better for me to just upload the cab so you can download it.
     
  12. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    I agree that would help :) which version of LGNPST do you use ?
     
  13. sammyz

    sammyz LG Whiz Kid

    2.2.3 but 1.2 and 1.3 never gave me problems.
     
  14. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

  15. sammyz

    sammyz LG Whiz Kid

    When you get that error, try this:
    Unplug USB
    Pull battery
    Put in battery
    Plug in USB
    Try again.
     
  16. ThrowBack 330

    ThrowBack 330 Newbie
    Thread Starter

    I would try that but now whenever I try to turn the phone on it gets stuck in "S/W Upgrade Do Not Unplug Mode"
     
  17. firestormx19

    firestormx19 Lurker

    Can you PM me the ADB too. I have the usb drivers and Setup wizard.apk. All I need is the ADB.
     
  18. sammyz

    sammyz LG Whiz Kid

    Turn it off and back on, try again.
     
Loading...

Share This Page

Loading...