Help Lineage OS bootloop + Broken TWRP + no USB Debugging enabled

Essentially my first post, because I have not found any helpful tutorials with the issue I'm having.

So, I tried to update from CyanogenMod to LineageOS 14.1 on my moto g4, and for the most part it went alright. I made some mistakes (ex. wiping my entire phone data with advanced wipe in TWRP which meant that I also deleted the .zip of Lineage that I was going to flash) but I ultimately got it working, but the phone had issues, like it would automatically shut down after unplugging it from a charge cable. Without thinking, I thought that the smartest course of action would be to update my Recovery from 3.0.2 to 3.1.1; and now I can't go into recovery from the bootloader, AND my device is in a constant bootloop.

I've gotten to the white LineageOS start screen, but even on a charger it will crash before I can even get close to enabling developer options and USB debugging. I've tried adb fastboot, using Windows and Ubuntu versions as a Superuser, but my phone is never recognized by adb on either OS, and I have no idea what to do from here.

In short, my Recovery is wrecked, my OS won't boot, USB debugging is NOT enabled on the phone, and what little experience I have with adb and fastboot has lead to nothing. hoping someone can help.​
Last edited:
Sure you have ALL of the drivers? Fastboot is probably not going to be recognized by ADB drivers alone. I'm not seasoned much with newer Motorola phones, but I know the Motorola forums are usually pretty helpful and you may be able to get the original firmware back on there.

Even if recovery partition is smoked, chances are, there may be a flash mode you can use, or you may have to use 'mfastboot flash' commands. They're weird like that. But first and foremost, be sure you have ALL of the latest and greatest drivers, and a high quality USB cable. Crap cables will not work

Edit: If debug is not set, ADB won't work, but shouldn't be a problem with Fastboot or a flash tool of sorts
Last edited: