Aug 12, 2014
Blacksburg, VA
When I try to mount the partition for Link2SD, I get a dialog that says:
Mount script error
Mount script cannot be created.

mount: No such device

OK Button (to tap on)

I had spent a few days studying the information to use this APP, and believe I got it down right... I have done it in the following matter:

  • 80% Partition VFAT (32);
  • 20% Ext4 (this was specified as the one for my phone). The percentages are close.
  • Link2SD is NOT installed on the internal memory part of the phone, but I read that is necessary.
  • The Desktop Computer (Opensuse 13.1 KDE, a Linux platform) has no problem reading/seeing both partitions, via own "Partition Manager" software, or the GPartED software

My Phone specs are as follows:

Sprint LG Optimus S™ LS670
Manufacturer: LGE
Model: LS670
Version: ZVJ.47B67B46
Android 2.3.3 Gingerbread

Busybox and Superuser are installed.

Anyone else having/had this problem, and knows how to resolve it (yet?) ?

The first time I partitioned to 20% for the EXT partition it rendered the SD card unusable. If you can repartition, try it to drop it to 15% and see if that gets it back in operation.

I'm also assuming that you already rebooted the phone?

Good luck.

Thanks. That did not work. Yes, I rebooted the phone. I'm going to try some other things. Seems partitioning editors like it better when the microSD card in plugged into an SD Card, instead of while it is in the phone. Maybe I should like different file systems, i.e. Ext2 or Ext3; but I did read it was supposed to be formatted as Ext4 for my phone, thus, that might be incorrect[?.]

Ah. I've never tried it on the phone, I partitioned mine on a Win8.1 PC with the mini partition tool (free download from I've heard and read too many things about weird results when trying it from the phone.

I used EXT4 for my second partition for Link2SD, make sure you set it as a primary, too.

Might be best at this point to remove all partitioning and start fresh.

Good luck.

Well, I got the problem solved ... I formatted the microSD Card with the phone, unmounted it, pulled it out, and inserted into an SD Reader Card, and notice a difference this time: the "boot" flag was set this time, as before it was not; maybe that was the problem, but I went ahead and reformatted the partitions, but used Ext2 first (though maybe it was just the "boot" flag, and I could have formatted the 2nd Partition with Ext4). Anyway, it APPEARS to be working fine now, and I even purchased the Plus version, so now I'm linking away ... :)