1. Are you ready for the Galaxy S20? Here is everything we know so far!

Linux user here - stuck with "insufficient permissions for device"

Discussion in 'Android Devices' started by Rene., Aug 19, 2010.

  1. Rene.

    Rene. Newbie
    Thread Starter

    The phone is correctly rooted, and I'm using this method:

    FASTFORWARD TO 5:17 PLEASE :)

    YouTube - How To Root & Sideload Apps on the Samsung Captivate with Windows

    I get stuck here trying to install a HTC_IME.apk file (trying to get the HTC Keyboard on my Cap) to my phone. I've ran it as a regular user and as a su user in my terminal. Is this an error on my phone's end? Maybe I missed a setting during/after rooting my phone?

    Code (Text):
    1.  
    2. rene@rene:~/Android SDK /android-sdk-linux_86/tools$ sudo ./adb install HTC_IME.apk
    3. [sudo] password for rene:
    4. error: insufficient permissions for device
    5.  
    Help would be greatly appreciated :D

    maerlim's guide did not look linux friendly (few things are different in the linux terminal than the windows command prompt) which is why I haven't tried it, but if any other linux users followed his directions I'll try to give it a go.

    *******EDIT*******

    Ok so I ran ./adb devices to view my device just for the hell of it and here's what returned:

    Code (Text):
    1.  
    2. rene@rene:~/Android SDK /android-sdk-linux_86/tools$ ./adb devices
    3. List of devices attached
    4. ????????????    no permissions
    5.  
    My phone is mounted correctly, USB debugging is on, what the heck did I miss? :( From what I can gather it probably does not even detect my device :(
     


  2. Swizz

    Swizz Android Enthusiast

    sudo ./adb kill-server
    sudo ./adb devices (it should no longer say ????????????? no perms)
    sudo ./adb install <name of app>

    if the install command doesn't work:

    ./adb push <name of app> /sdcard
    install from the phone using Astro or, my favorite, EStrongs.
     
    eromrab and Rene. like this.
  3. Rene.

    Rene. Newbie
    Thread Starter

    Thank you thank you thank you!!!! :)
     
  4. MKyritsis

    MKyritsis Lurker

    thanks so much, your solution fixed my problem (sudo ./adb devices returned
    List of devices attached
    ???????????? no permissions

    It makes sense now because the first time I ran adb it wasn't as sudo, so the deamon started with insufficient privileges. "sudo ./adb kill-server" and then starting adb as sudo did the trick!
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...