1. Are you ready for the Galaxy S20? Here is everything we know so far!

Loads of issues with KitKat 4.4.2

Discussion in 'Android Devices' started by sheadawson, Dec 18, 2013.

  1. sheadawson

    sheadawson Lurker
    Thread Starter

    Hey everyone,

    Since updating my Nexus 4 to Android 4.4.2, I've had a tonne of issues when making and receiving calls.

    * Screen does not turn on when someone is calling, so I can't answer the phone
    * "return to call in progress" just returns me to my home screen so I can't hang up on someone I have called
    * Dial pad does not seem to be aware when I am on a call, so dialing an extension when on a call does nothing, just starts searching for contacts with that number. This also means I am not able to perform any actions when in my voice mail box.

    These issues are incredibly frustrating especially as I'm about to go on holiday and am using the phone a lot to organise stuff.

    Googling around doesn't seem to have revealed many others reporting these issues so thought I try and make some noise and hopefully find a solution.

    Many thanks,

    Shea
     



    1. Download the Forums for Android™ app!


      Download

       
  2. John Bean

    John Bean Happy Wanderer

    They all sound related, as though something - an app perhaps - has "stolen" some of the phone functions.

    As a first attempt I'd go into settings, tap "Apps" then in the apps menu select "Reset app preferences" to ensure you get back to defaults.
     
  3. sheadawson

    sheadawson Lurker
    Thread Starter

    Yeap that fixed it thank you for the suggestion!
     
  4. John Bean

    John Bean Happy Wanderer

    Good result :)
     
  5. jhonb

    jhonb Android Enthusiast

    Isn't that great when someone answers your post and solves your problem in 12 minutes?
     
  6. sheadawson

    sheadawson Lurker
    Thread Starter

    It's excellent... just gotta put the question out there earlier :D
     
  7. jhonb

    jhonb Android Enthusiast

    I have had no bug issues. But I hate the new phone interface. Hate it!
     
  8. DC1022

    DC1022 Well-Known Member

    I'm having issues too. Is anyone else having problems with the volume rocker not functioning at all once in a while? I already did a factory reset as soon as I updated, just as a fact about what I've done, and also am stock. 4.4.2
     
  9. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    I'm warming up to it, but it does take a good bit of getting used to.

    I haven't seen any volume button issues, but I've noticed some sluggishness when waking up the phone on Wifi. I think it renegotiates with the network first. It didn't do this on 4G and since I've switched to ART, It's even less.
     
  10. DC1022

    DC1022 Well-Known Member

    So my volume buttons always start working again after I do a reboot. Do you think a factory reset would fix the problem totally?
     
  11. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    That would be hard to tell, especially if it's an app that's the problem. If you reset and then install the same app, you could end up right back here. Are you using any apps that are specifically designed to control sound? Custom volume levels or custom ringtone assignments? You might try simply clearing the apps caches and data and see if that solves your problem. FYI, clearing data will remove your settings for the app and put it back to a default state.
     
  12. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    You could try running in safe mode for a while, see if the problem manifests itself. The phone will reboot, but when it loads, no 3rd Party apps will be running. If you don't experience the problem in safe mode, you'll know it's an app that's causing the problem.

    You can boot in to safe mode here: https://support.google.com/nexus/answer/2852139?hl=en-GB
     
    D-U-R-X and John Bean like this.
  13. DC1022

    DC1022 Well-Known Member

    No, I'm not running any apps that set custom volumes. I've had the same apps as I had before my KitKat update. That's why I feel like it has something to do with the update. Here are my apps if it helps: Airdroid, Box, Drive, Dropbox, Dynamic Notifications, Evernote, Glovebox, Flashlight, Hero Academy, LinkedIn, Pudding Monsters, Puzzle Retreat, Soundhound, textPlus, Where's My Droid, World of Goo.
     
  14. John Bean

    John Bean Happy Wanderer

    Have you tried safe mode as suggested? The fact that a misbehaviour didn't surface until after the update doesn't necessarily mean that the update was the cause of the problem, it still could be (and probably is) an app-related issue.

    If the phone works in safe mode you have eliminated the phone and OS as a cause; after that you'll need to isolate which app is the real culprit.
     
    El Presidente likes this.
  15. DC1022

    DC1022 Well-Known Member

    I have not, I'm going to try safe mode tomorrow and use my phone decently heavily to see if I get any results. I'll report back in a few days to see if I have any success or not. So far today the volume buttons not working has not been an issue. It's kind of a funny issue as only once in a while they will just not work, thus requiring me to reboot my phone to make them work. But, I'll report back my results in a few days of trying safe mode. Thanks for all the suggestions so far guys, really appreciate it.
     
    lunatic59 likes this.
  16. DC1022

    DC1022 Well-Known Member

    Just reporting my results. So after a few days of using safe mode, after turning my phone on today, the volume buttons were once again not working so I had to do a reboot to get them working once more.
     
  17. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Of you were still in safe mode and the buttons didn't work, I'd have to say it points to a hardware problem rather than software.
     
  18. DC1022

    DC1022 Well-Known Member

    Dangit! Ok well it only has happened once in the last week so I'm not to worried. I can wait till the Nexus 6!!!
     

Nexus 4 Forum

The Nexus 4 release date was November 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 2100mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...