1. Are you ready for the Galaxy S20? Here is everything we know so far!

Location services not working

Discussion in 'Android Devices' started by daystrom, Aug 18, 2010.

  1. daystrom

    daystrom Member
    Thread Starter


    Not sure what forum to put this one in since it could be an Android general question, an Intercept question, or a Sprint network question!

    I have three new phones. One Evo, and two Intercepts.

    Both of the Intercepts exhibit the same problem. When I open the browser to Google OR any application that uses location info like Fandango, etc. the phones will NOT locate my position using tower triangulation. GPS works fine but while indoors and no GPS lock, I have no location service.

    All the necessary settings on the phones are on such as use mobile network location, gps, etc. etc. I've researched this and have tried all the fixes.

    My Evo has no such problem.

    I've also noticed using Latitude the phone will triangulate with the towers fine while traveling. However when we get back to our home city Latitude reverts the location back to where we were and continues to update from that location! I know it's using triangulation because of the 'circle of confidence' around the user is much larger than true GPS has.

    Has anyone seen this behavior before? My next test will be to bring an Intercept to work with me to see if the towers in my area are at fault. My Evo works fine in the same location however.


  2. megabiteg

    megabiteg Android Enthusiast

    Make sure to check the following settings (on the intercept)
    settings - location and security - Use wireless networks = checked
    settings - Privacy - Use my location = checked

    If you are indoors, there sometimes can be problems (depending on your service straight too). If you still can't get any luck I would suggest a hard reset (settings - Privacy - Factory data reset, caution this will delete everything on your phone please backup if necessary before doing this)

    If the problem persists after doing this, I would suggest calling Sprint Tech support and see what they say.
  3. daystrom

    daystrom Member
    Thread Starter

    I've checked those settings over and over on both phones. Everything is set right. It just doesn't work on either phone. You'd think the Evo would be polling the same Cell ID that the Intercepts do? The Evo works.
  4. megabiteg

    megabiteg Android Enthusiast

    Antennas can maybe be limited on the amount of calls they handle but its hard to saturate the amount of data they can stream to each phone. You should be able to have 100 phones right next to each other and they all should pick up the location service without a problem.

    Now, did you try being out doors while doing so for the first time? have you tried maybe the FR? Make sure you are also signed in on the Google website with your user name and password (done using the phone) and making sure its also activated in the settings, that can be a wiled guess but it may be related.
  5. daystrom

    daystrom Member
    Thread Starter

    Factory reset done on both phones, location service still doesn't work. Makes location aware apps pretty useless! Can you tell me does yours work? Could it be the towers in my location. Hard to believe I would have two broken Intercepts.
  6. megabiteg

    megabiteg Android Enthusiast

    I'm at work right now but I can test it in a few hours, I don't have good service because we are underground here (military facility). Stay tuned for a response after 1700h EST.
  7. daystrom

    daystrom Member
    Thread Starter


    Where you able to test the location service out on your Intercept?

    What I've found out -

    If I turn GPS OFF, and then open Google Maps I will get an error that says "Your location is temporarily unavailable". If I turn GPS ON my location is dead on. This would indicate that CELLID is not working.

    BUT - while the phone is sleeping the location is found using CELLID. I can tell this because for one the GPS doesn't turn on while the phone is sleeping per Google. And the blue circle around my location grows to multiple blocks around my area like it is using the towers for location.

    I've also found that while in Google Maps, if you do a help/about the MYL field IS populated with data. If CELLID was not working that field would say N/A.

    So whatever passes the MYL data to apps isn't working right.

    Let me know what your Intercept does.
  8. megabiteg

    megabiteg Android Enthusiast

    I apologize for not updating on time, lot's of work lately....

    I tested the location services in various places over the weekend. I didn't have the GPS ON, only Location Services was enabled.

    I tried using the Google website and it found my LOC pretty quick and accurate all the time. I also used applications like Movies, Weather Channel and Yelp which require that service for better user experience, and it worked flawless. With Google Maps (with GPS OFF) I haven't had any issues, now if using Navigation services yes, I could see how there could start being an issue.

    I'm located in Boston, MA so I don't know if it can be maybe a problem in your specific area.
  9. daystrom

    daystrom Member
    Thread Starter

    Not a problem. Glad everything works on yours!

    It has to be a service issue where I am (NE Ohio) because two Intercepts exhibit the same problem. The Evo I use doesn't have this issue but its radio is a Rev.A where the Intercepts are Rev.0 if that matters.
  10. megabiteg

    megabiteg Android Enthusiast

    Are you indoors? how's hows your signal strength while performing these tests? Have you tried it in your metropolitan area (like downtown or center of the city)?
  11. daystrom

    daystrom Member
    Thread Starter

    It's been tested indoors, outdoors, three separate areas (separated by at least 20 miles a piece). All three of my phones report MYL under maps and the data is the same. The two Intercepts don't know what to do with that data!

    My signal strength where I live is very good, full bars good in fact.

Share This Page