1. Are you ready for the Galaxy S20? Here is everything we know so far!

Looking for Linux File Transfer Tool for Android 4.0 Devices...

Discussion in 'Computers' started by Isthmus, Feb 13, 2012.

  1. Isthmus

    Isthmus Android Expert
    Thread Starter

    As most of you know, Google dumped the transfer via USB feature in Android 4.0 and above and replaced it with MTP File Transfer. The result is that while you no longer have to mount and un-mount your device when connected directly to a computer, your computer needs to have the ability to read MTP. Windows has this ability natively and plugging in any ICS device will immediately cause it recognized by windows and your device shows up as a folder, and immediate access sis given to internal folders. (I've tested this as far back as XP and it works).

    MacOS does not have MTP ability that is native to it, so Android released a tool for mac call Android File Transfer. Once installed, This tool allows your Mac to automatically recognize your ICS device and gives you access to internal folders (though your ability to modify those folders is a bit limited).

    For Linux systems there seems to be nothing. I find this odd seeing that Android is a Linux base OS. I've done some research into it and there does seem to be a way to hack this functionality into Linux, but it is an ugly hack.

    I was wondering whether any of you had any recommendations on how to go about getting a Linux system to recognize an ICS device so that files can be transferred between them through dragging and dropping. Before someone suggests it, yes I know that there are wireless options for doing this, but I'm not interested in them seeing that all of them are a bit too slow for my liking.

    Thanks in advance for any help and recommendations.

  2. Isthmus

    Isthmus Android Expert
    Thread Starter

    moya036, johnlgalt and EarlyMon like this.
  3. linuxrich

    linuxrich Well-Known Member

    A quick Google turned up an app called SSHDroid. Looks promising. I've not tried it personally. All I do is use my phone as the client (AndFTP) and the desktop machine (Running openssh-server) as the server.

    I know you pretty much dismissed wireless (i.e. over the network.) solutions but for me, losing a little speed is worth the convenience of not having to get off the sofa to physically plug into whichever PC I want to transfer to. I guess I'm just too used to transferring over the network using sftp as opposed to sneakernet.
  4. mrspeedmaster

    mrspeedmaster Android Expert

    SSHDroid and other likes like FTP are not the solution. We need a native filesystem mount.

    You can use FUSE and write a script that mounts it but it is very wonky and sloppy.

    I'm also very confused why they dumped USB Mass Storage for MPT.
    I can't plug in my phone to my car's usb port anymore.

    Furthermore, many of the music sync apps don't work even if you have MPT access like doubletwist:

    Galaxy Nexus not recognized for Mac

    My Windows7 computer can't see my Galaxy Nexus device
  5. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

  6. mrspeedmaster

    mrspeedmaster Android Expert

  7. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Maybe try...

    MTPfs Dual Elephants

    See also - SlackBuilds.org - mtpfs

    Haven't tried it personally, but hope this helps!

    PS - I think this whole MTP thing is a bunch of hooey. It simply allows for Windows users to not have to stop and eject their devices.
    moya036, 9to5cynic and johnlgalt like this.
  8. baillou2

    baillou2 Well-Known Member

    I'm confused. Is this more of a hardware thing? Because I'm running ICS on my Vibrant and I've had no problems accessing the filesystem with my linux laptop. Nothing has changed as far as I can tell.
  9. Isthmus

    Isthmus Android Expert
    Thread Starter

    Yes it is a hardware issue, or more specifically a device issue that is thus far exclusive to the Galaxy nexus, since that device has no USB storage (it's all on-board). Here are a couple of explanations:

    Google's Dan Morrill confirms USB Mass Storage in Ice Cream Sandwich, not present in Galaxy Nexus, however - GSMArena Blog

    Why Google uses MTP instead of USB file transfer on Android 3. glasskeys.com
    moya036 and mikedt like this.
  10. atek3

    atek3 Member

    Has it become any easier to get MTP working between linux and the GNex?

    I gave up and copy files from my server using a windows 7 box as the intermediary.
  11. SUroot

    SUroot Extreme Android User

    I do the same. Have my ubuntu pc as an ftp server then connect using estrongs. Not only do I not need to be in the same room as the pc, I don't even need to be on the same continent
  12. mrspeedmaster

    mrspeedmaster Android Expert

    FTP, Samba, SFTP, SSHFS,webdav are all nice for the occasional small jpegs.

    Get back to me when you can copy 4-6 Gigabyte files in the morning before your commute? E.G. a TV show you just downloaded and want to want on your new device.

    MTP is still a problem in Ubuntu 12.04.
    And MTP is a problem with newer devices not including the Galaxy Nexus.

    My new Galaxy Tab plays hissy fits.

    You have to install libMTP, MTPFS, gMTP, probe the USB, create fstab entries, and manually mount the devices in the command line.

    Even then, there is no guarantees the connection will not disconnect during file copies..

    The whole MTP thing has been an exercise in frustration.
  13. SUroot

    SUroot Extreme Android User

    This is me getting back to you. Love you, bye

    Of course my tv shows aren't 6 GB though, because my resolution is 480 x 800 so even a movie at that resolution would need to be 8 hours long to be that size
  14. MK27

    MK27 Lurker

    Here's what you need to know to get basic MTP support on whatever linux flavour. Any GUI app you find is just going to be built on top of this so you might as well try it first:

    1) FUSE filesystem support in the kernel. Chances are you use a pre-built distro kernel and there is already a module on your system that will autoload, so you don't need to worry about this. If you rolled your own, FUSE is a single option under "filesystems"; you can save some time and just add this to your config as a module, then make modules and make modules_install.

    2) Packages for libmtp and mtpfs. Most distros should have these and install the former as a pre-req for the latter.

    3) Create a directory to mount into, then:

    mtpfs /whatever/mount/path

    Done. To disconnect, use umount:

    umount /the/path

    As per usual, you can't have the directory open or umount will fail.

    Works no problem for me with kernel 3.0.6 and Android 4.0.3.
  15. Satires

    Satires Android Expert

    I transfer most of my files via 'wifi file explorer pro'. You just go through your browser and router. :)

    I'm still on gingerbread, transfering files in this manner seems faster.
  16. SUroot

    SUroot Extreme Android User

    I'm still having no problems using FTP to transfer 900MB ROMS etc over the FTP server. Still working brilliantly.
  17. mrspeedmaster

    mrspeedmaster Android Expert

    I did that but found out there was a bug with 64bit according to Ubuntu's buglist website.

    Also my main workstation running CentOS doesn't have the same accoutrments as my home ubuntu workstation.
  18. spion

    spion Lurker

    Shameless plug: if you have the android sdk installed, you can try adbfs-rootless:


    It allows you to mount your phone using adb (android debug bridge). Performance should be acceptable.

    note: Unlike the original adbfs it doesn't require rooting your phone.
  19. mikedt

    mikedt 你好

    That clears up something for me, from when I started reading this thread. I've got an Ampe A76 ICS 4.0 tablet, and have no problem transferring files on a PC, Windows or Linux. I just plug it in and it mounts automatically. Internal storage and SD-card appearing as two separate drives.
  20. SUroot

    SUroot Extreme Android User

    The sgs3 shows as two separate but not usb mass storage. Just mtp and ptp. Can't transfer files on Linux. Windows is fine
  21. 9to5cynic

    9to5cynic Android Expert

    I had this problem with my nexus and debian - I ended up using ftp. :p

    Not as fast, but oh well.
  22. Jay Aristide

    Jay Aristide Well-Known Member

    This is working pretty well for me. later, I'm going to try that adbfs someone mentioned, as well
  23. Newton_Jose

    Newton_Jose Lurker

    Another ugly solution, for very large transfers, is take off the microsd card and plug it in PC.
  24. Jay Aristide

    Jay Aristide Well-Known Member

    Not much of a solution for those of us with nand-only devices (like my nexus7)
  25. 9to5cynic

    9to5cynic Android Expert

    In the case of large files, I tend to just ftp the files back and forth... not pretty, but it works.

    I've found that when I am able to get MTP working on linux, it'll fail if the files are too large (or maybe too numerous) - and that's when I resort to ftp. :D

Share This Page