1. Are you ready for the Galaxy S20? Here is everything we know so far!

Looking to Compare Notes: Viewsonic Viewpad 7

Discussion in 'Android Devices' started by chicknlil, Apr 19, 2011.

  1. chicknlil

    chicknlil Android Enthusiast
    Thread Starter

    I picked up a Viewsonic Viewpad 7 the other day, primarily to be able to remotely update a website when I'm away from my computer. So far, I'm loving this device, but I've noticed a few little quirks that I'm wondering if anyone else has experienced. I have rooted the device, but not put any ROMs on as yet. Maybe my "issues" can be fixed that way - I haven't tried that yet.

    Baseband version: PR3.7_125
    Kernal version: Apps_2.6.32.9
    Build number: 1008_3_240

    Quirk 1 - The Orientation: Works fine when I use the default launcher (which is perfectly usable). In trying either ADW Ex or LauncherPro though, everything is fine when the device is horizontal (the assumed default position), but turning it 90 degrees puts everything on the screen upside down. Again, no issues like this with the default launcher.

    Quirk 2 - Browser Scrolling: Periodically, regardless of which browser I use, the screen (typically in gmail) will not scroll at all, which is problematic. Yes, I know I can use the app version, but I want to have full access to downloads and be able to more easily copy/paste items.

    Anyone else with this device notice anything like this, or any other quirks I may not have noticed yet?

    As I said, I really like the device, and I've found the battery life to be superb (battery is at 85% after 12 hours of moderate usage). Neither of the two quirks above are dealbreakers as their are clearly workarounds available...more just trying to get a handle on if this is just how it is, or if there are known fixes.

  2. jaomadn

    jaomadn Lurker

    Hi Im a viesonic v7 users also lately last week, can i ask where or how to rooted the device. Thanks in advance.
  3. chicknlil

    chicknlil Android Enthusiast
    Thread Starter

    From this thread on XDA...
    1. Download version 1.7 of Super One Click. Some users have reported issues with the latest version, but previous versions can be found in the thread.

    2. Place your Android device into debugging mode, and connect to computer.

    3. Right-click the Super One Click executable and select 'Run As Administrator'.

    4. At program launch select 'rageagainstthecage' exploit method, then select 'Root'.

    5. If there is no activity for more than 30 seconds and the terminal display is stuck at 'Running rageagainstthecage....' remove the USB plug momentarily and plug back in.

    6. You should get the message
    GilViking likes this.
  4. Davedds

    Davedds Lurker

    I have been using the free version of adw and don't have the same problem that you have with the ex version of adw...

    In the process of trying to get the viewpad 7 to see and use an ad hoc network, but so far it has not been working out. Still searching for a solution. Current wpa_supplicant version is 0.6.9 and so far I have not been successful.

    The most valuable thing outside of rooting I have is to create a second partition on my sd card and use link2sd to link most of my apps to the sd card. I have close to a total of 150 apps, loaded in it.

    Occasionally, the plastic clips on the case touches the screen edge and the viewpad screen starts to do funny things...

    Overall I like the viewpad, looked into roms for it but have not found anything special.
  5. chicknlil

    chicknlil Android Enthusiast
    Thread Starter

    Yeah, I've done the second partition on the SD card deal as well.

    Just tried the free version of ADW - still have the same orientation issue. From what I've read on MoDaCo, this seems like a known issue, and no one seems to know how to resolve it.

    Ah well...at least the default launcher works!
  6. pragahwiwoko

    pragahwiwoko Lurker

    my default launcher is turning every application into portrait and stuck in that position while the home screen is always on landscape, is that normal?, did mine have different default launcher or something else is wrong?
  7. GilViking

    GilViking Lurker

    Dear Chiknlil, I have tried 10 or 15 times to root using SuperOneClick versions 1.7, 2.1, 2.2. All result in a "Waiting for Device" message that causes SuperOneClick to become "unresponsive" removing and re-plugging the USB appears to have no effect at least for 10 cycles. Any ideas?

    Thank you - Gil

Viewsonic Viewpad 7 Forum

Features and specs are not yet known.

Release Date

Share This Page