1. Download our Official Android App: Forums for Android!

Losing access to the SD card...

Discussion in 'Android Devices' started by Ghâshûl, May 17, 2010.

  1. Ghâshûl

    Ghâshûl Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    217
    Joined:
    Dec 28, 2009

    Dec 28, 2009
    217
    11
    58
    Denmark
    Hey! I've had this happen several times, sometimes when I turn on the screen there's a notice saying that backing up to SD had failed, so I try to look at the contents of the card and I can't see any of my files. Sometimes I notice it when I try to take a picture, and it'll say that it doesn't have the required access. Other times, I've just wanted to access something on the card and noticed it had happened.
    Now, this sounds like it happens all the time, but it's only a couple of times a week, but quite annoying nonetheless. The only solution I have found is to turn off the phone, and then turn it back on again.
    I have tried with the programs SDRemount and SDRescan, but neither have any effect.

    Any hints as to get rid of this problem? Is it an issue with the SD card that would go away if I got a new one?

    PS. I have searched for this topic several times in here, without finding it, but I think something goes wrong in the search process (even if I just search for SD, nothing is found, and I'm quite sure SD has been mentioned a couple of times in here :)
     

    Advertisement

  2. Deego

    Deego Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    May 17, 2010

    May 17, 2010
    2
    0
    5
    Happened to me today as well :( I have only had the phone since Saturday, so cant say if its a problem or not. I unmounted and re started the phone. its been ok since!!
     
  3. jauhari

    jauhari Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    97
    Joined:
    May 13, 2010

    Try to reboot your HTC Desire.. it's worked on me
     
  4. Ghâshûl

    Ghâshûl Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    217
    Joined:
    Dec 28, 2009

    Dec 28, 2009
    217
    11
    58
    Denmark
    Yes, it works fine with rebooting, but since it's a recurring problem, and usually happens when I want to show something off, it's not all that great, so I'd prefer if I could make the problem go away entirely.
     
  5. dd1989

    dd1989 Member
    Rank:
    None
    Points:
    36
    Posts:
    33
    Joined:
    Apr 10, 2010

    Apr 10, 2010
    33
    5
    36
    Happened to me a few times too. It's a bit frustrating.
     
  6. ncoloss

    ncoloss Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 17, 2010

    May 17, 2010
    1
    0
    5
    Hi
    I also have this problem. Pjone only a week old. Disappointing.
    I'll try a new SD but if that fails I suspect that it is something to do with a poor contact mechanism between the phone and the SD card. In which case its a design flaw or a manufacturing flaw and we're just unlucky.
    N
     
  7. Sheshnag

    Sheshnag Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    233
    Joined:
    Apr 28, 2010

    Apr 28, 2010
    233
    9
    56
    This keeps happening to me - is there any solution? Please help!
     
  8. Tyseyh

    Tyseyh Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,035
    Joined:
    Jun 9, 2010

    Jun 9, 2010
    2,035
    296
    163
    Male
    Leeds, UK
    Same here, like you guys the only thing iv found is to restart the bloody thing. :(
     
  9. SHiFT3R

    SHiFT3R Member
    Rank:
    None
    Points:
    15
    Posts:
    46
    Joined:
    Jun 21, 2010

    Jun 21, 2010
    46
    0
    15
    It also happens to me.
    Reboot is not solving the issue cause... it just happens again :S

    I suspect ASTRO file manager. Do you have it installed?
     
  10. davetarmac

    davetarmac Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Jul 17, 2010

    Jul 17, 2010
    8
    0
    5
    Both me and my wife had the problem with the SD card. It does seem that it needs to be unmounted and remounted, but since the only thing that let's you do that is restarting the phone this mkea it a very annoying process.

    Neither is us have Astro installed, in fact the only thing we have installed recently is the Facebook update.

    What about any if you?
     
  11. Phenomenological

    Phenomenological Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    782
    Joined:
    Jul 7, 2010

    Jul 7, 2010
    782
    186
    93
    Nobody brings this thread up for 3 months then 5 people chime in saying they have it today? Did this start recently or something?
     
  12. Sheshnag

    Sheshnag Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    233
    Joined:
    Apr 28, 2010

    Apr 28, 2010
    233
    9
    56
    This used to happen to me, but it had not happened for months. It started again I think yesterday.
     
  13. snowmobile

    snowmobile Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    479
    Joined:
    Apr 10, 2010

    Apr 10, 2010
    479
    92
    73
    This has happened to me a few times and only started in the past couple of weeks. I do have Astro but I haven't installed the Facebook update.
     
  14. markjwilson

    markjwilson Newbie
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Apr 19, 2010

    Apr 19, 2010
    20
    2
    16
    I have never had this problem till yesterday, every hour or so i would loose the SD card or sometimes i would only loose half the folders.

    I changed for an old 2GB card and the problem has gone away. so ive just ordered a new 16gb card hopefully it's just a fault card.
     
  15. donnie

    donnie Member
    Rank:
    None
    Points:
    36
    Posts:
    49
    Joined:
    Jun 8, 2010

    Jun 8, 2010
    49
    2
    36
    Sweden
    Happens to me all the time. I've heard rumors that reformatting the card should work. Also, some say that it's got something to do with the read/write permissions. Can anyone confirm ?
     
  16. WozzaTT

    WozzaTT Well-Known Member
    Rank:
    None
    Points:
    48
    Posts:
    221
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    221
    11
    48
    Happened to me when I first got the phone a month ago. I took the SD card out and put it back in and thought this had solved it as I was then problem free.............until yesterday and today when it's happened again.

    I'm hoping getting a new SD card will solve it but I'm not too optimistic as there are several other threads on here about this problem and some have had it with more than one card.

    If it is a problem that can't be fixed I won't be buying another HTC device again -
     
  17. markjwilson

    markjwilson Newbie
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Apr 19, 2010

    Apr 19, 2010
    20
    2
    16
    Quick Update. I have fixed it!!!

    I copied all my data to my pc, then formatted the card and then copied my data back. No problems at all everything works and has done all weekend..
     
  18. BruceC

    BruceC Newbie
    Rank:
    None
    Points:
    16
    Posts:
    25
    Joined:
    Aug 2, 2010

    Aug 2, 2010
    25
    4
    16
    Male
    Oxfordshire
    Did you format it on the PC? On my Desire, the SD card format option is greyed out.
     
  19. adam_hilluk

    adam_hilluk Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    218
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    218
    17
    58
    Solihull, UK
    this happened alot on my Hero, just had to format the SD card via

    menu > settings > SD & phone storage > Unmount SD card > Format SD card

    after this put stuff back on (make sure you back up before format) and all was fine :D
     
  20. BruceC

    BruceC Newbie
    Rank:
    None
    Points:
    16
    Posts:
    25
    Joined:
    Aug 2, 2010

    Aug 2, 2010
    25
    4
    16
    Male
    Oxfordshire
    Ah, thanks Adam. Not very intuitive to unmount the card before you can format it, but thanks! I haven't got round to backing up on PC yet, so will do this first.
     
  21. adam_hilluk

    adam_hilluk Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    218
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    218
    17
    58
    Solihull, UK
    thats okay, just let us know if it works. fingers crossed for you
     
  22. BruceC

    BruceC Newbie
    Rank:
    None
    Points:
    16
    Posts:
    25
    Joined:
    Aug 2, 2010

    Aug 2, 2010
    25
    4
    16
    Male
    Oxfordshire
    My SD card works fine, so not really necessary, but it's a replacement one, and I always think it's best to format on the device.
     
  23. adam_hilluk

    adam_hilluk Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    218
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    218
    17
    58
    Solihull, UK
    My SD card worked fine on everything else but just suddenly stopped working on the phone every so often. right faff
     
  24. nx1977

    nx1977 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    2,421
    Joined:
    Feb 8, 2010

    Feb 8, 2010
    2,421
    174
    163
    UK
    Started getting mybackup pro DB errors - which their faq says is an SD error. Removing all the backups seems to have sorted this.

    Everything else that uses the SD card was running fine.
     
  25. markjwilson

    markjwilson Newbie
    Rank:
    None
    Points:
    16
    Posts:
    20
    Joined:
    Apr 19, 2010

    Apr 19, 2010
    20
    2
    16
    I took it out and formatted it onto a PC.

    There did seem to be a lot of empty directories for apps i have uninstalled.
     
Tags:

Share This Page

Loading...