1. Are you ready for the Galaxy S20? Here is everything we know so far!

Lost the ability to change USB Config to MTP

Discussion in 'Android Devices' started by Fred615, Oct 5, 2020.

  1. Fred615

    Fred615 Lurker
    Thread Starter

    On my Galaxy 7, up until a few days ago, I was able to go to Settings/Developer Options/USB Configuration/ and then pick MTP protocol and then easily transfer photos from my SD card to my PC. All of a sudden, about 3 days ago, when I swipe on the settings icon and go look for the "Developer Option" choice, it is no longer there. Was there an upgrade done in the background that eliminated that choice? More importantly, now what is needed to be able to move my photos from the SD card to my PC ?
     


  2. puppykickr

    puppykickr Android Expert

    Have you tried turning the device off and back on?

    Cliche? Yes.
    Can sometines work wonders?
    Also yes.

    If this gives no help, then perhaps you must reenable the developers options.

    Generally this is accomplished by finding and then tapping the Build Number in the settings.

    Your device may vary, but the general gist is...

    Settings
    System
    About phone
    Build number
    (tap until notice "You are now a developer" appears)

    Then go back in the settings, find the developers options, select them, and then turn them on.

    Another quick fix may be tojust go wireless, through your Wi-Fi, with NitroShare.

    https://f-droid.org/en/packages/net.nitroshare.android/

    There is a version for PC available online.

    Transfer is possible as long as all devices are on the same Wi-Fi network.
     
  3. Fred615

    Fred615 Lurker
    Thread Starter

    puppykickr,
    I have turned it on and off many times over the past few days with no change.
    I started to go through the process to get into the developer section but right away there is a problem; there is no SYSTEM selection on my list under SETTINGS.
    ??
     
  4. puppykickr

    puppykickr Android Expert

    Ok, different devices are different.

    How did you enable developer's options the first time?
     
  5. svim

    svim Extreme Android User

    The Developer Options menu is an integral part of the Settings app itself. If you had that USB MTP option there previously but no longer, perhaps some random config file became corrupted. Try going into your Settings >> Apps menu, find and open the Settings app listing, and then find and tap on Clear data. Then restart your phone. Using Clear data will wipe the Settings menu config files, so don't be surprised if you have to go through the process of enabling Developer Options again. Hopefully this will restore that missing USB option.
     
  6. Fred615

    Fred615 Lurker
    Thread Starter

    dontpanicbobby, MrJavi and puppykickr like this.
  7. puppykickr

    puppykickr Android Expert

    Excellent!
    Glad to have been of some help.
     
  8. Fred615

    Fred615 Lurker
    Thread Starter

    Unfortunately, today I tried to move a couple a file via the approach I was using 2 weeks ago and for the file I tried to move I did a copy and then a paste into the mobile directory and I heard a little ping which means that it tried to put the file into my cell folder but it would not show up in the directory after two tries. Any ideas on what might be wrong now ?
     

Galaxy A7 (2018) Forum

The Galaxy A7 (2018) release date was October 2018. Features and Specs include a 6.0" inch screen, 24MP camera, 4/6GB RAM, Exynos 7885 processor, and 3300mAh battery.

October 2018
Release Date
0
Reviews
Loading...

Share This Page

Loading...