1. Are you ready for the Galaxy S20? Here is everything we know so far!

lost wifi after update

Discussion in 'Android Devices' started by babelfish69, May 15, 2011.

  1. babelfish69

    babelfish69 Lurker
    Thread Starter

    Hi guys, the wife may cause me pain if I don't get this sorted.

    Her x10 was on 1.6 with o2, it started locking and rebooting about a month ago, so. I thought I'd update it to 2.1. After several failed updates via SEUS and repairs using SE Companion I cannot get it to connect with WiFi.
    It recognizes networks and has a WiFi sign with a ?. I enter the wep key but it won't connect, an any other attempt to connect is unsuccessful and without any kind of WiFi icon in notifications bar.
    I have rebooted modem, phone and am still at a loss, I know I have signal as I'm using it now with my phone with no probs.

    Any advice much appreciated
     



    1. Download the Forums for Android™ app!


      Download

       
  2. beau420

    beau420 Android Expert

    Change the password or encryption type on the router. Make sure you can sign in on the phone. Then change it back.

    Routers aren't as smart as people like to think.

    Turn all wireles security off....connect....then turn it back on....then try and sign back in using the password.

    Usually it is the router. If it works without encryption and doesn't work with WEP...change the encryption type to WPA or PSK or something else.
     
  3. babelfish69

    babelfish69 Lurker
    Thread Starter

    Hi beau,
    Thanks for the reply, I tried turning off the security and it recognizes the change from wep to psk, but not as an unsecured network for some reason. But still wont connect to anything even another local open network. It still has no wifi icon.
    What I forgot to include last night was that it keeps coming up with force close or wait option and is very laggy. The laggy bit I was expecting from others posts about updating. I have only found 1 other post with a similar problem of lost wifi like mine but unfortunately it had no replies.
    Have you any other suggestions?
     
  4. beau420

    beau420 Android Expert

    First thing I would do would be to reflash the phone.

    Download and install SEUS from Sony's website and then turn phone on holding the back button and go through the reinstall.

    Uninstall any security apps you may have installed...

    If it you have tried it on two different working wireless networks and you can't connect to an unsecured network, it leads me to believe you have a problem with the software on the phone....that is why reflashing/reinstalling might be the best route to go.

    I think there is a reset on the phone too....somewhere in About Phone or something.

    Or download and install SuperOneClick and root the phone and then reflash it.

    Just do a backup first.

    Only other thing I could think of is if you are in an area with very high amount of wireless traffic (like an appartment with a ton of wireless routers and phones) If that is the case, try and get the WiFi Analyzer app and look at what channels are less active.

    At my buddies new appartment today there were more than 5 wireless networks on channel 6 and they were all crap signal. I changed his router to channel 14 and now he is the only one listed with a strong signal.
     
  5. babelfish69

    babelfish69 Lurker
    Thread Starter

    Hi beau, thanks for your replies, have now tried it on a couple of different networks, had a fresh download of the OS on a different pc and its still getting force closes and not working, so either it can't cope with 2.1 or its somehow messed around with the phones WiFi driver or something. So I'll try going to the shop see if they can hit it with a bigger hammer
     
  6. matrix243

    matrix243 Newbie

    I have the same problem here. Wifi worked great under 1.6, and immdiately after update to 2.1, it won't connect. I'll add network, and it'll start to scan but then disconnect and show a quick message saying "unable to scan".

    Sounds like a glitch with 2.1.
     
  7. beau420

    beau420 Android Expert

    LOL....it's not a glitch with 2.1

    First, if you haven't already since the upgrade, turn off the phone...remove battery for a minute and restart it. Second, restart the router.

    I know your router hasn't changed or anything, but you might have to temporarily change the password on the router and then change it back to what it was.

    Best way to test to see if WIFI is working is to temporarily change your router to use no password at all. If it connects, then it's not the phone's fault. At that point, you usually just turn the security back on....connect once more and everything works.

    Just go through those steps and don't overthink it.

    It is possible the upgrade to 2.1 failed, but it is much more common that your router is confused about the phone.

    If you haven't checked your 3G connection, make sure you have your APN settings...open Settings->Wireless and Nerwork->Mobile and make sure it has a Access Point Name already created.
     
  8. babelfish69

    babelfish69 Lurker
    Thread Starter

    Hi matrix, sounds like the same problem.
    Beau I understand what your saying but I do think there is an issue albeit not common with the software.
    So far I have downloaded the update on 3 separate pc's and used 3 different routers on different networks. I have changed the type of security, turned it off, changed the address range and still no joy. As matrix said it'll recognise networks and try to scan but fail. And most times hang then force close.
    Matrix, I don't know where you are ( I'm in UK) but I gave up with it and it has now gone back under warranty to be looked at.
    Hopefully within 2 weeks I'll be able to let you know what went wrong.
     
  9. matrix243

    matrix243 Newbie

    Thanks, I'll try all that but it just sounds like a waste of time. It will connect to my home wifi but it won't automatically. And even when I get it connected, 5 minutes later, I'll check it and its disconnected. Never had any of these problems with 1.6.

    And with my work wifi, I don't have access to it, and it won't connect whatsoever, and worked fine right up till the upgrade.

    Does sound like it screwed something up in the phone with the wifi system.
     
  10. matrix243

    matrix243 Newbie

    I hate when you try to gain other features on upgrades and you end up losing what you had.
     
  11. beau420

    beau420 Android Expert


    Good luck.

    I do hope that you weren't updating using PC Companion and you were using SEUS from Sony to upgrade.

    I hope you ran SEUS as an Administrator and I hope you tried flashing using different USB ports. I also hope that you removed any 1.6 apps on the phone when you upgraded to 2.1....or cleaned up the SDcard a bit.

    Hope you tried a reset too at some point.

    If it was just WIFi and data/3g was fine then I would be more sceptical, but if you are getting force closes, something else is going on.

    I hope after each flash you restarted the phone at least 2 times.

    Guess you will have to wait now.....I hope everything works perfectly when you get it back.
     
  12. matrix243

    matrix243 Newbie

    Tried the battery trick, just gives me the "wifi available" with a question mark.
     
  13. matrix243

    matrix243 Newbie

    No way a phone should be this complicated. Guys here at work with BB's connect wifi and emails almost instantly.
     
  14. beau420

    beau420 Android Expert

    First, make sure phone power is at 100 percent....when mine dips below 60 percent it disconnects from my wireless network after about 10 minutes in order to save power....if after that 10 minutes I try and access the internet it will usually restart the wifi, but it takes a good 30 seconds.....it is usually easier to just turn wifi off and back on.

    If I were you I would download a Task Manager app and take a look at what is running in the background.

    Another reason I would lose my wireless connection is when I am using several apps at once that don't require internet access, and in order to make space in the RAM to run these multiple apps, it has dropped my wifi.

    Here is what one guys did:

    Main: RE: Xperia X10 - WIFI connects and...

    What version of Android does it say you have installed?

    Firmware, baseband and build.

    I do believe the first time I flashed from 1.6 to 2.1 I was missing my APN settings altogether and I couldn't connect to my Wifi, after I entered the settings and turned off the phone and turned it back on it was working.

    Take a quick look at this too:

    http://androidforums.com/sony-ericsson-xperia-x10-mini/98694-wifi-issues.html
     
  15. matrix243

    matrix243 Newbie

    Good amount of info there, thanks. I'll look through it.
     
  16. matrix243

    matrix243 Newbie

    Weirdest thing, if anyone cares, I gave up and left my work wifi setup and it eventually connected by itself. Weak signal, but connects on its own now.

    Only thing I can get to work is the outgoing work email. Won't allow tls(always).
     
  17. beau420

    beau420 Android Expert


    Great app here - Wifi Analyzer | AppBrain Android Market

    One really important feature it has is the ability to show all the wireless channels and tell you which one's are used and which one's are open.

    Example....friends apartment building has 5 router showing all on channel 6 and all are weak, but then there is one on channel 2 and one on channel 13...one is his and the other is an open unsecure network. I actually tried to change his router to channel 6 (just to mess around) with the other weak one's and when I did that his showed up...but it went from full bars to half bars.

    If there are multiple routers on the same channel the signal will be affected. Ideally 1 channel per router. Most are set to auto but default to 6 or 7 and don't really change.

    Other things will affect the wifi like cordless phone's. Unplug those.....there are alot of other things that can cause problems, but that WIFI analyzer will let you see the strength and they have different views you can use that show a ton of actually useful information.
     
  18. matrix243

    matrix243 Newbie

    That sounds about right. Here at work, we have a router for each floor. Not sure on the channels.
     
  19. babelfish69

    babelfish69 Lurker
    Thread Starter

    Just an update like I promised.
    It went off the the repair centre allegedly to have all the software stripped off and rebuilt, but learnt today that it is unfixable, no reason given. So it is still a great mystery as to what went wrong with it. They have offered a replacement though.......a Samsung galaxy s.......I think not!
     
  20. beau420

    beau420 Android Expert

    Galaxy S is a pretty sweet phone. But has a lesser camera and to me, feels light and screen is bigger...too big for me, but thinner.

    Too bad it was irreparable.
     

Sony Ericsson Xperia X10 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...