1. Download our Official Android App: Forums for Android!

Support Lots of problems lately on samsung S2

Discussion in 'Android Devices' started by thisandthat, Jan 2, 2013.

  1. thisandthat

    thisandthat Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 2, 2013

    Jan 2, 2013
    3
    0
    5
    Hello everyone, first time poster here, long time lurker. I decided to post here in order to be able to have some help with my Samsung Galaxy S2. I have had the phone for a little over a year now in Canada. I am not exactly sure what the difference between the international version and my version are, but the model on my phone is the GT-19100M. There are just so many different models of the S2 that it becomes a little confusing. So i am currently running the official version of ICS, i have inquired about rooting it for a while now however there are so many version that I just cannot rack my mind over it. I'll start off with the problems.

    Ever since I updated to ICS a while ago the phone began lagging much more. Now the really serious problem is the battery life. I find that the battery lasts about 4 hours if I am lucky. For my usage here, all I use it for is texting, the occasional call, and a little of facebook/instagram (but try to keep it very little). I find that I cannot use the phone too much because it will overheat and then the battery will drain very fast. I looked around and found an app called juicedefender and installed it and it helped the battery life for a few days but it went back to the same. I find that if I do not carry around my charger and hoping to find an outlet that my phone becomes nothing more than a paperweight.

    I am currently running stock ICS 4.0.3. And I have the backlight on the screen to the lowest possible, the wifi turned off when i leave home so it does not search for anything, the screen lock timed to the lowest (15seconds). I feel that this phone is just annoying me so much right now that i want to go back to a flip phone that lasted me like 3 days without charging. I understand that its a completely different ball park. If there are any options or help with this I would gladly appreciate it, any input whatsoever because I am very annoyed with this phone that used to be very good when i first got it. Thank you everyone for your time.
     

    Advertisement

  2. ironass

    ironass Extreme Android User
    Rank:
     #18
    Points:
    1,343
    Posts:
    11,624
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,624
    5,837
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
  3. thisandthat

    thisandthat Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 2, 2013

    Jan 2, 2013
    3
    0
    5
    thank you for your reply, im reading through it right now. I have reset it several times now and the problem persists. I will however try to read and see if I can find some sort of help within that very informative thread.
     
  4. ironass

    ironass Extreme Android User
    Rank:
     #18
    Points:
    1,343
    Posts:
    11,624
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,624
    5,837
    1,343
    Male
    Keeping one step ahead of the tax man.
    Cotswolds, England
    If you have already Factory Reset it and it misbehaved before you re-installed any app's or settings then it could possibly be a bad firmware upgrade download. This can happen with both OTA and Kies updates. You could try re-flashing your M variant firmware for ICS, I9100MUGLD3, Bell or SaskTel using Odin and the instructions under the heading, "My firmware is not eligible for ICS yet but I want it now!", in post #1, here. Alternatively you could take it to a Samsung Service Point and see if they will do it for you.
     
  5. thisandthat

    thisandthat Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 2, 2013

    Jan 2, 2013
    3
    0
    5
    thank you so much for your time, i will definitely try and flash it first. Thank you for the help
     

Share This Page

Loading...