1. Are you ready for the Galaxy S20? Here is everything we know so far!

Low on Space, "System data" huge!

Discussion in 'Android Devices' started by bryandlewis, Feb 16, 2011.

  1. bryandlewis

    bryandlewis Lurker
    Thread Starter

    Hi! I'm a relative Android newbee, had MyTouch 4g for two months.

    I'm having problems with the "Low on space" warning. I have moved all my apps to the SD card which helped for a while but the warning came back. I then started clearing out data, uninstalling apps but days later it still came back. I read about the "diskusage" app and have it installed after clearing more data. What it is telling me is of my total data (1162 MiB) 115 MiB is free, 63.3 MiB is Applications and 983 MiB is "System data". There is no way for me to tell what this system data is made up of. I installed diskusage on my wife's MyTouch 4G and found her system data was only a little over 100 MiB.

    How can I clean up the system data so I get my phone back to normal?


  2. Talderon

    Talderon Android Expert

    Do you do a lot of web surfing? If so, you should try to wipe cache and history from the browser. Also, if you do a lot, get Dolphin Browser HD (free) and set it to cache to the SD card.

    This is the most likely culprit. It was for me a while back on the Nexus One.
    Milo Willamson likes this.
  3. bryandlewis

    bryandlewis Lurker
    Thread Starter

    I'm not a big web serfer, but yes, I have cleared cache and history from the browsers. I used to have Dolphin installed but removed it to try to get my size down.

    983 MiB seems just HUGE! It would take lots and lots of apps to use that much space! I'm wondering if it were some kind of memory leak. I don't understand why it doesn't go away when I reboot.

  4. bryandlewis

    bryandlewis Lurker
    Thread Starter

    Arg! And it is getting worse. I uninstalled Firefox and then did a rescan in diskusage and since this morning my "System data" has gone UP to 1022 MiB from 983 MiB. That is another 39 MiB, for those of you keeping score at home. I'm not doing anything with the phone either other than rebooting, running diskusage and uninstalling Firefox.
  5. Talderon

    Talderon Android Expert

    At this point, you might benefit from a Wipe/reinstall. Monitor everything as you re-install your apps. Something much have gone nuts at some point.
  6. nodrogkam

    nodrogkam Well-Known Member

    check you email settings and attachment download settings. i'd also take a gander at your data usage trends. i wonder if an app is constantly downloading something onto your system.
    if your OS is stock and you haven't rooted/modified it, you shouldnt be experiencing memory leaks. even with memory leaks you often regain the space after a reboot.
    do some more investigating. but it sounds like you should prepare to start from scratch again anyways (even after finding the cause).
  7. bryandlewis

    bryandlewis Lurker
    Thread Starter

    Thanks all. I thought about the email attachments potential, but I don't get many (if any) of those. I never have rooted the phone and it is the stock OS. It is odd that restarting was not clearing out the problem. That "System data" was only growing, never getting smaller.

    I realized I had run out of options so last night I did a factory reset. I was actually surprised how quickly I was up and running again. Any apps I had not uninstalled that were on my SD were still there, of course. Before resetting I saved my contacts to SD so they were there too. Actually, I think it pulled them from Google because I didn't do the "restore from SD". Other than the apps I deleted myself and saved data on games, I think I'm no worse for wear. I'm now running with over a 1000 MB free.

    As suggested, I will monitor this now. If I run into it again, at least I know the factory reset isn't the end of the world.

    Thanks everyone for their help! :D
  8. Talderon

    Talderon Android Expert

    With the strides that Google has been making with the market, saving info and all that, resets are not that bad nowadays.I came from running an HD2 Modded with a MyTouch4G stock ROM to the actual MyTouch 3G phone and once I logged into my google account, all kinds of magic happened, even resetting my wallpapers back.

    It's a nice thing. :D
  9. nodrogkam

    nodrogkam Well-Known Member

    Glad to hear it's worked so far. I actually left android for a while and when i got this phone most of my old apps and all of my calendar/contacts that i always sync with google automatically popped up after about an hour of activation. I think my first day of data use was 50mb just for synchronizing all accounts and stuff...haha.
    The only pain in wiping is re-doing some of the settings and arranging your home screen. Everything else should be quite simple or just require a username and password. :)
  10. bryandlewis

    bryandlewis Lurker
    Thread Starter

    I thought I'd give you all an update. Here it is now June and I still have this ongoing problem. I may be unique because I don't find a lot of info regarding this problem on the web.

    I monitor my memory usage using DiskUsage app. I have to rebuild the phone about every two weeks. If I catch the problem in progress, I can usually stop it from building by rebooting, but the memory usage is still stuck and eventually when it takes off again I run low on memory. I have tried a task manager/killer app with little success. Even if I kill all apps the memory leak continues.

    I finally called T-mobile to see if they could help. After walking me through a whole diagnostic script she finally agreed to send me a new phone. Alas... two weeks later I was low on memory and needed to rebuild again. I stopped in a T-mobile store to explain my problem, but they were totally worthless. I knew a whole lot more than the girl there.

    So I know the problem isn't the hardware.

    Has to be an app going nuts. I want to rebuild from scratch without the apps being restored by my google account. I tried deleting the restore by going to Setting -> Privacy and unchecking the Backup My Setting which was supposed to delete the backup from my Google account. However, when I rebuild the phone it still automatically installed all my old apps. I don't want to have to create a new google account, but that may be my next best option.

    Thanks for listening. If anyone has run into a similar problem please let me know.
  11. lazboy0284

    lazboy0284 Lurker

    Don't feel as though this problem only affects you. I've got it too, and I haven't even had my phone for a week. Good luck finding out anything, I'll try to research as I can too and will default back here with/for findings.
  12. livead

    livead Lurker

    Same issues here and have gone deeper than descriptions here for cleansing. I am on different phone. Evo4gstock with gingerbread updates. :(
  13. http://androidforums.com/android-lounge/404997-internal-storage-issue.html

  14. Matroid

    Matroid Lurker

    I ve got the Desire S and over 1GB of internal storage. I had quite some apps installed but not THAT many. After trying moving apps to SD, delting cache and data files I saw it was useless.
    Using DiskUsage I found out that \data\system data took a huge amount of memory (this you can see also with an unrooted device, but not more).
    My solution:
    1) Root the device (plenty good guidelines of how to do it and it was less painful that expected)
    (Comment: After this, I searched for files acc. nomonkeynodeal with yaffs explorer and ES Explorer, latter allowing also to delete single provider apps; however, it was not before restarting that I miraculously attained possibility for next step.)
    2) Give root permissions (superuser) to DiskUsage and have a look into the \data\system data.
    3) Here I found the folder com.android.htcprofile and inside that folder the file "anr_history.txt" which was 833 MB big
    xdadevelopers show this is a file generated as "Application Not Responding". Deleting it gave me great pleasure and now I have loads of memory available. :p
    This forum gave me the right hints - thanks!
  15. biggamer3

    biggamer3 Member

    same issue, even after a complete wipe, i have 800MB in system data for no reason.

    Do i have to root to get rid of this issue?
  16. biggamer3

    biggamer3 Member

    Oh, I have the Evo3d BTW
  17. thefraj

    thefraj Lurker

    Hi, Like Matroid I had this same issue and it was also with /data/data/com.android.htcprofile/anr_history.txt which had grown to a little over 650 Mb.. deleting it immediately fixed the problem tho you will need root to do this I suspect.

    Not had a chance to see why log had ballooned - deleting it is like treating the symptom rather than the cause - but glad I don't have to a fresh install of Android just yet (though this might not be a bad idea at some point anyway!) (I'm using 2.3.3 on HTC Sensation XE)

    Good luck everyone, hope it is as simple as that :)
  18. ninkynonk

    ninkynonk Newbie

    I stumbled across this thread and thought I'd add that I have the same problem with a Galaxy S3. :(
  19. roelvz

    roelvz Lurker


    I had exactly the same problem with an unrooted Samsung Galaxy S2 running Android 4.1.2 (JellyBean). Storage space was growing by about 30MiB each day. Factory reset didn't help (it cleared the storage, but it still kept growing).

    I started out from the principle that I didn't want to root my phone to fix this... that didn't work.

    So finally I did the following:
    1. Rooted my phone
    2. Gave root rights to DiskUsage (you can do that in the app itself)
    3. Started scanning the different root folders one by one
    4. When scanning /data, I saw that /data/log/ was taking up around 400MiB
    5. There were a lot of .txt.tmp file with the same name in that folder (I forgot to note the name). I deleted all those files using the (downloaded) 'File Manager' app. Please note that I did not delete all files in /data/log. There were 21 small files with other names. Maybe deleting them is no problem, but I don't know enough about the operating system to be 100% sure, so I just left them.
    6. I now forced DiskUsage to do a new scan and system data was now only 30MiB, yay :). Watch out, if you don't force DiskUsage to do a new scan, it will still show the old scan (I just restarted my phone after I deleted all files).

    Conclusion: I did not succeed in fixing this problem without rooting my phone. After I rooted my phone, I succeeded in less than 30 minutes. This is not how it should be! People should not have to root their phone to fix problems like this. Anyway, I consider myself to be a nerd now :).
    cobot likes this.
  20. Raptor_Jesus

    Raptor_Jesus On Probation

    I used this Root Cleaner app (quick clean was enough) and got my free space back.
  21. pemills

    pemills Lurker

    I am having the same issue with a Galaxy S2 (vodafone) looked at the root cleaner app but it states it will only work on rooted devices which I do not want to do, I have had the phone now for two years and it has performed well until the JB updates, for some reason I received two JB updates, not sure what were the differences as it said it was version 4.1.2 on both occasions.
    The space issue is becoming a real issue as any update to my apps over 7 or 8 MB fail due to 'insufficient space available' I have uninstalled loads of apps, moved all the apps that will move to SD to the SD card and still the space is decreasing, what the hell is going on!! sometimes I get a 'invalid file package' message which I have put down to insufficient space to store the downloaded file not completing.

    I will monitor this thread in the hope that someone out there finds a solution before I go down the reset option which I am really loathed to do as it took ages to get the phone to look and work the way I wanted it to, apart from the low space issue of course!!
  22. cobot

    cobot Lurker

    I just wanted to say thanks to everybody in this thread! I have the international unlocked Samsung S2 on 4.1.2 and was constantly getting the "Insufficient storage" errors. I rooted my phone (so easy!) and instead of having 200MB available, now I have almost 1GB from deleting all those logs mentioned above (insane!).

    Really amazing how this stuff isn't cleared out automatically by Android or Samsung (whoever is responsible for writing the logs). ..I've been having issues the past week or two with my phone and I suspect it could be due to the low space remaining so hopefully this resolves it.

    Thanks again!
  23. jgramp

    jgramp Lurker

    I installed the free version of SD maid onto my rooted Samsung S2, located the data/log folder and deleted 5GB of log files from this folder - everything in it (there were a LOT of small ~1.4MB files).

    My system data in the DiskUsage App has shrunk and my phone is working properly again :)

    I didn't need to reinstall anything either!!
  24. damianoz

    damianoz Lurker

    You don't have to root your phones to fix this problem. Just dial *#9900# on the phone and then select from menu - delete dumpstate/logcat. I tested this solution on my SGS2 and it works. :)
  25. gben01

    gben01 Lurker

    Wonderful - that worked a treat. It's a shame I didn't know this 3 reboots ago. Yes the reinstall is quick and easy, but I keep loosing game progress which is sooo irritating. And like many - I did not want to 'root' the phone.

    My space is back, and I'm a happy S3 user again.

Share This Page