1. Are you ready for the Galaxy S20? Here is everything we know so far!

Low-quality MMS

Discussion in 'Android Devices' started by gringostar17, May 30, 2017.

  1. gringostar17

    gringostar17 Newbie
    Thread Starter

    Is there a way to make the stock messenger application send pictures and videos uncompressed? I can't find an option on my Verizon phone.

    1. Download the Forums for Android™ app!


  2. mikedt

    mikedt 你好

    You very likely can't, because Verizon like just about all carriers limits the size of MMS to 300kb or so.

    MMS is really a legacy thing from the era of dumb-phones and feature-phones. You want to send big uncompressed images and videos, you may have to find another more modern messaging method, like WhatsApp or something.

    MMS was originally designed and intended to work with limits of what phones like this could do, the Sony Ericsson K700 with VGA camera from 2004, and the MMS specification has never been changed or updated since.
    #2 mikedt, May 30, 2017
    Last edited: May 30, 2017
    tube517 and Snakeyeskm like this.
  3. kate

    kate Dreaming of Bugdroid.

    Video/picture texts (MMS) are heavily compressed when sending because most/all carriers have a size limit for messages.

    Check your messaging apps settings, some allow you to set the maximum size of MMS so you might be able to increase the quality a little. But if it's over the limit the carrier might not send it, or compress it further.

    If your messaging app doesn't have that setting you can use Textra:

    The limit is determined by your carrier and your friends, you can try no limit and if it doesn't work go down from there.
    tube517 and mikedt like this.
  4. gringostar17

    gringostar17 Newbie
    Thread Starter

    Thanks for the responses. This is definitely a bummer.

Samsung Galaxy S8 Forum

The Samsung Galaxy S8 release date was April 2017. Features and Specs include a 5.8" inch screen, 12MP camera, 4GB RAM, Exynos 8895 processor, and 3000mAh battery.

April 2017
Release Date

Share This Page