1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support [LRShinePlus][Android2.1]Unable to use app accessing Internet on wifi

Discussion in 'Android Devices' started by zhuanyi, Sep 13, 2011.

  1. zhuanyi

    zhuanyi Newbie
    Thread Starter

    Hello all,

    I have recently had a pretty weird problem with my new LG Shine Plus which I hope you guys could help, here is what I did:

    When I first sign up for the phone, I purchased a one month data plan just to try things out, everything was great and I was able to use the data plan and wifi when I am at home and downloaded quite a few applications and they all worked perfectly.

    I cancelled a data plan since it cost quite a bit, however I am a student and there are both wireless networks on campus and in my residence room. As a result, I have turned off the Mobile Data Networks.

    After that, all the applications, for some reason, stopped working. When I opened up the Advanced Task Killer Free, for example, it will show You must have INTERNET and ACCESS_NETWORK_STATE permissions in AndroidManifest.xml and when I tried to hit KILL selected apps, it will crash. On Bloomberg, it says android.Manifest.permissions.INTERNET permission not set in AndroidManifest.xml file before crashed, and on a whole bunch of other apps, they just crash as soon as I open it up.

    However, the most interesting bit is, I was still able to access the Internet on my mobile browser (tried several website that I know I did not go before just to make sure those are not cached pages) on wifi and I can access Android market on wifi as well.

    So I turned Mobile Data Networks back on in hope that would resolve the problem, but the same thing happened even with the Mobile Data Networks turned on and now I am unable to use any apps I installed :( I have verified that I have the apn set up properly in there.

    By the way, I have link2sd installed, but it was installed while I was using the data plan, and it worked fine then, I have also had AdBlock installed, which I have already uninstalled it and even apps without any add (dropbox) is crashing at the moment as well.

    Please help!



  2. MisterPuzzler

    MisterPuzzler Newbie

    Have you tried uninstalling the apps and then reinstalling them via downloading them off wifi?
    zhuanyi likes this.
  3. Burned

    Burned Member

    Be sure to get the data access blocked by your cell provider. Even though you are not paying for a data plan, your phones apps will still access it and you will get a nasty phone bill.
    zhuanyi likes this.
  4. zhuanyi

    zhuanyi Newbie
    Thread Starter

    I actually ended up just wiping out the phone and reinstall every single app I have...took me several hours but everything seems to work now, thanks a lot for your help!
  5. zhuanyi

    zhuanyi Newbie
    Thread Starter

    Thanks, it seems when I opened up my account, Telus has already put the data block on it, but thanks a lot for your reminder :)

Share This Page