1. Are you ready for the Galaxy S20? Here is everything we know so far!

LT7033 USB Windows Drivers

Discussion in 'Android Devices' started by mavrikmeercat, Dec 19, 2012.

  1. mavrikmeercat

    mavrikmeercat Android Enthusiast
    Thread Starter

    Hey all, I wanted to make a place for discussion on the windows drivers because there has been much on the matter. Please post here for help or your experience

    So I emailed Curtis international asking for the drivers for our tabs (and also commented on their crappy website lol) and they replied with an attachment. they are below along with some others we have found VV

    Also some of our users have done some scouring on the web and have come across an XDA post with drivers for the chipset in our LT7033


    Thanks to dimitriz for finding the post and to SferaDev over in XDA for posting there and giving us root

    Edit; for instructions on how to install these drivers, download them here and then go here an follow the step-by-step
    Thanks for the detailed guide SuperNoober!

    Attached Files:

    SuperNoober, bxluvnat and blueracer90 like this.

    1. Download the Forums for Android™ app!


  2. CheezBalls

    CheezBalls Lurker

    I'm new to unlocking. After starting the run me, how do I do the first step?
  3. Alexh42

    Alexh42 Member

    I cannot for the life of me get these drivers to load for my girlfriend's Curtis Klu LT7033... I've tried 3 different computers and says that these drivers are not compatible with my device. This is the closest I've gotten and it recognizes the device as a rockusb device but it isn't installed correctly. When I run the runme.bat file it says "daemon not running. daemon started on port 5037. daemon started successfully" and the just sits there.. what am I doing wrong?


    Now it actually says "Driver is not intended for this platform" on my error message

    Attached Files:

  4. Alexh42

    Alexh42 Member

    aaaaaand it's being recognized as an unknown device in my device manager..
  5. SuperNoober

    SuperNoober Member

    there are step by step instructions in post 4 of the thread:
    A Step by Step Guide to getting Amazon Appstore, & Google Play on a Curtis Klu LT7033
    You must have the adb drivers properly loaded with the driver status saying the device is functioning properly before you try to run the root tool kit runme batch file. Until then there is no real connection between the pc and the tablet. When you run the runme.bat file you will notice that the 1st thing listed as requirements is instal the drivers of the folder. This is what your failing to do.

    You will notice when you extracted the ADB zip that two separate folders are created, one for AMD based processors, and one for intel based processors i386 you need to point at the correct folder when you try to upload the drivers
    WhitneyLeigh86 and mavrikmeercat like this.
  6. mavrikmeercat

    mavrikmeercat Android Enthusiast
    Thread Starter

    OP is updated with your guide SuperNoober, I'll leave the drivers in place for search engines since they seem to be so scarce on the web. You might want to add [GUIDE] "how to root" to to your heading and we can request a moderator to sticky it to the top of the threads so our newcomers will go there first.

    Thanks for your contribution brother!!
  7. SuperNoober

    SuperNoober Member

    God I'm glad your back! I was starting to feel like everybody fell off the edge of the planet.

    Any news from the ROM_ulen front?
  8. mavrikmeercat

    mavrikmeercat Android Enthusiast
    Thread Starter

    Rom is done but still trying to get cwm ported. This recovery is being a PAIN!!

    oh and the wife bought me a samsung galaxy tab2 10.1 32gb for christmas lol, so you know what i've been messing with the past few days haha... already got CWM touch and CM9 official on it.
    SuperNoober likes this.
  9. SuperNoober

    SuperNoober Member

    Open ES File Explorer and click...
    (3 vertical dots) > Settings > Root settings
    Staring at the bottom uncheck the bottom 3 boxes,
    Leave the next box, Up to Root, checked.
    and then uncheck the top box.
    Back out of ES File Explorer

    While you were doing that you may have had the program asking for super user access. If so, you may also have noticed that even if you picked deny access the program was granted super user privileges anyway. Even the most careless of system administrators only grant themselves super user access long enough to accomplish the task at hand, and then they turn super user access back off. Unchecking all but Up to Root will allow you to see your entire file structure without the risk of accidentally erasing something vital, and turning your tablet into a paper weight.

Share This Page