1. Are you ready for the Galaxy S20? Here is everything we know so far!

M8 file copying to MBP losing my mind !!

Discussion in 'Android Devices' started by omoanya, Aug 25, 2014.

  1. omoanya

    omoanya Member
    Thread Starter

    Can it possibly be so darned difficult to have a simple reliable way to mount my my phone on my MAC and navigate and copy files /// WHY ??

    HTC Sync -- is suuuuper lame it wants to copy everything from my 64gb phone to my computer --- I don't want that I just want to navigate the phone and copy/move files that I want.

    AIRDROID was cool but won't let me navigate and copy and only sees photos in one location.

    Android FILE transfer - NO DEVICE FOUND when device is plugged in !

    Easy Sync -- won't mount !


    I have debugging enabled but still phone will not mount

    What is going on ????
    HELP !
     



    1. Download the Forums for Android™ app!


      Download

       
  2. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Android File Transfer used to work 100%.

    Blame Apple, they started changing things so that sometimes it works, sometimes it doesn't.

    I think that you're probably stuck with needing wifi to transfer files - until your next OS X update and then try AFT again.

    Meanwhile, try AirDroid.

    And yeah, I have an MBP as well so I feel the pain (sometimes).
     
  3. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I think it was Mavericks broke AFT for me, though I skipped the Lions so they may also not have worked. But there's a workaround using an app called DriveDroid. There's some setting you need, which I'd have to look up,, but that fixed this problem on my M7 (even when running a port of the M8 ROM).

    Edit: ah, tried searching for the settings and it seems it requires root.
     
  4. Rdjr74

    Rdjr74 Android Enthusiast

    I use dropbox. Downloaded it on my mac. Works just fine. I'm sure you can use google drive as well.
     
  5. omoanya

    omoanya Member
    Thread Starter

    Yes, I am using dropbox as well - at least its reliable. But I really need a way to navigate the M8's folders - I have a lot of different audio and video folders set up and am modifying them daily (I'm a musician so I load practice mp3s of my rehearsals )
    Next phone will be only a usb drive bootable phone ...
     
  6. omoanya

    omoanya Member
    Thread Starter

    Airdroid is useless to me as I get a fail eachtime i try to upload a file to my SD card. It also reads the wrong camera folder so I cant use it for pictures. Android File Transfer siumply won't connect half the time. So here we are with a 600 phone and 2K laptop and am unable to transfer files easily to where I want them. Nice HTC/Google?Android or whoever the hell thought up these restrictions ... ON the positive side, I did go into terminal and disable htc sync installation disc from showing up EACH TIME I PLUG IN MY PHONE TO MY COMPUTER ! -- What is up HTC !?
     
  7. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Yep.

    A lot of us were unhappy when Google chose to support the MTP (media transport protocol), a Microsoft favorite - in fact, all of us using OS X and Linux.

    The Linux community caught up and now the storage transfer scheme is no problem - counting Windows, that's two out of three.

    Grab a file manager - X-plore is pretty good - and look at where your pictures are stored - the top of the directory structure is named DCIM - the original standard for digital camera images.

    Once upon a time, you could plug in any Android and iPhoto would recognize that.

    Four years ago, right after the Tiger release, came an Apple update so that no longer worked.

    I have an Olympus camera that worked since the iPhoto beta that stopped being recognized 4 years ago - when Apple decided to shut out Android. Check and search the Apple support discussion forum if you don't believe me - a lot of us were pissed off, while the Apple shills insisted in a stunning display of revisionist history that they never supported that camera industry standard.

    My camera was listed FIRST as supported by iPhoto. FIRST.

    Why did Apple do that?

    iPhone competition.

    Why can't you upload files via AirDroid or anything else?

    Google is your friend - Apple no longer supports uploads to unknown servers.

    Another anti-competitive tactic that used to work in OS X since before the public beta.

    Plug your M8 into a Snow Leopard machine and watch Android File Transfer just work.

    Plug it into a Tiger machine and watch wifi FTP, WebDAV and AirDroid just work in both directions.

    Plug it in to Linux or modern Windows and watch it just work.

    I have 6 Macs in my house, going all the way back to Jaguar. I know what they did and when.

    When all it takes is an Apple update to increase their anti-competitive stance against Android in favor of the iPhone, it's completely obvious that your beef is not with Google or HTC, no matter how strongly you feel.

    Sorry but there it is.

    Meanwhile, you're going to have to try the earlier suggestion to transfer via Dropbox or Google Drive.

    Just like my wife with her Mac.

    She used to just plug in her Android.

    Until she took an Apple update.

    Why build quality into an iPhone when all you have to do is violate standards from two separate industries and convince people that the evil you did is someone else's fault?

    This is from someone who suffered the same thing trying to maintain his legacy film editing on a Mac -



    Good luck my friend!

    If you don't like the cloud solution and want to know how to run Linux in a virtual machine on your Mac to not let the bastards win and transfer your files that way, let me know. :cool:
     
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    By the way - to copy files from your Mac to your phone, turn on file sharing on your Mac, get X-plore, go to the LAN storage (tap the X-plore on the upper left to get to the panel shown), tap scan and choose your Mac.

    1409425788896.jpg

    It's a dual pane explorer, choose your Mac in one, the phone destination in the other and tap Copy.

    You can try it the other way, I'm not near my desk to check it for you at the moment.
     
  9. I would like to learn how to run Linux in a virtual machine so I can use it to transfer files to my phone. I just bought a mac book and this is my only complaint with it so if theres a way to easily boot into ubuntu or some other distro to transfer files i would love to learn how because this is one of the major things i do with my laptop. Any instruction would be greatly appreciated. Thanks.
     
  10. gibbs1984

    gibbs1984 Android Expert

    Just look for a video on YouTube, might best off using a LiveCD.
     
  11. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Get https://www.virtualbox.org/

    Grab the iso install file for http://www.ubuntu.com/desktop

    Attach the iso as a virtual CD - the setup wizard will help you - and install from there.

    After installation, look for the VirtualBox Guest Additions, you'll be prompted to install those as well.

    Learn the tools at the bottom of the VirtualBox window so that it owns the phone when you plug in, and copy / move files to shared Mac storage that you'll set up.
     
    BRAINZ2013 likes this.
  12. BRAINZ2013

    BRAINZ2013 Extreme Android User

    Also make sure you have a WiFi good connection if it drops the virtualbox will also drop giving you error messages . it was a pain at first but when you get to know it hey its your best friend . so tell the friends there is a new best friend that arrived in town.
     

  13. So I made it as far as downloading the two files hahah. Do you think you can expand on the next three steps?
     
  14. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    pharaohsupreme likes this.
  15. Ok now I've made it as far as installing ubuntu in the virtual box. I ignored the parts you mentioned. Nothings coming up when I plug my phone or external hard drive in though. Thoughts?
     
  16. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Either under the Device menu at the top, or the USB icon at the bottom, attach the device to the virtual machine.
     
    pharaohsupreme likes this.
  17. When I click on my phone under the device menu it just opens android file transfer and does nothing in ubuntu.. thoughts?
     
  18. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Open the file browser in Ubuntu. If running the Gnome desktop (default), move your mouse to the upper left corner of the Ubuntu desktop, choose applications.
     
  19. Still cant seem to get it to work.
     

HTC One M8 Forum

The HTC One M8 release date was March 2014. Features and Specs include a 5.0" inch screen, 4MP camera, 2GB RAM, Snapdragon 801 processor, and 2600mAh battery.

March 2014
Release Date
0
Reviews
Loading...
Similar Threads - file copying MBP
  1. matrixebiz
    Replies:
    1
    Views:
    217
  2. countryblue
    Replies:
    3
    Views:
    435
  3. Mysteryman
    Replies:
    3
    Views:
    562
  4. Ian Preddy
    Replies:
    13
    Views:
    4,188
  5. FeriM
    Replies:
    11
    Views:
    663
  6. SYOB SYOT
    Replies:
    13
    Views:
    3,148
  7. tommydog1
    Replies:
    2
    Views:
    1,327
  8. lordpuffer
    Replies:
    5
    Views:
    1,262
  9. drblau
    Replies:
    0
    Views:
    1,829
  10. Biffos
    Replies:
    8
    Views:
    2,048

Share This Page

Loading...