1. Download our Official Android App: Forums for Android!

magnetometer troubles

Discussion in 'Android Devices' started by Belsatzar, Jan 13, 2010.

  1. Belsatzar

    Belsatzar Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jan 13, 2010

    Jan 13, 2010
    4
    0
    5
    i've been a (mostly) happy user of the milestone, as it is called over here, but in the past few days i noticed a problem.
    the compass in the phone is not only off, but virtually broken. it detects a constant reading "to the upper left", which simply overrides the earth's magnetic field. so, no matter how i turn the phone, north is always between one and two o'clock. by using the amazin tricorder app, i was able to find out that the magnitude of the reading differs significantly depending on the orientation of the phone, reaching almost "100" in the max, and about "65" when the phone is 180
     

    Advertisement

  2. teschoen

    teschoen Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    149
    Joined:
    Dec 29, 2009

    Dec 29, 2009
    149
    1
    36
    did you spin the phone on all 3 axis?
     
  3. Belsatzar

    Belsatzar Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jan 13, 2010

    Jan 13, 2010
    4
    0
    5
    you mean, to reset the magnetometer? or to figure out the exact position of the "subjective north"?
     
  4. Belsatzar

    Belsatzar Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jan 13, 2010

    Jan 13, 2010
    4
    0
    5
    can noone help me? any suggestions?
     
  5. cimisman

    cimisman Lurker
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 16, 2009

    Dec 16, 2009
    9
    0
    25
    Did you move your phone in a figure 8 pattern to set it?
     
  6. Belsatzar

    Belsatzar Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jan 13, 2010

    Jan 13, 2010
    4
    0
    5
    yes, i drew eights in all axis. but nothing changed at all.
     
  7. Sempai

    Sempai Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 24, 2010

    Jan 24, 2010
    1
    0
    5
    I don't know if this will help you but I was experiencing the exact same behavior on my Motorola Droid ... I was extremely frustrated when neither spinning nor figure 8's solved the problem. I was disappointed that the answer wasn't here and thought I might have been headed for a hardware swap when I started to suspect my compass app (marine compass). I uninstalled it . . . google sky started responding properly again . . . and the replacement compass app ( by snaptic) is now working perfectly. Good luck.
     

Share This Page

Loading...