1. Android Forums is going down for maintenance at 6:00PM Central time. We apologize for any inconvenience! Shouldn't be down too long.
  2. Check out our app, Forums for Android! Download and leave feedback here!

Support Mail with Exchange is extrememly slow

Discussion in 'Android Devices' started by cityguru, Jun 4, 2010.

  1. cityguru

    cityguru New Member
    Thread Starter
    5

    Jun 4, 2010
    2
    0
    5
    This is crazy, i just got the EVO i synched my mail, and everytime i get a new email, i am not kidding it takes almost one minute for the email to display. everything takes an insane amount of time in this program. everything else is speedy and fine but the mail program.

    Gmail comes in and can be read quickly and easily but not the Activesync Exchange Mail.

    Anyone else experience this same problem and if so is there a solution for this?

    If the email is downloaded already how come it takes so long to open or reply to an email?

    Anyway majority of time i press another button, everything freezes and then i get that non responding warning asking if i want to wait or force quit.

    Any help from fellow exchange users that would be great,

    btw for exchange hosting i use intermedia
     

    Advertisement

  2. tama2112

    tama2112 Well-Known Member
    15

    Jun 7, 2010
    48
    0
    15
    I have been noticing the exact same thing. I can open the email quickly, but it takes FOREVER for the text to show up! I'm using ActiveSync with exchange.
     
  3. tama2112

    tama2112 Well-Known Member
    15

    Jun 7, 2010
    48
    0
    15
    Is anyone else experiencing this? My Evo is lightning fast, but for some reason Mail using Exchange ActiveSync is SLOOOOOOOOOOW. It takes forever to open new emails - even when i have full bars of signal..

    Why is this? Do i have too many emails in my inbox?
     
  4. hwipark

    hwipark New Member
    5

    Jun 18, 2010
    4
    0
    5
    Try clearing the MAIL cache. That should speed things up.
    Menu>Settings>Applications>Manage Applications> Mail> Clear cache.
     
  5. tama2112

    tama2112 Well-Known Member
    15

    Jun 7, 2010
    48
    0
    15
    My Cache was 1.75MB. Do you think this was the problem? Do i need to clear this every couple of weeks?
     
  6. cjnyc

    cjnyc Member
    15

    Jun 5, 2010
    11
    0
    15
    I'm also having this problem. It can take up to 20 seconds to open the email list or a simple text email. I've never had an issue like this going all the way back to my Treo. Exchange is vital for me. Clearing the cache is no help. Is the Evo not properly managing how it keeps Exchange mail in memory? Is the HTC email application at fault? Any help would be apprecaited!!!

    Thanks in advance!
     
  7. dels28

    dels28 Well-Known Member
    16

    Jun 14, 2010
    57
    2
    16
    NW Indiana
    I think this is a major concern of those who use the default mail service. I know my IT guys have went to K-9 mail which they say retrieves the mail much faster. There definitly is a delay, I have noticed from my work account as long as 25 minutes from the time the message is sent until it reaches my phone. I have changed settings to retrieve every 5 minutes on my three accounts which has seemed to help, but it is not on the same level as my old curve 8330 used to be. I live with this shortcoming giving all the other things I love about the phone.
     
  8. cjnyc

    cjnyc Member
    15

    Jun 5, 2010
    11
    0
    15
    My problem isn't actually with delivery, which is actually as quick as a Blackberry for me. Once the email is delieverd and I go into the actual HTC mail client, it could take up to 20 seconds to open the email list and then another 20 seconds to simply open the email, which is horrible.
     
  9. tama2112

    tama2112 Well-Known Member
    15

    Jun 7, 2010
    48
    0
    15
    This is exactly the problem i am having too.. Interesting that my brother has the HTC Incredible with Verizon, uses the exact same Exchange Server and the HTC default mail service - and does not have this problem at all...
     
  10. cjnyc

    cjnyc Member
    15

    Jun 5, 2010
    11
    0
    15
    I found that if I change the syncing to last 30 days instead of "All", it fixes all my issues. Must be a memory thing.
     
  11. htcevolee

    htcevolee Well-Known Member
    73

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    Yes I only do 15 days which limits what it needs to keep up with and refresh. I only download partial emails not all unless i need the whole thing.
     
Tags:

Share This Page

Loading...