1. Are you ready for the Galaxy S20? Here is everything we know so far!

Many Google features missing on UK Milestone?

Discussion in 'Android Devices' started by celios, Dec 4, 2009.

  1. celios

    celios Well-Known Member
    Thread Starter

    1. Download the Forums for Android™ app!


  2. deadite66

    deadite66 Well-Known Member

    likely they are there just forgot to list them, contacts is part of AOSP so moto' didn't have to pay to have it.

    EDIT: looked at a milestone review on youtube and i can see the calendar icon.


    Attached Files:

  3. Spiky

    Spiky Lurker

    I can confirm I have Gmail, Google Calendar, Youtube, Google quick search box, and Google maps pre-installed on the Milestone I have...

    Need to check google lattitude - not seen or used this

    Hope this is helpful!
  4. celios

    celios Well-Known Member
    Thread Starter

    Very helpful, thanks Spiky. Where did you get your Milestone?

    Also, can you see if you can access paid apps in the Android Market...?

  5. Deleted User

    Deleted User Guest

    Do you have different stock wallpapers then the DROID? I wish there was a way to get them off and post them.
  6. MartinodF

    MartinodF Lurker

    Every app listed above is present, except for Google Navigation (which is not yet available outside US) and Google Voice Search (i can't understand why).
    I was able to install Voice Search from a Droid Dump, though it's not so straightforward (you have to un-odex it). Also, the latest Maps version hacked for Navigation outside US works, so you can forget about that crappy MotoNav which is included.

    The Droid wallpapers i saw in many screenshots are not there in the Milestone, so at least some of them are different.

    Hope this helps ;)
  7. celios

    celios Well-Known Member
    Thread Starter

    Yep, I got my Milestone on Friday and everything is working well.

    I seem to have google voice search (you do mean the option to do a search by using speech to text right?), this is available from the homescreen and from inside Google Maps.

    The bad news is... the auto-focus bug on the camera is present, and we have just entered a 'bad cycle' on Friday 11th Dec which will last for 24.5 days. When I first fired my Milestone up on Friday the camera AF was working fine, on Saturday it stopped working and is now working maybe one time in 12 attempts. The v2.01 firmware fixes this I think, so hopefully that will be making it's way to the Milestone ASAP.
  8. mpovolo

    mpovolo Member


    Can you tell me how you installed the voice search? Mine seems to be missing. Also tried a keyboard app that takes voice input and it says the voice libraries are missing. Did you get those installed also?
  9. Afront

    Afront Member

    Voice Search came pre-installed on my Milestone (UK), however I noticed there was an update in the Market so applied it. This broke Voice Search but fortunately there's a roll-back option to revert the version that works.

    As for diffs, well I blogged this yesterday:

    What you get on the Droid but not on the Milestone:

    • Amazon MP3 Store
    • Google Maps Navigation
    • Facebook
    • 16 GB microSD card (the Milestone comes with an 8 GB card)
    What you get on the Milestone but not on the Droid:

    • Multitouch pinch and zoom
    • A pair of earbuds

    For the full review of the Milestone, see:

    Motorola Milestone UK: First Impressions | Pansentient League - a Spotify Blog
  10. LEP

    LEP Newbie

    If you want to get Google Maps Navigation just follow this.

    1. Open Market - search SpeechSynthesis Data Installer - install

    2. Download maps3.3.1-by-directions-root-2.apk from maps3.3.1-by-directions-no-root-2.apk ... at uploaded.to - Free File Hosting, Free Image Hosting, Free Music Hosting, Free Video Hosting, ... to your computer

    3. Copy maps3.3.1-by-directions-root-2.apk to Milestone with USB cable

    4. Install it on Milestone ( use any file explorer to open it, I used Astro )

    Once its done you will have 2 google maps icons. One is the old one and the other is the new one with turn by turn voice navigation.[​IMG]
  11. linuxwarrior

    linuxwarrior Newbie

    This is actually super cool :), worked for me here in Buenos Aires, I need to go for a ride and check it out ... however it's almost 1am ... an tomorrow is a work day ... :cool:

    Thanks a lot LEP!!

    If only we can get Voice Search now :rolleyes:
  12. LEP

    LEP Newbie

    Yeah, Google voice search would be good
  13. Jus

    Jus Lurker

    For some reason, I'm not able to download the .apk file. Clicking on the "free download" button just opens up another webpage. Can someone please assist or just send me the file? Thanks!
  14. LEP

    LEP Newbie

    When it opens up the webpage, you need to wait the 10 seconds and download the file that says 'free download'. Its that simple.
  15. Jus

    Jus Lurker

    Thanks, and that is exactly what I did but for some reason, it just directs me to another webpage but no download. Could the file have been removed in the meantime?
  16. xenomorph

    xenomorph Lurker

    I just downloaded it, no problem. Thanks LEP.
  17. barisi101

    barisi101 Lurker

    Just downloaded the file. Try changing your browser co I discovered that it doesn't download in opera. I downloaded it with Firefox so switch browsers and you should be able to download it also.
  18. lonesomefolly

    lonesomefolly Newbie

    I cant find the voice navigation option in the maps application, help?
  19. MarioNico

    MarioNico Member

    What maps are those.. EUrope?

    EDIT: just found out.. it works just fine with the routes for all EU. TNX.
  20. Richdog

    Richdog Member

    AWESOME... you're a legend. :D
  21. slatyford

    slatyford Well-Known Member

    well tried to download this but it say windows can not open the file unrecognised
  22. Richdog

    Richdog Member

    You are trying to install the file on your... Windows PC?

    It's unrecognised because it's meant to be installed on ANdroid. Put it on your SD card and then run and install it from the phone.
  23. xjester

    xjester Lurker

    Hi LEP , thanks for the awsome Navigation.

    The turn by Turn Voice is not working for me, sometimes the voice instructions come after the turn or just at the start , or somewhere in between when i take a random turn, All these are random instances and i have not been able to find any correlation between when the Voice speaks to any upcoming turn or instructions.

    Even though the written instructions are a plenty but somehow the Text to Voice does not always speak those. Any Idea why this should be happening ?
  24. duckmanrox

    duckmanrox Lurker

    how do i get youtube on my European milestone??
  25. Szadzik

    Szadzik Extreme Android User

Motorola Milestone Forum

Features and specs are not yet known.

Release Date

Share This Page