1. Are you ready for the Galaxy S20? Here is everything we know so far!

market application doesn't work :(

Discussion in 'Introductions' started by amandaa012, Sep 18, 2011.

  1. amandaa012

    amandaa012 Lurker
    Thread Starter

    I'm hoping someone can help me out, I have a Sony Ericsson Xperia and everytime I click on my market application and try to login with my google account, it says "can't establish a reliable data connection to the server." i am 100% sure i am connected to the internet on my phone as i am able to use it on any other site and application except for the market one. what do i dooo?
     

    Advertisement

  2. scary alien

    scary alien not really so scary
    Moderator

    Welcome to the AndroidForums, Amanda.

    Sorry to hear you are having data connection issues :(. Normally, I'd point you towards your device's specific forum, but there are lots of Sony Ericcson Xperia models here at AF (LOL, I count at least 13 ;)). Here's the main forum page with all of the devices in it:

    http://androidforums.com/

    However, there are a couple of things you could check on:

    Are you using wi-fi or 3G? Try toggling each off and back on (I often find I have Market issues if I've been using 3G and then switch to wi-fi--its like the Market app needs to "disconnect" from the previous transport method (3G) before it can switch to using wi-fi).

    Try using just one or the other. If you are using 3G, go to your Settings app -> About phone -> Status -> Signal strength. A "good" signal is -90dBm or "lower" (I say lower in quotes because these are negative numbers; -80 is better than -90 in this context); an iffy signal would be (in my experience) -95 and above. Don't pay any attention to the number of bars you have--its really all about the signal strength.

    Of course, for wi-fi, that's a little different. The closer you are to your wi-fi router, the better.

    You could also try putting your phone in airplane mode and then back on (out of airplane mode). This is done either via a 3G widget or from Settings -> Wireless & network settings -> Airplane mode. This should also turn off your wi-fi when you do this--you can still turn wi-fi on even when you are in airplane mode. Don't forget to turn it back on ;).

    I'm guessing that you've also tried a fresh reboot, too (let things "settle down" for a minute or two after you've rebooted so that all the background apps get launched and your phone connects back up to 3G (or wi-fi if you are using that).

    Good luck and I hope you figure this out.

    Cheers!
     
Loading...

Share This Page

Loading...