1. Are you ready for the Galaxy S20? Here is everything we know so far!

Market apps not downloading?

Discussion in 'Android Lounge' started by gezh, May 31, 2010.

  1. gezh

    gezh Member
    Thread Starter

    Is it just me, or are apps not downloading from the market?

    I have two devices (Hero on Orange, and Nexus rooted) and neither can download apps from the market suddenly. For example, I just tried Toss It, and the screen says 'Starting download' and it just sticks there. Same for upgrades to my existing apps.

    What's going on?

    1. Download the Forums for Android™ app!


  2. zedthegreat

    zedthegreat Lurker

    [FONT=&quot]I had a similar issue. I am based in Scotland and had an account officially as 'googlemail.com' before the switch to 'gmail.com'. However I had always logged in as 'gmail.com' and Google accepted this. I had to go through my Google acc on my PC and sort all the settings to end 'gmail.com' then to get my phone to sync again I had to reset and sign in to my phone as if first time with 'gmail.com'. This allowed me to download again.

    Of course this may be of no use to you at all but thought I would through in my experience.[/FONT]
  3. gezh

    gezh Member
    Thread Starter

    Ah... that just might be it... I only switched to gmail 2 days ago!

    So it's not quite as straightforward as Google make out!

    Any ideas how I reset my email address on a 1.5 device? I can't find any option to sign out of the Gmail app, or a setting where I can edit the email account.
  4. IOWA

    IOWA Mr. Logic Pants

    Go to settings > applications > manage applications. Clear the cache for gmail, market, gtalk, and google maps. Then open the market, and it will have you sign into gmail again.

    Tapatalk. Samsung Moment. Yep.
  5. gezh

    gezh Member
    Thread Starter

    Hi, thanks for the tips.

    I've done all the clearing out, but now when it asks me to sign in to Google mail again, it always returns an error:

    "This could be a temporary problem or your SIM card may not be provisioned for data services. It if continues, call Customer Services".

    It happens every time - I'm stuck!
  6. IOWA

    IOWA Mr. Logic Pants

    That sounds like a carrier issue. Do you have data at all?

    Tapatalk. Samsung Moment. Yep.
  7. mrspeedmaster

    mrspeedmaster Android Expert

    Many apps are restricted by carriers. I normally remove the SIM, disable the APN and use only wifi. That bypasses the carrier-specific restrictions in the marketplace.
  8. Salad

    Salad Newbie

    I recently had a nightmare with the 'Download Unsuccessful' bug caused by the date/time being auto-synced wrong. I tried everything under the sun and only a factory reset finally solved the problem. Factory resets are a pain in the ass, but it looks like it's the only way to fix these issues.

    I would recommend trying all the various other fixes first, just in case. A factory reset should be a last resort. However, I'm pretty sure a factory reset will remedy the problem.
  9. IOWA

    IOWA Mr. Logic Pants

    For the date/time thing, you can manually set the time to avoid a hard reset

    Tapatalk. Samsung Moment. Yep.
  10. NZtechfreak

    NZtechfreak Android Expert

    None of the reported fixes working here, interestingly it failed from the get go on my brand new Galaxy S, which suggests theres nothing going on with caches...
Similar Threads - Market apps downloading
  1. codezer0
  2. anabeokai
  3. Hadron

Share This Page