1. Are you ready for the Galaxy S20? Here is everything we know so far!

Market Has Perpetually 'Downloading' App - Can't Clear It

Discussion in 'Android Devices' started by johnatthebar, Jun 11, 2010.

  1. johnatthebar

    johnatthebar Member
    Thread Starter

    Yesterday I opened up the Android Market to see if I had any updates. There were several, one of them was ROM Manager. The updates downloaded and installed except for ROM Manager. ROM Manager failed to download. After several attempts throughout the day it eventually downloaded, but didn't go past 100% downloaded, not even attempting (seemingly) an install.

    I tried rebooting, uninstalling ROM Manager, clearing cache, etc. I still have this symptom. I reinstalled ROM Manager from the apk but the constant download attempt persists in the marker. Any ideas? I thought about clearing market data and installing from an apk, but I don't see any reliable looking downloads for the market apk.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. halytech

    halytech Lurker

    I think I would check out the Manage Applications under Applications in Settings. In there, if you hit the Menu button, you can choose Filter. Change Filter to All instead of just Downloads.

    This should provide access to the data stored for the system apps as well as downloaded applications.

    There's one there for Download Manager and Market Updater. I think you can pretty safely Clear Data on those if it's there. Just be careful I guess.

    This came in handy for me when I accidentally attached a file larger than 25mb to a Gmail message I created and my phone got stuck in Sync and I could no longer retrieve new messages from my Gmail inbox. I went in and cleared the data on Gmail and it resync'd and all was good.
     
  3. growler13

    growler13 Member

    I was having the same exact problem with rom manager yesterday. Eventually it just downloaded. The funny thing is, is that I was doing it on 2.1 Cyanogen rom and later was on 2.2 BB rom and had the same problems. I think it might be a problem in the market or specifically rom manager.
     
  4. Branndon

    Branndon Android Enthusiast

    Same problem here too.
     
  5. johnatthebar

    johnatthebar Member
    Thread Starter

    I was thinking about clearing data in the market before and after this thread, but really, if I dont have a reliable way of restoring it (sans reloading the ROM) I'm a bit nervous about trying that.

    Its driving me bonkers, will post if I find a solution.
     
  6. johnatthebar

    johnatthebar Member
    Thread Starter

    tried the patch on droid-life. didnt help :-/
     
  7. Fadelight

    Fadelight Android Expert


    Forgive me for what may seem like a very stupid response, but I noticed on your list of things you have tried, that you were missing the part where you clicked on the application page in market and then selected "cancel" at the bottom of the page?
     
  8. johnatthebar

    johnatthebar Member
    Thread Starter

    Fair response as I never explained that part. If I cancel it FCs and goes to the 'home' market screen. Next time I go to downloads I am right back to the same problem.

    It has downloaded to 100% several times, but never installs, even after an hour.
     
  9. Fadelight

    Fadelight Android Expert


    Hmm. I am at a loss, then. I had the issue with the downloads, but canceling them solved it. Your problem is much different than mine.
     
  10. johnatthebar

    johnatthebar Member
    Thread Starter

    I think the difference is the auto-update feature in 2.2. I can FC, but as soon as it restarts its gonna start that download. Never gives an option to disable auto-update because of the loop its stuck in.
     
  11. UBRocked

    UBRocked VZW Nexus Please!!!

    Okay I have the same issue. I have managed to clear it from the download list (so when I go to downloads it doesn't show ROM Manager downloading). To get to this point, I used AppBrain to uninstall the app. Now my problem is that when I search for ROM Manager and click on it...it still shows that it is downloading (canceling download causes FC for me as well). If I figure it out I will post back.

    Sent from my Droid using Tapatalk
     
  12. UBRocked

    UBRocked VZW Nexus Please!!!

    Okay...think I have the fix.

    - Go into "GTalk" app and log out (this may not be necessary but it is what I did after reading other posts about this problem on different forums)
    - Open Market
    - Go to Downloads section (or just search for ROM manager)...don't click on it
    - Long press on ROM Manager
    - Press "Cancel Install"
    - Bingo...it cancelled the install that way (it was force closing when inside ROM Manager's page on the Market)
    - then click (ie short press) on ROM Manager and click "Install"

    Hope it works for you...pretty simple fix for a problem I spent 2 hours troubleshooting :D
     
    RichP likes this.
  13. johnatthebar

    johnatthebar Member
    Thread Starter

    It's funny (now it is anyways) but this morning I tried that (or so I thought I did, guess I didn't correctly) and didn't get an option for canceling. It was probably something dumb I did.

    It worked this time, problem solved. Finally.

    Thanks a million, that was driving me nuts.
     
  14. UBRocked

    UBRocked VZW Nexus Please!!!

    Haha, NP...glad I found it too cause it was driving me nuts. I saw your first when you first posted it but it's one of those problems that you have to see to fix :rolleyes:. I'm assuming it's a problem with ROM Manager but I've noticed some wacky stuff in the last day or so with the Market. I'll open it and there are 5-6 apps that all say "Starting Download" yet...it's not actually starting. I had to go in and cancel them all and then select install. Everyone worked fine except for ROM Manager...

    I didn't know you could long press on an app in the market until today (didn't know if that was new to Froyo or not :thinking:).
     
  15. Deleted User

    Deleted User Guest

    I had app stuck on installing and killed everything, pulled batt, what ever and nothing worked. Finally went into ATK, but instead of killing app, long press on app and selected Force Stop/Detail and it finally cleared the "installing..." after sitting there for three days!
     
  16. emdmao

    emdmao Android Enthusiast

    Just clear market data and reopen the market. It will prompt you to log back in and everything will be restored. Not a big deal, you'll never lose your paid apps and everything else you have installed will still show.

    Happened to my wifes Droid two days ago when she updated 'not call log'. Couldn't cancel it because it would force close the market and reboots didn't help.
     
  17. nitrochris

    nitrochris Lurker


    This worked for me as well. I had two apps that were showing as 'installing' and I came here to post to find a solution but this thread was already going.
     
  18. Eurosteve

    Eurosteve Android Enthusiast

    I had this problem the other day and the solution was to clear the cache (under market in applications etc). I didn't touch the "clear data" button. No problems since I cleared the cache.
     
  19. SNeitzel

    SNeitzel Android Enthusiast

    Have had this same issue under LFY1.71 as well.
     

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...