1. Download our Official Android App: Forums for Android!

Support Mass Storage Mode Disabled on PC

Discussion in 'Android Devices' started by mosdef1, Jun 3, 2011.

  1. mosdef1

    mosdef1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 3, 2011

    Jun 3, 2011
    3
    0
    5
    Hi

    I have 2 Optimus V phones running 2.2. One stopping giving me the option to go into Mass Storage Mode when I plug it into my pc. It only charges. However when I plug it into my laptop the option to turn on mass storage comes up. Anyone know how I can enable this on PC (assuming it's PC issue)? I assume I must have accidently hit an option to turn removable storage off on the pc somehow.
     

    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,109
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,109
    24,083
    3,118
    Scotland
    Is it possible there's a fault with the USB port on the PC?

    To my knowledge, there are 4 connectors inside a USB socket, 2 are used for data, the other 2 for charging. Maybe the data connectors are faulty/damaged?
     
  3. mosdef1

    mosdef1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 3, 2011

    Jun 3, 2011
    3
    0
    5
    Hey El Presidente. USB port seems fine. I plugged in a friends phone that also has a Optimus V and it went right into Mass Storage Mode. Plugged mine in and it just charges. Can't wrap my brain around this one.
     
  4. JerryScript

    JerryScript Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,212
    Joined:
    Mar 15, 2011

    Mar 15, 2011
    2,212
    2,065
    313
    Las Vegas
    Plug your phone into your PCs USB port, then on your phone go into settings>>applications>>developement>> and check the USB Debugging option. If it is not checked, check it, wait a few seconds, then uncheck it. If it is already checked, uncheck it. Usually when you check or uncheck it, you will be taken to a screen asking if you want to enable USB mass storage, say yes, and a couple of seconds later your PC should recognize your phone as a mass storage device.

    If that doesn't fix it, there may be a problem with your phone's usb port, since you already know it's not the PC's USB port malfunctioning. Try a different cable as well.
     
  5. olbriar

    olbriar  
    Moderator
    Rank:
     #8
    Points:
    2,013
    Posts:
    19,148
    Joined:
    Jun 19, 2010

    Jun 19, 2010
    19,148
    21,062
    2,013
    Male
    Land of Oz
    You might also check your desktop's drivers. You may need to update it's driver base to recognize your phone as a mass storage device.
     
  6. mosdef1

    mosdef1 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jun 3, 2011

    Jun 3, 2011
    3
    0
    5
    thanks for the tips. tried change debugging mode on and off and it still only charges with no usb symbol. added drivers same thing. here the crazy part. i plugged the phone up to my husband's linux laptop and it recognized it immediately and I got the Mass Storage option. Tried it again on windows and it still on charges :(
     
  7. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #2
    Points:
    4,238
    Posts:
    38,129
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    38,129
    37,468
    4,238
    Male
    IT
    Pennsylvania
    Give this a go ... open up device manager on the windows machine (right click on my computer and select manage and open device manager). Plug in your phone and see if anything changes. What you are looking for is yellow triangles. Remove that device and then unplug your phone and replug it. You might reboot your computer between unplugging and replugging just to make sure there's nothing cached.
     
Tags:

Share This Page

Loading...