1. Are you ready for the Galaxy S20? Here is everything we know so far!

meep wont boot

Discussion in 'Android Devices' started by davidss1, Oct 24, 2013.

  1. davidss1

    davidss1 Lurker
    Thread Starter

    my son was given meep by his grandmother 1 week ago and it is stuck in the booting logo . it was purchased in australia and my son is in thailand , so it will be basically impossible to send it back to the store of purchase etc.
    i have tried rebooting/reset many times
    efforts to contact the company through email have not been responded to.

    has anyone been able to reflash the OS or transform it to accept a normal android OS?

    thanks in advance

    1. Download the Forums for Android™ app!


  2. MeepTablet

    MeepTablet Member

    Hi Dave!

    I'm sorry for the delay in response. There are two things you can try for the stuck-loading issue, which are reboot and reset. I know you have tried both, but sometimes it works to try each method several times in a row. If you still are stuck, then this is considered a hardware issue and there is no known remedy. The company does not have advice on your last point about the operating system nor do I know anyone who has tried it on their own. My best suggestion is to continue to contact OSI. I'm not sure which email you are trying, but you might want to try the following:

    1300 300 155
    Email (AUS and NZL):

    Technical Support - Oregon Scientific

    The contacts I have for Asia are for distributors, but they may also be able to assist in your region:
    Oregon Scientific - Smart Living

    Lastly, you can always contact the USA center and tell them where you are located and they can then perhaps provide you with a contact:

    One other thought... outside of the USA in most cases all issues go back through the retailer, so you may have the best success contacting the store where you purchased it and going through them.


Share This Page