1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Merit] [ROOT] update.zip [ROOT]

Discussion in 'Android Devices' started by stayboogy, Jan 13, 2013.

  1. stayboogy

    stayboogy Android Expert
    Thread Starter



    everyone enjoy.

    the best, easiest, most efficient way to root your device.


    install from stock recovery

    Code (Text):
    2. 1. copy to root of sdcard
    4. 2. reboot into recovery
    6. 3. scroll to your second option--"wipe data:factory reset" and press the back key (no data will be wiped but the update will be installed and you will be rooted)
    8. 4. reboot device and install superuser or equivalent

    jcase--without him none of this would have been possible



  2. mechgt5

    mechgt5 Lurker

    i tried this, stock recovery... said it was installing, rebooted and nothing different
  3. stayboogy

    stayboogy Android Expert
    Thread Starter

    it doesn't do anything but root the phone. the phone won't be any different.

    you have to install superuser from the market to be able to do anything with root permissions.

    and aside from that, i have all three versions of the phone and I KNOW it works on each model. it's been working on each model for longer than you've seen it here on the boards....

    so i suggest you try again...
  4. kingmt

    kingmt Android Enthusiast

    Glad to see you back to posting files. Keep up the good work.
  5. jarito

    jarito Lurker

    Got it thanks, I connected the phone to the computer but cant find the folder with root data I' running windows 7
  6. kingmt

    kingmt Android Enthusiast

    I assume your taking about the root of the SD. If so that just means not in any folder.

    If you mean root of the phone. You can but not just with file explorer.
  7. bmoyer1

    bmoyer1 Lurker

    so after I root the phone, I am still having the low storage issues, but it says it is rooted, how do I get other apps on here or what apps should I be getting rid of and how? Is there another thread I should be looking at for cleaning up the phone after the root. I tried to download titanium back up but my phone doesn't have room for it.
  8. mtnvortex

    mtnvortex Lurker

    Hey stayboogy, thanks a lot for this post. I tried this on my Straight Talk Merit, and it worked perfectly. You really cleared up the whole process of how root is accomplished on this phone...especially with the video. This is the first phone that I ever rooted, and after following your directions, I feel stupid for thinking this was somehow complicated before. Thanks.

  9. mtnvortex

    mtnvortex Lurker

    I did notice an issue, after rooting with this method. My WIFI will not stay connected to my home network. It seems as if the phone is in a perpetual state of scanning/connecting/disconnecting/scanning... Do you have any idea why this might be happening?

  10. Motorhead1991

    Motorhead1991 Android Expert

    Being one of the first decs for this phone, I've been here throughout it's history. It used to be a process to root the Merit, involving adb.

    Lemme write up a quick history lesson:
    - When the Avail came out, it started with an adb method, which we later found out wasn't needed. ZTE, as we discovered, left a hole in the programming, allowing rooters to input a code, then update the binary from Superuser. AT&T later patched that up.

    - The Merit came out about 6 months later with 2.3.5 firmware, disabling any current root methods, so it was back to adb. Since then, both phones have recieved alot of attention, with files like this.
    mtnvortex likes this.
  11. mtnvortex

    mtnvortex Lurker

    Ah, I see. So it is still a bit of a process, it's just that "loophole" being discovered that let everyone take this shortcut. The process of inserting this update file was quite easy, but it has left me with a few problems that I'm not sure how to solve. I've been searching the internet all night for a solution.
  12. stayboogy

    stayboogy Android Expert
    Thread Starter

    this file doesn't cause problems :hmmmm2:

    it does exactly what it's suppose to and nothing less or more.

    pm me with what you are having issues with.

    aside from that, without jcase's root method i would not have been able to root and figure out how to bypass all that junk in first place.

    this isn't a loophole at all. it's just freakin genius lol. the phone allows updates, meaning anything can be installed with an update. why not su? PROPER EDIFY SCRIPTING is what makes it GUARANTEED

    not to mention leaving USELESS busybox aside...
  13. mtnvortex

    mtnvortex Lurker

    No, I wasn't trying to say it's the file's fault, just that something happened after I installed it. I mean, maybe the file didn't jive with something I already had on the phone. I'm not sure. I do appreciate your instructions. They were very clear, and worked very smoothly. I sent you a PM to ask about the issue I'm having. Maybe you'll know what's up. You guys seem to have a lot of knowledge here on this forum, and it's much appreciated. Thank you.
  14. Motorhead1991

    Motorhead1991 Android Expert

    Only if your signing can pass verification :p. I signed an update with dsixda's kitchen and it died.
  15. mtnvortex

    mtnvortex Lurker

    Ok, so I went into build.prop using Rom Toolbox, and I changed (init.svc.wpa_supplicant) from "running" to "stopped". That seems to have fixed my wifi connection issue that I had after updating. Go figure.


    UPDATE: It is now running again, but the problem has stopped. ???
  16. dlsc2111

    dlsc2111 Lurker

    I can't get into stock recovery!!! HELP!!! Unsuccessful. The package is corrupt.

    That is what I get when I try to boot into stock recovery, anyway to repair this so I can gain root?
  17. stayboogy

    stayboogy Android Expert
    Thread Starter

    none of what you have typed makes any sense.

    the package is fine and will install just fine. there's even a video to prove it.

    which is it? you can't boot into recovery?


    you can't install the package?

    if you can't explain clearly what's going on, i'm not going to waste my time trying to help
    EnlightenedSha likes this.
  18. foiled

    foiled Lurker

    It mean when 'signature cannot be verified/package is invalid'?
  19. kingmt

    kingmt Android Enthusiast

    You guys really do need to give us more information. If we can't understand you then we can't help you.
    stayboogy likes this.
  20. out of ideas

    out of ideas Android Enthusiast

    probably a bad download. Try again.
  21. stayboogy

    stayboogy Android Expert
    Thread Starter

    clearly it passes verification--video shows it all

    which means

    (like out of ideas has said) bad download


    user error

    those are the only two reasons for error with this file that are plausible...
  22. nightstar1975

    nightstar1975 Lurker

    I have downloaded update.zip. And I have moved it to my sd card root. Then I have power my phone off. And I start in recovery mode. I go down to wipe factory data. And when I get to that part and it starts the installation of the update.zip.It gives me an error message saying signature verification failed installation aborted. So I went in and deleted update.zip and I have to redownload it. And went back through the process 7 or 8 times. And everytime I do it keeps giving me the error message saying signature verification failed installation abort please help with this problem. I have superuser, root checker, and clock work mod on my phone.
  23. stayboogy

    stayboogy Android Expert
    Thread Starter

    don't know what to tell you--something on your end is wrong, not mine. i've proved this OVER AND OVER AND OVER AND OVER AGAIN

    the update is signed, and signed properly, and installs properly on stock recovery

    watch the video--there's the proof

    and you obviously don't have clockworkmod on your phone or you wouldn't be trying to install this on stock recovery
  24. nightstar1975

    nightstar1975 Lurker

    well I just did a factory reset. And now it is not letting me download the file.
  25. redfield88

    redfield88 Well-Known Member

    Don't download the file by phone, do it via a PC. Not sure if you're doing it that way, but it's the most common cause for error messages while installing .zip files. The phones default down loader sucks balls, pure and simple.

ZTE Merit


Share This Page