1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Merit] zte merit root cwm rom no pc needed for root

Discussion in 'Android Devices' started by napalm6283, Jan 1, 2013.

  1. napalm6283

    napalm6283 Newbie
    Thread Starter

    I am not responsible for any problems that you may encounter with this method.
    Please understand this is at your own risk. i did not write any of the files i just hunted them down, was tired of my merit being plain jane.

    clockwork mod is a recovery program that has a few more options than factory recovery.

    This is a proven method of rooting the zte merit z990g
    from straighttalk with no pc. All from the handset. It is proven to work
    on many of these android phones.Below will be links to all files that you
    will need to dL for this task. I will also attach a deodexed stock merit rom.
    I recommend using this big time. Before doing anything enable usb debugging, and
    Unknown sources in development. settings/applications/development

    What you want to do is download the update.zip and store it to the root of the sdcard.
    this file location should read sdcard/update.zip. this will give you a nonroot version of
    cwm6.0.3.5. how to load up cwm you hold power, volume up, and menu button(3 slashes)
    until the factory recovery starts about 10-15 seconds. using the volume down go to
    the wipe/factory reset and press the back button (to the right of the home button)
    soon you will notice cwm popin up. go to install zip from sdcard using the vulume up
    and/or down and to select with the power button. install the file down below that will
    root the z990g. after install is successful reboot the phone. if superuser is not
    in the app drawer then go to play store and download it. i am using superuser3.1.3 i believe. i do not know if supersu works with this method. superuser has been successful 100% of the time.

    The recovery.img is for the full root verion of cwm. This you will need a pc to do.
    connect the merit to pc with drivers installed. Mine installed off of the phone.
    DO NOT ENABLE USB MODE. open cmd prompt on pc. i have done this on xp and win7 pc's.
    no propblems on either. in the cmd prompt box type the following without quotations.

    "adb shell"


    "flash_image recovery/sdcard/recovery.img"

    "reboot recovery"

    after all of this you should be able to boot straight to cwm without the use
    for the update.zip method. if the phone does not automatically reboot it should be
    fine. i had one that didnt, and one that did. just reboot it yourself.

    Go ahead and make 2 backups of your rom now. go into cwm, using the volume to navigate
    and power to select.

    now if you want to go ahead and install deodexed rom to save space and make apps
    less dependent on each other. i did this using a pc. simply download deodexed zip file
    down below. using pc unzip the file to desktop.phone may be connected to pc and be
    in usb mode. once the file is on the desktop you will need to highlight the folder.do
    not put the folder in the backup file, only the contents. you can copy them to the
    backup folder of clockworkmod folder located on the root of the sdcard. delete the contents of one of the backup folders.
    place the unzipped contents into the hollow backup folder.

    the name of the folder will be a date and time in
    24 hr format. you may rename the file too. that way they are easier to locate. do this
    by single clicking the folder while you are in the backup folder. or right clicking and
    renaming. after the contents are all in the folder you just named it should be in this
    location. sdcard/clockworkmod/backup/***the name u made*** now disable usd mode when
    the file is setup. shut off the phone and restart into cwm. wipe data/factory rest,
    wipe cache, and in the advanced menu clear dalviche cache. now go into the backup and
    restore and restore the file you named. after it is done reboot the device. you will
    now be completely out of the box new. you wont notice much to change except that you do
    not have a odex of each app taking up space on your already limited storage.
    just download superuser from play store and it should still be rooted. if not just
    go back into cwm and run the root zip again.

    now i will have another rom download link to a deodexed clean rom. bloatware removed
    (orkut, docs to go, etc) it also has a ics feel to it. its not the best but it seems to
    be liked by most of my friends with the device. i do not know if this will work for the
    AT&T Avail. just because of the os diference. if it does work for someone with an Avail
    plz let me know. Thank You Hope i have helped all of you that were needing this info.
    to delete bloarware- after root download
    root explorer lite. it is the black folder with
    the android guy on it. this is the best file explorer in my opinion. now go into the
    system folder and the app folder should be the one at the very top. open it. these are all your apps. most of the bloat apps can be deleted without problems. if for some reason a message pops up saying force close. simply get the phone to shut off. between force closes hold the power button letting the power options menu to pop up. then press power off. after it shuts down power back on.. it will be running fine. to delete the apps long press the app u want to delete. when the options menu pops up select delete. press ok. then the app is history. if ur rom is odex u may delete the odex file as well. DO NOT DELETE EMAIL APP. it is tied to ur camera somehow. if it is removed ur camera will not work. these are all my tips and tricks to the straighttalk zte merit z990g. good luck and let me know about any fails or successes plz.

    MegaCloud - nate wilson wants to share a file with you root link

    MegaCloud - nate wilson wants to share a file with you update.zip link

    MegaCloud - nate wilson wants to share a file with you recovery.img link

    deodexed rom link

    Best easy root zte merit, cwm download

  2. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Do you happen to have links to where those files originated?

    Welcome to the forums! :)
  3. Rush

    Rush {<>}~{<>}

    Welcome aboard.

    Happy New Year! :santaclaus:
  4. napalm6283

    napalm6283 Newbie
    Thread Starter

    i downloaded them from 4shared originally i believe to my merit
  5. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Sorry, I was wondering if you had links to whichever dev came up with those. ;) :)
    Rxpert83 likes this.
  6. napalm6283

    napalm6283 Newbie
    Thread Starter

    did you get to try this method possibly??
  7. napalm6283

    napalm6283 Newbie
    Thread Starter

    i have no problem giving cred to the people responsible for making these files. i just want to make it easier for ppl looking for this info to find it. it took me a while to finally get all this info together. i just wanna help others with it
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Yeah, not questioning your integrity, but giving credit is good form and a standard practice, that's what I'm looking for. :)
    Rxpert83 likes this.
  9. napalm6283

    napalm6283 Newbie
    Thread Starter

    I may just be a noob.. but i have been studying and prolly downloaded 600 different zip files begore i got some that worked. They have been modded by myself also.. just a lil.
    EarlyMon likes this.
  10. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

  11. stayboogy

    stayboogy Android Expert

    this method of rooting is just taking an su update.zip file from the developers of superuser and trying to use it to get root.

    the problem is that it will work sometimes, and then other times it will not work, simply because the edify scripting is incorrect in the updater-script

    this isn't a fool-proof root method so to speak.
    EarlyMon likes this.
  12. napalm6283

    napalm6283 Newbie
    Thread Starter

    This has worked everytime i have tried it with multiple merit phones. I wouldnt have posted it if it was a 50 50 shot of root..
  13. stayboogy

    stayboogy Android Expert

    i realize this.

    i'm just telling you from experience that it is not a 100% guaranteed every time to work to gain root. the att avail will reject the root 50% of the time with the edify scripting errors that are present in updater-script. some models of the merit will do the same although they are rarer.

    it was after many rewrites that i finally fixed the scripting errors that cause this to happen.
  14. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!!

    Hello napalm, I'm afraid I can't help you, but I humbly welcome you to our forums. :)
  15. napalm6283

    napalm6283 Newbie
    Thread Starter

    I didnt say it was for the avail. I said u could try it. this is a merit root. And cwwilsons recovery img is the one that u wanna dL it thanks cw. Its good prime dont need it
    Scarsketch likes this.
  16. napalm6283

    napalm6283 Newbie
    Thread Starter

    If anyone needs help with anything involving the above post, plz dont hesitate to pm me and i will walk u through it personally. Thank u for ur time. And i apologize for thr typos.. i wrote it all on my merit in notepad.lol
  17. kingmt

    kingmt Android Enthusiast

    Just found out there is two threads with the same thing. Instead of posting twice here is the other thread: androidforums.com/merit-all-things-root/670553-best-root-method-zte-merit-z990g-no-pc-needed-tell-your-friends.html

    If you want to update it with my suggestions your welcome to.
  18. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Had you read the last post in the other thread, and I strongly recommend that you do, and the one a few above yours here, you'd find this thread is here because I moved it in, and the other is locked for a reason.
  19. kingmt

    kingmt Android Enthusiast

    Sorry to link twice. I didn't reread the thread to know it had been edited. I'm not bickering. I only added info I thought was helpful & PMed the OP last night since it looked like he took it that way.
  20. napalm6283

    napalm6283 Newbie
    Thread Starter

    foxfi is the shiz.. finally found a wifi hotspot app that works. lol
  21. napalm6283

    napalm6283 Newbie
    Thread Starter

    if this thread is helpful in anyway plz let me know.. if something isnt working or if it worked extremely well could you plz post or pm me plz.. thanks
    SquidlyMcNerd likes this.
  22. AzurePanda

    AzurePanda Lurker

    This worked perfectly. I had only ever attempted to Root a phone once before, and I had bricked it. This was simple and easy. Napalm even walked me through it on the phone. He is a great guy and this process is simple and easy as hell! I super recomend it to everyone that has a Merit.
    xer0615 likes this.
  23. xer0615

    xer0615 Newbie

    Edit - Disregard I r teh newb
    So, I am attempting this method of root because of my handsets issue with USB connectivity-- simply put, I cannot enter usb mode-- it charges via usb but will not allow data transfer or anything of the sort-- my computer simply does not seem to recognize it.

    Anyway back to the issue

    I have downloaded both the root.zip, and update.zip, and stored them to the root directory of my sd card. I put the sd card back into the phone, mounted it.. and now the phone is on and I am attempting to start the recovery, by holding the Power+Volume Up+Menu key and it is doing nothing whatsoever.. After a few seconds the options to enter airplane mode, silent mode, or power down comes up,, and at one point it beeped at me, then vibrated but I'm fairly certain that's because the volume got changed..

    So please, what am I doing wrong? I am pressing the combination of buttons at the exact same time, and the phone is powered on while trying attempting this.. Is that incorrect procedure?
  24. xer0615

    xer0615 Newbie

    I have tried the same process again, however choosing the root.zip to install this time.. and According to rootchecker I do indeed have root access!

    Thank you very much for this simple process =)

    Might I make 1 reccomendation, however? Your original post, the instructions are not quite clear.. One thing in particular threw me off...

    "go to install zip from sdcard using the vulume up
    and/or down and to select with the power button. install the file down below that will
    root the z990g"

    By default it wants to install from the Update.zip, which I realized after reading three or four times.. that was the incorrect procedure, But maybe you should specify the file name rather than saying "the file that will root" etc.. But hey that's just one newbs opinion. Anyway, Thanks again for this process!

ZTE Merit Forum

Features and specs are not yet known.

Release Date

Share This Page