1. Check out our companion app, Forums for Android! Download from Google Play

Support Message counter shows wrong value.

Discussion in 'Android Devices' started by dmantamp, Jan 11, 2013.

  1. dmantamp

    dmantamp New Member
    Thread Starter
    5

    Oct 28, 2012
    3
    0
    5
    Hi all,
    On my S3, the message icon always shows there are two message( number 2 at the top right side of message icon). I don't have any unread message. Even if get messages the number does not increase. I tested this by sending three SMS from a different phone and I recived them. But the icon still shows 2. I installed an application that was telling it can reset the count. But it didn't work.

    Any help ?


    Thanks
    DM
     

    Advertisement

  2. SUroot

    SUroot Well-Known Member
    1,123

    May 25, 2010
    23,925
    5,304
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Are you rooted?
     
  3. dmantamp

    dmantamp New Member
    Thread Starter
    5

    Oct 28, 2012
    3
    0
    5
    No. I have not rooted. I have upgraded to JB sometime back,
     
  4. Shotgun84

    Shotgun84 Well-Known Member
    313

    May 30, 2011
    5,322
    3,108
    313
    Whatever he said.
    Cambridgeshire, England
    Welcome to the forum.

    I'm not sure if this fix is permanent but go to settings, application manager, all, BadgeProvider and clear data.

    I've moved this to the main gs3 forum. Maybe someone else will have some other ideas:)
     
  5. dmantamp

    dmantamp New Member
    Thread Starter
    5

    Oct 28, 2012
    3
    0
    5
    Thanks a lot. It worked.
     
  6. Perrorist

    Perrorist Member
    15

    Apr 14, 2014
    15
    0
    15
    Male
    Writer, software developer
    Central Coast, Australia
    I have a similar problem to the OP. In my case, it shows -1 when there are no mails. Whatever number is shown, there's always one more mail to read.

    I've tried the BadgeProvider clear data approach and it hasn't helped.

    I've recently updated to 4.3 but the problem remains.
     

Share This Page

Loading...