1. Are you ready for the Galaxy S20? Here is everything we know so far!

Messed up going back to stock...

Discussion in 'Android Devices' started by Luke Robinette, Jan 15, 2016.

  1. Luke Robinette

    Thread Starter

    I went from carbon back to stock... flashed restore(to let me go back to stock), Recovery, and ROM... Now I don't have twrp and no OS... Only stock recovery and i can't mount or install anything, GApps worked though... I get an error:
    ----------------------------------------------------------
    --Install /sdcard----
    Finding update------
    opening update-----
    Verifying update----- ( All good so far)
    E: footer[2]=0x17 footer[3]=0x10
    E:signature verification failed
    Package corrupt
    Installation aborted
    -----------------------------------------------------------
    I am 98% sure i did everything right... But i must have screwed up somewhere... I'm not noob but I'm not a developer either... Just a happy little script baby...
    I have tried several roms and a couple kernals... Nothing is writing...
    I have ADB suite i just don't know what i need to do to get it to work right...
    Thanks for any help....
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Masterchief87

    Masterchief87 Android Expert

    What EXACTLY did you do and in what EXACT order?
     
  3. Luke Robinette

    Thread Starter

    changed from rooted stock to Carbon Mod... To go back to Stock I wiped, then applied first the recovery(old NanDroid), then the rom found here ( https://www.androidfilehost.com/?w=files&flid=32973 )... I was told by someone that this was the stock rom and just wipe and apply like normal... I can get to the stock Recovery and it reads-
    -------------------------------------------------
    Android system recovery <3e>
    Z970_MetroPCSV1.0.0B13
    -------------------------------------------------
    This is the same version i had when it was new (B13)...
    I can't turn it off but i can restart it and see everything availible through stock recovery(sdcard,Cashe,Sideload, wipe part., wipe data/factory reset, and restart)... Restarting it just boot loops twice then goes to recovery... In adb I am getting a closed reply to pushing updates but i don't know what i am doing with adb so I may have gotten some commands mixed when trying to push updates...
     
    #3 Luke Robinette, Jan 16, 2016
    Last edited: Jan 16, 2016
  4. Masterchief87

    Masterchief87 Android Expert

    I'll give you an example of what I meant.

    When I got my last zmax(I've had a few) this is what I did.

    (To get root on the stock ROM)
    1 download kingroot SuperSU and zmax twrp app
    2 install kingroot and zmax twrp app
    3 run kingroot until temp root is acquired
    4 open zmax twrp app and install twrp custom recovery
    5 uninstall kingroot and reboot to twrp recovery
    6 flash SuperSU through twrp and then reboot system.

    (To get system r/w so I could uninstall bloatware, install xposed...)
    1 download switcher and restore zips for the stock ROM
    2 reboot to twrp and flash the switcher zip, then reboot recovery(which from then on would boot me into android instead of twrp)(doing a normal reeboot would then boot me into twrp instead of android)
    3 do whatever system modifications I wanted to

    (To flash a custom ROM after using a switcher)
    1 download the ROM & GApps
    2 reboot system(which would take me to twrp because I was using a switcher)
    3 Flash the restore zip
    4 reboot recovery(crucial step that can't be skipped)
    5 flash ROM & GApps
    6 reboot system
    (Using switchers with custom ROM is the same procedure as already described above)

    (To go back to stock after using a custom ROM with a switcher)
    1 Download stock rom
    2 reboot system(which would take me to twrp because I was using a switcher)
    3 flash the restore zip
    4 reboot recovery(crucial step that can't be skipped)
    5 flash the stock rom and reboot system
    6 test to make sure everything works properly
    7 reboot to twrp manually by shutting off the phone and holding power & volume down
    8 Lastly, flash the stock recovery
     
  5. Masterchief87

    Masterchief87 Android Expert

    Looks like your fatal error is that you didn't reboot recovery after flashing the restore zip but before flashing the stock ROM(I explain the correct order in which to do everything in the post above as well as on my threads for the stock ROMs and switchers). Also, you flashed the stock ROM and the stock recovery at the same time instead of following the installation instructions. Because of this you bricked your phone and removed twrp(probably the only way to fix your phone) at the same time.
     
  6. Masterchief87

    Masterchief87 Android Expert

    There is one hope for fixing your phone(the stock recovery is completely useless for fixing your problem)

    1 Press and hold power and volume up to boot into ftm mode
    2 Connect your phone to your PC
    3 Open a terminal or command prompt
    4 Type this command
    5 then
    6 if you get a prompt saying root@draconis# your problem can be fixed as long as you don't do anything else with the phone until receiving further instructions. If you don't get that root@draconis# prompt then your phone is toast.
     
  7. Luke Robinette

    Thread Starter

    assuming that it is fried... Any attempts to sideload a restore image returns could not read... I will check in later and see if you have answered... thank you for your time...
     
  8. Luke Robinette

    Thread Starter

    upload_2016-1-21_18-14-47.png running adb sideload returns closed error...
    I have no mount in ID...
     
  9. Luke Robinette

    Thread Starter

    I can run the following... I saw someone post that if no error pops up run this script... I have not run it but it appears that i have access to root if i can write to cashe... Sorry for spamming... upload_2016-1-21_19-13-18.png
     
  10. Masterchief87

    Masterchief87 Android Expert

    The only way to fix your phone is to get root in adb shell and use it to flash twrp, then use twrp to correctly flash a ROM. Adb sideload won't work because the stock recovery can only install zips signed by zte with their private key. I couldn't read the second and third screenshots you posted but in the first one I could see that while you do have access to adb shell, you do not have root access.
    Sorry but there is nothing I can do at this point.
     
  11. Luke Robinette

    Thread Starter

ZTE Zmax Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...