1. Are you ready for the Galaxy S20? Here is everything we know so far!

Messed up

Discussion in 'Android Devices' started by justinyun2748, Oct 23, 2010.

  1. justinyun2748

    justinyun2748 Newbie
    Thread Starter

    I messed up with root for my sf... it turns on normally but it just keeps making me force quit twlauncher, and bunch of stuff so I have no access to my phone... how do I fix this???

    1. Download the Forums for Android™ app!


  2. nitsuj17

    nitsuj17 Android Expert

    sounds like you hit the force close hell a lot of us have had. Did this happen the with the auto-reboot by the root program, or the next time you manually rebooted?
  3. justinyun2748

    justinyun2748 Newbie
    Thread Starter

    I tried to disable lag fix, and install d12 something, and I dont know what happened... is there a way to reset the whole thing?
  4. nitsuj17

    nitsuj17 Android Expert

    give me the step by step on when it first happened. it sounds like it was a voodoo issue not root
  5. nitsuj17

    nitsuj17 Android Expert

    well i gotta go, hope you get it worked out or someone else here can help you!
  6. saps

    saps Extreme Android User

    Yes you can restore to stock if you need to. A more detailed account of exactly what you did and where you are right now is vital for diagnosing your problems. Restoring a voodoo bork might not even be needed in your case, cannot tell based on above info and certainly we dont wanna guide you thru a process you may not need
  7. justinyun2748

    justinyun2748 Newbie
    Thread Starter

    So basically, I wanted to disable lagfix, and install a different voodoo... after I did that It got messed up so I got this uninstall.zip thing to uninstall everything, and now whenever I turn on my phone, it just says twlauncher needs to force quit, and android process needs to force quit, and stuf
  8. nitsuj17

    nitsuj17 Android Expert

    the uninstall voodoo.zip is like a 50/50 success rate. To really insure you remove voodoo before odin back to stock you need to do the full uninstall using adb.

    [How to] Completely Remove Voodoo Lagfix - xda-developers
  9. justinyun2748

    justinyun2748 Newbie
    Thread Starter

    I just went to verizon, and got a complete new phone... i dont know if I shud root it or not now haha
  10. nitsuj17

    nitsuj17 Android Expert

    Given what appeared wrong with ur phone it didn't seem neccesary to exchange it...,.it wasnt a total brick by any means. Did u at least remove all traces of cwr and odin back to stock before exchanging?

    If not there exists the chance (however small) that they pick up that it was a modded device. Its best to never try and return something that can be recovered.

    Returning devices only lends support to companies wanting to lockdown their devices more to stop bricking.

    I'm glad u have a working phone now but u might be better off taking a step back and relaxing before trying to voodoo again
  11. Konos

    Konos Member

    I don't mean to take over this thread but I find myself in a similar situation
    except I arrived here after trying to mod the framework_res.apk in order to get the circle battery percentage indicator.

    I mistakenly renamed and moved the original framework_res.apk with the hopes to just replace it with the new framework... well as soon as I moved the original, it froze and I couldn't replace it with the new .apk so I rebooted

    For a while I couldn't past the boot up screen so I tried the
    "wipe data/factory reset, wipe cache partition" options, of course with no luck. THEN I used Odin to

    1. flash the Clockworkmod
    2. installed a new framework_res.apk from a .zip found on a thread the battery indicator mod for the SF

    Now I can get past boot screen, up the lock screen it's fine. However once unlocked its going into the multiple Fore close screens "com.android phone has stopped....TwLauncher(process.com.sec.android.apptwlauncher) has stopped...etc. etc.

    I'm trying to figure out how I should proceed from here. ANY ideas...


    UPDATE: I tried all the fixes in this link
    Odin Restore files to get you to stock - xda-developers
    was still getting forced closes. Then I wiped the stock recovery cache. (Thanks to GoBruins for that one)
    After that it was still giving me FCs but to a lesser degree and I was able to make it into the "Settings menu" and do a factory reset.
  12. saps

    saps Extreme Android User

    Keep the updates coming. Hard to tell if you are golden again yet or not. Sounds like you're getting the hang of it
  13. nitsuj17

    nitsuj17 Android Expert

    so after the factory reset are you good to go then?
  14. Konos

    Konos Member

    Update 2:

    Ok so I've had time to play around with my SF post "Force Close" hell and reflashing back to stock. All day today at work it's been pretty solid.

    No real issues except I noticed my GPS took Extremely long to acquire position. Now I know many people have complained about this issue, including myself to some extent but NOT this long. It was taking like 5mins, so i finally gave up and d/l GPS STATUS from the market. Ran it (it took <1min) and then re-ran Navigator, and didn't seem to have any new issues.

    Otherwise I got off work early so I was able to
    1. RE-Root via one click root.
    2. Reflashed CWM
    3. Backed up Nandroid this time :eek:
    4. Changed battery indicator to Circle battery indicator (worked this time!)
    5. Flashed Dirrk's Voodo LV1200 kernal.
    6 Installed Set CPU and have been running at 1200 (conservative)

    I had a brief issue right after installing SET CPU where my phone wouldn't wake up from sleep (all i got was a black screen). Did battery pull and haven't been bothered by that since.

    All afternoon its been pretty solid. I notice that my battery has discharged somewhat earlier than usual (which is counter to what I'd expect)...BUT i chalked this up to keeping my screen on for much longer than usual. to re-download apps, mess with settings, etc. and making several more phone calls than I usually do. [BTW: I really can't believe just how much making calls drains the batt...is there a "fix" for this? I thought the complaints were that our antennas were actually underpowered?]

    So far I think things are looking like they're back to normal with my phone. I'll post anything unusual that might come up.
    saps likes this.
  15. saps

    saps Extreme Android User

    Good stuff Konos. Whenever someones shares their problems and solutions its a great benefit to us all. Also realize for every registered member who may have already gone thru this same thing there is someone unregistered and lurking who found your post on a google search.
    Phone calls should drain the battery about 1% every 3-4 minutes. So yeah a 20 minute call should drain you 5-7%. If you are on BT it will be slightly higher. Phone is rated for 7 hours of talk time but as always YMMV
  16. Cenabite

    Cenabite Lurker

    Hella, i am a COMPLETE droid noob and the same thing happened to me after trying to install 2.2.1 and now i cant access my phone at all just force close force close.. I have the new epic and it means sooo much to me to have it working... Will anyone help me?
  17. nitsuj17

    nitsuj17 Android Expert

    ya might want to head over the samsung epic forums...as we dont have that phone ;)
  18. KrysD

    KrysD Lurker

    (Samsung Galaxy Y) I'm having the same problem. My phone is rooted as well (Withh ChainsDD's version). I was installing a font using root font installer and when it ask me to reboot the system, i did. After rebooted the phone, the twlauncher started giving me the same problems. Can anyone help please?

Samsung Fascinate Forum

The Samsung Fascinate release date was Q3 2010. Features and Specs include a 4.0" inch screen, 5MP camera, GB RAM, Hummingbird processor, and 1500mAh battery.

Q3 2010
Release Date

Share This Page